abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Zen V (http://www.anythingbutipod.com/forum/forumdisplay.php?f=38)
-   -   Zen V Plus Screen Problems (http://www.anythingbutipod.com/forum/showthread.php?t=20674)

The Few 12-15-2006 10:18 PM

Broken Screen!!
 
I placed my Zen in my car's storage compartment and accidentally broke the screen. It still plays, but, the screen is hosed. What can I do? Can I repair it? Where do I get parts? Creative wants $140 parts and labor! Help!!

Brodey 12-16-2006 04:22 PM

If creative wants 140$ that's as much as the player itself or more!

kidmullet 01-05-2007 11:26 PM

Zen V Plus Screen Problems
 
yea i was just wondering y my screen keeps getttin darker like i was at school and i was lisenting to it and in the corner it was really dark there then i turned it off then after school i turned it on and i can bearly read the letters across the screen can some body help me about this???

Steeev 01-06-2007 05:07 PM

STUPID QUESTION ALERT!!!

Is it charged up? :D

bionicslim 01-06-2007 08:35 PM

My screen broke. i need help
 
I just got my Zen V. Then a week later, it froze up. I didnt have time to look up info on what was wrong with it, and i made the mistake of taking it apart. now my screen doesnt work. Can someone link me to a help page on how to reassemble it?

alt-master 01-19-2007 02:40 PM

the question is not stupid anyway:)

unfortunately I have the same problem.
actually, this definetely refers to physical breakage/defect, therefore it should be taken to creative and fixed there.

however maybe someone else has experienced such problem? have you found any solution?

alt-master 01-19-2007 02:44 PM

maybe you should look there
http://www.anythingbutipod.com/forum...ead.php?t=7095

ZenChick 01-19-2007 03:14 PM

This sounds like the backlight failing to me. There's no solution for that.

emar5 01-20-2007 01:56 AM

maybe the OLED pixels died or something. my player had a distinct vertical blue line on the left side of the screen, at first it disappears and re-appears every now and then, after a while it didn't go away anymore. i returned it to the store where i bought it to have it replaced. they said that they have to send it to their tech guys to check the problem. its been a week already, but the sales clerk said that they sent the player to the distributor cause they don't know how to fix it. hopefully i just get a new player.

Chensington 01-22-2007 04:40 PM

Quote:

Originally Posted by ZenChick (Post 57623)
This sounds like the backlight failing to me. There's no solution for that.

If I'm not mistaken, the Zen V/Zen V Plus has an OLED screen, and OLED screens do not require backlighting, since they emit their own light. :cool:

Anyways, OLED screens are pretty sketchy, are known to have a far shorter lifespan than LCD screens, not to mention that certain pixels can wind up dying before others, and this is mainly due to the sensitivity of the organic materials uses in such screens.

Assuming that you haven't had the player for very long, however, this shouldn't be your problem. It's probably just physical abuse, maybe a defective battery or screen (judging by the fact that it's an OLED screen, it may be the latter). However, you should give us a little more information in order to receive a proper diagnosis.:)

Kie 03-18-2007 07:06 PM

Broken Screen
 
My Creative Screen doesn't work after the player got squashed. Externally it is fine but the warranty is up. Is there any way I could fix this myself, and is it worth taking into a repair shop or would they not be able to fix it.

SalamandoX 03-19-2007 03:30 AM

I wouldn't be worth it. Just get a new one. Taking it apart is risky and taking it to repair would cost more in the long run.

tambu 04-26-2007 12:26 PM

Problem with screen
 
Hello, i got my Zen V+ back from warranty about week ago. (froze and didnt start up on 3rd day, firmware was latest). Yesterday i saw that white color is being drawn to the upper and lower edge of the screen (there is also in the right place, just lighter). Today the screen is very dark, at the first place i tought it didnt start up. Brightness is at 100%, got latest firmware and im kind of annoyed about it. Second problem with only like week after ordering.

ZenChick 04-26-2007 01:38 PM

Call them back up and send it back!

I'm sorry this is happening to you. Sometimes these things happen - it doesn't matter what kind of device it is or who made it. I once had a computer - a Commodore 64 - that I had to have fixed three times before I finally gave up and fixed it myself.

I don't suggest that extreme, though. You player is under warranty, and they are responsible for giving you back a fully-functioning player when doing warranty work. Hold them to that, and don't give up! :)

tambu 04-27-2007 06:06 AM

Thanks. The reason why i didn't send it right away was because there is no warranty in my city. have to send to other city and when i keep sending it many times, i lose money for their mistake. If it breaks 3rd time i call to consumer protection. :mad:

RAPCAT 06-30-2007 03:14 PM

My Zen Vplus screen is missing pixels?
 
So one day I turned on my 2 week old Zen V plus and :( :confused: the screen has a
black line across the top!! It kinda went on and off as I went through the menus. I reset the player,but it didnt do anything. What do i Do?

RAPCAT 06-30-2007 03:29 PM

oops you guys can delete this thread I got my answer in this forum...:o

RAPCAT 07-01-2007 10:13 AM

wait a second..I still need help! would the filmware fix this problem or should I return it for an exchange?????

SDZenVPlus 07-02-2007 12:55 PM

Exchange it ASAP.

RAPCAT 07-02-2007 09:51 PM

so more pixels will go away?


All times are GMT -5. The time now is 11:42 PM.