abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Samsung T10 (http://www.anythingbutipod.com/forum/forumdisplay.php?f=120)
-   -   UMS firmware for the T10 (http://www.anythingbutipod.com/forum/showthread.php?t=21463)

Zeddicus Zu'l Zorander 10-26-2007 08:05 AM

UMS firmware for the T10
 
A UMS (MSC) firmware (version 1.27) may now be downloaded, here.

It might not be possible to install a UMS firmware on the T10 (which is already running MTP firmware) since this is the case with the U3 and possibly the P2 which revert back to MTP firmware when trying to install a UMS version. Neither of these two players are damaged, or effected in any way when failing to install another firmware, so if anyone wants their T10 to be a UMS device, it's worth a try.

Here are the steps posted by Samsung:
Quote:

How to upgrade YP-T10 Firmware

- Before upgrade process, please check your battery status.
- Connect the player to your computer.
- unzip downloaded zip file on your PC
- Copy the 2 files into the root directory of the YP-T10.
- Select Safely Remove Hardware and remove the YP-T10 from the USB port of the computer.
- When you turn the player on, firmware updates are automatically performed during booting.
- To confirm an update,
Select MENU -> SETTING -> SYSTEM INFO from the menu to view the firmware version

Not sure what the difference between MTP and UMS is?

Very basically, they are two different means that the T10 can be connected to a computer, each having some advantages and disadvantages: Only MTP firmware is compatible with WMA-DRM files which many online music download services provide, while UMS firmware will connect the T10 in the same way as an ordinary storage device allowing it to connect to almost any computer (regardless of its operating system).

initer 10-29-2007 04:04 PM

Has anyone actually been able to install this update? I've tried the instructions above but the player doesn't update the firmware (or any other firmware for that matter). I have a YP-T10JAB.

f-rouz 10-29-2007 09:19 PM

Unfortunately, it also didn't work with my European YP-T10JCB which actually has the 1.20 MTP running...

Zolxen 10-30-2007 11:48 AM

Quote:

Originally Posted by initer (Post 178866)
Has anyone actually been able to install this update? I've tried the instructions above but the player doesn't update the firmware (or any other firmware for that matter). I have a YP-T10JAB.

I've run into that too. I havent tried installing this firmware, and I might not. I think i'll keep it MTP for now. But question, The Samsung Media Studio software has an option to upgrade firmware on a connected player. Does this feature actually work? I tried it with the "new" firmware released (1.20) and even though I have 1.19 BB (i guess the BB is a country code from what I've read), it wouldnt find the update and install it. And I never really noticed if it did or not on my old T9.

initer 10-30-2007 02:07 PM

I've tried the upgrade firmware option in Samsung Media Studio as well and haven't had any luck. It seems like it is doing a website check, but even though version 1.20 is on the website it still says there are no updates (my player has v.1.99 BB). Does anyone know if this firmware update feature is looking somewhere on the harddrive for a firmware to update with?

sir_rath 11-04-2007 05:19 PM

I'm sorry, this might sound a bit dumb, but I'm unable to copy anything into the root directory. I just can copy files to the "data" and "media" folders. What do I do wrong?

Zeddicus Zu'l Zorander 11-04-2007 10:49 PM

Do you have WMP10 installed by any chance? If so, you may have to use the System/Data folder instead of the root.

sir_rath 11-05-2007 02:06 AM

Yes, I have wmp10 installed. I already tried the system/data folder, because I guessed it would make sense to put the files there, but nothing happened, as I restarted the player. Has anybody sucsessfully done this firmwarechange yet? It is pretty essencial for me, because I'm using a mac and it absolutely s***cks to reboot and start windows via bootcamp just to put some songs on my musicplayer.
Would it help to format the player, using the windows format tool (via right mouse button) and the copying the firmware files to the blank player?

sir_rath 11-05-2007 03:51 AM

Okay, I've got it. The files had to be renamed to T10J.* and the kopied into the data folder. The player starts updating, but then says "please update rsc file. So no luck. Is there a more recent ums firmware from samsung?

Zeddicus Zu'l Zorander 11-05-2007 04:00 AM

I'd say you were doing nothing wrong by putting the files in the Data directory. Looks like you've had the same response as everyone else who haven't had success either.

sir_rath 11-06-2007 01:17 AM

Is there any chance for an ums firmware for this device? I'm not quite sure if I may ask such questions in this forum, but are there in general firmware hacks for mp3 players like there are for, let's say, Sony's PSP?

Zeddicus Zu'l Zorander 11-06-2007 07:37 AM

Hacked or alternate firmware have never been developed for any Samsung players that I know of. That doesn't mean it isn't possible in the future though. The best hope of a UMS support is if Samsung decides to release a compatible firmware. This is more likely to happen, as misterx has reported here.

foxx 12-04-2007 11:45 AM

Does anyone got it working? I have an YP-T10JAW with 1.29 EU firmware and nothing is happening when I try to use these firmware files :-/

foxx

BlueFyre 12-04-2007 02:38 PM

Are there any new than 1.29 firmwares?

lebellium 12-10-2007 06:50 PM

1 Attachment(s)
I need some people to try this way:

download the 1.29 UMS here:
http://www.samsung.com/he/Support/Pr...55881119983375

Copy the files T10.ROM, T10.RSC AND the config.dat file in "attach files" in the T10.

I hope it will become UMS!

fde 12-12-2007 04:53 PM

Hi lebellium! I tried what you propose with a European (Belgian) MTP YP-T10. It did not work. In a first time, I thought it was just because of the name of the firmware (in Europe it must be "T10J.ROM" and "T10J.RSC" and not just "T10"), but even after having renamed them, my player says "invalid firmware".

lebellium 12-12-2007 05:31 PM

Yep that's a pity.:(
That does not work on a french T10 too...

I don't understand why it works on the P2 and not on the T10 whereas they both have the same base

fde 12-14-2007 04:07 PM

Still no solution?

lebellium 12-14-2007 04:40 PM

At the same time, nobody seems to be looking for a solution....

shinobi00 12-14-2007 08:08 PM

Guys, please call samsung and send them an email about this issue. We want to install other firmwares on our player. If we bug them enough(as the tech said) they'll eventually get to it.


All times are GMT -5. The time now is 03:17 PM.