abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Cowon iAudio X5 (http://www.anythingbutipod.com/forum/forumdisplay.php?f=27)
-   -   x5 does not start up (http://www.anythingbutipod.com/forum/showthread.php?t=40717)

Blue Star 03-05-2009 12:54 AM

x5 does not start up
 
i have iAudio X5 which has gone through battery replacement once. I didnt used it for about 6 months or so. Now, I am tryign to start it up but it wont.
I have lost the AC adaptor and the connector so cant try that straight away. However I am putting the x5 on cradle then connecting it to PC via USB, but no luck. It just dosent show any sign of life. Earlier it used to power up when connected via USB. I have lost the original USB cable also just tried about any USB cable I could find that could be hooked up the the cradle but no luck.

Any advice or calling company support line is my only option ?

Thanks

pushpull 03-05-2009 06:08 PM

Did it work after the battery was replaced? Who did the replacement? If it was Cowon it might be covered under warranty for the battery/workmanship issues.

Blue Star 03-05-2009 08:38 PM

yes it worked well after the battery was replaced. and that we a long time back actually so no more warrenty coverage I think.

pushpull 03-05-2009 09:41 PM

Well, you might think about picking up a new subpack and power supply and see if that does the trick. You might have a problem with the cradle making a good connection but since you do not have a subpack and power supply you cannot rule it out. You can also go here and buy one of these units that bypass the subpack.

prozac 01-04-2010 09:56 PM

hello
 
i am hopping that im writing in right window...anyway my iaudio x5 60gb (by me best mp3 player ever) i managed to format it... now i cant play music and installing a firmware semis a big problem, all what i get is hdd error, please help... please HELP!!

many thanks


All times are GMT -5. The time now is 08:26 AM.