abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Zen X-Fi2 (http://www.anythingbutipod.com/forum/forumdisplay.php?f=215)
-   -   How to fix most problems with your X-Fi2 (http://www.anythingbutipod.com/forum/showthread.php?t=52875)

LordXenos 02-25-2010 02:09 PM

How to fix most problems with your X-Fi2
 
Below are some steps you can take to fix most problems that occur on your ZEN X-Fi2. Start from the beginning and stop whenever your problem is resolved.

If you have a step that you think should be added to the list, post it here.


1. Update your X-Fi2 with the latest firmware (1.22.03 as of this writing).

2. Clean up your player's memory by following these steps from a Creative FAQ section:
Quote:

Press and hold the Home/Menu button while powering up the unit
Release the power button once the splash screen display appears
Continue holding down the Home/Menu button until the Recovery Mode screen appears
The Recovery Mode screen appears, and three menu items are shown: Clean Up, Format All and Reboot.
To clean up your player's memory, select Clean Up.
When the cleanup is complete, select Reboot. Your player restarts and starts rebuilding its music library.
3. Search Creative's Knowledgebase for existing solutions to your specific problem.

4. Reformat your player with Creative's MP3 Player Recovery Tool. This option will erase all your songs/apps/personal data on your X-Fi2. Only do this step if none of the above steps worked and you don't mind reloading all of your songs/etc.

5. Contact Creative's Technical Support. If you've reached this point you are probably SOL. Good luck and God's speed.



** Also Helpfull: Pressing the 'Reset' button on the bottom of your player will reboot it if it freezes or you just can't get it to shut off normally.

Habhome 02-25-2010 02:22 PM

I'd put #4 as #3. Better to do that before reformatting the player.

Idroy 02-25-2010 02:50 PM

Quote:

Originally Posted by Habhome (Post 445863)
I'd put #4 as #3. Better to do that before reformatting the player.

Yep, indeed :D

LordXenos 02-25-2010 11:04 PM

Ya... I don't know why I had them in mixed up like that... fixed

G.Ri 04-03-2010 02:43 PM

I vote this gets stickied.

barrettr33 05-14-2010 08:37 AM

How do you remove the sceen protector on the zen x-fi2

mattye112 05-14-2010 07:43 PM

simply peel it off

jammaniaclord 07-17-2010 02:44 PM

Also don't unplug your Zen 64( or any model for that matter) when the firmware updater is handshaking your unit. It said my Zen wasn't plugged in (when it was), and being so tired from the overtime i was hording at work, and i panicked, unplugged it, plugged it back in, but something was funny. When i unplugged it, it didn't reboot like it normally does, and rebuild library. I pushed the reset button, and it rebooted, but locked up on the ZEN logo. Reset again, and plugged it back in, Zen firmware updater recognized player, updated to 1.21.05, closed updater, unplugged, reboot, and it locked up on the rebuild screen. Had to format after several tries. Laptop wouldn't even recognize the unit most of the time, before the format. All is well now though with new firmware. Be careful folks. = )

stevieo63 07-28-2010 09:40 PM

zen xfi2 auto locks
 
Anyone know how to control this? I've gone into the settings and made sure it wasn't highlighted, yet it keeps locking up on me and I'm unable to turn the unit off.

Jerryherz 09-11-2010 08:51 PM

locked
 
I have the same problem. Not much help from support,

MrGrimshaw 09-28-2010 04:31 AM

Hi guys. I got my X-fi2 a couple of weeks ago. Generally very impressed except for Creative Centrale which has a tendency to crash - "this program is not responding" etc. But on Sunday I was getting the "player locked" message a lot when trying to turn off the unit, despite having installed latest firmware (ZENX-Fi2_PCFW_L22_1_21_05.exe), and had to drag the icon off the screen a few times before it would finally switch off. I went into Recovery Mode wanting to clean up the memory, but when the message asking if I wanted to do this came up, it stuck on the default of "No" & would not respond to tapping "Yes" - it would then bring up the "Format" screen instead. Obviously I didn't want that, as my playlist tags were edited manually (a lot of work). This happened repeatedly. Then I unintentionally did hit "Yes" in the Format screen & lost all my stuff & playlists: it took about 8 hours work to get it all back the way it was. I got the "Player locked" message still after this, but a reset seems to have fixed it for the time being (I know you can reboot from Recovery Mode but I don't want to go there again unless necessary!). So the question is - has anyone else had trouble using "Clean Up"? and if so, how did you get it to work? I'd just like to know for future reference. I'd be really grateful for any suggestions. Cheers. (not quite sure how this board works yet so am using "Post Quick Reply").

MrGrimshaw 10-28-2010 07:24 AM

Replying to my own post: all sorted now. You have to hold down the power button for a couple of seconds to shut it down; one quick press will just tell you the player is locked. It would have been helpful if this basic point could have been covered by Creative in a "Quick Start" guide. And if things do go wrong, use the reset button before considering Recovery Mode. It worked for me (despite initially misidentifying the microphone as the reset button hole cos I hadn't got my glasses on, shoving a pin in there & poking it around. The mic still works, surprisingly).

uutela 11-11-2010 03:41 AM

The problem:
I've had my X-fi2 since this summer and this is the first time I'm experiencing problems. The thing is, the little freak just freezes at times. At first it was only when I dragged the unlock icon out of the screen to unlock it. The screen froze and the music stopped. Nothing to do but reset. Then this went on for a couple of days and started getting worse, now it freezes like anytime, when I want to change the song or change the volume, just about anything. And it does this all the time. I can listen to just about one song before it happens, and that's not something I can live with.

What I've done to solve it:
I've updated the firmware; nothing changes. I've done the Clean Up and Reboot thing; nothing changes. I've tried the MP3 player recovery tool, but it just updates my firmware; nothing changes. So a couple of minutes ago i went to the recovery mode screen and chose Format All. I'm currently transferring songs to the player so I can test it the next time I go out. I'll post another reply later, letting everyone know if the problem was solved (though I don't think it is, I'm never that lucky).

uutela 11-11-2010 04:41 AM

So I went for that walk and it worked suspiciously fine for about ten minutes or so before it froze in the middle of a song. Then followed some resetting and minutes of scanning disk. I got to the menu and it shut down - it didn't freeze, just powered off, when I turned it on it scanned the disk for a while before starting up the menu. Since then it's been working suspiciously fine... about twenty minutes now.
I currently do not know if the problem is fixed or not (though I think not), so I'm preparing to be poor for a while, since it's likely I have to myself a new mp3 player.

uutela 11-18-2010 06:26 AM

So. Update. Since last it has actually worked pretty fine, though it has frozen and shut down a couple of times. Nothing major, although the problem certainly is not fixed. I believe it'll get worse again, just a question of time. But for now I can live with it.

Habhome 11-18-2010 02:27 PM

That problem you've been having seems really odd. I've never heard of anything similar. Did you ever get around to trying Creative's Recovery tool? Might be something to try if it acts up again otherwise.

Grond33 01-21-2011 04:59 PM

Y'know what's infuriating? The fact that i got my xfi-2 today and it's brilliant, except when it comes to turning on/off. I can only get it to turn on by plugging it into a pc and then unplugging it. I know it's fully charged because that all went fine and i've got all my music on there. Then when it comes to turning off i just have to leave it to it's own devices until it shuts down, surely there's a way to manually shut it down?

Habhome 01-21-2011 05:58 PM

Yes, there is. On one side there is a tiny flat black button, is that one not working for you?

eXCiDiuM 05-03-2011 01:45 PM

Hello everyone.
This is my problem: My XFI2 (16GB) stucks on the "SCANNING DISK" screen, just after powering up, and stays there until battery rans off.
Ive been trying to access the recovery menu, but its imposible, and the Creative's MP3 Player Recovery Tool just upgrades the firmware.
I dont care if i have to format the player and lose everything, while i can restore it to
work again.
Can anyone help me here please.
Thanks

Habhome 05-03-2011 04:42 PM

That is odd, the Recovery Tool should be reformatting the player and force it to start from scratch.
How many times has it done this to you? Did it suddenly start doing it? Can you access the files on it or does is say Scanning disk even then? (never tried plugging in my player when it needs to scan disk). If it suddenly started doing it, do you remember what you did right before it acted up? Application used? File added/deleted?


All times are GMT -5. The time now is 11:29 PM.