abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   iriver H Series (http://www.anythingbutipod.com/forum/forumdisplay.php?f=113)
-   -   How do I install firmware on a formatted H10 6GB? (http://www.anythingbutipod.com/forum/showthread.php?t=55398)

aarons510 05-31-2010 12:58 PM

How do I install firmware on a formatted H10 6GB?
I have two 6GB H10's (MTP version). One of them is working fine with Rockbox installed over OF 2.51. The other, however, has been formatted and the following is the situation:

1) When I start it, I get the Missing System Files message.

2) When I then plug in the USB cable to the computer (a PPC Mac running Leopard), it mounts the H10 as a drive (i.e., in UMS/MSC mode).

3) I've tried various methods of installing the firmware, including:
a) copying the System folder from the working player, along with the .rockbox folder, to the root level of the player;
b) copying another System folder that was saved before Rockbox was installed;
c) copying all the files from the downloaded H10_56G_MTP_US(V2.51).zip to the root level of the player. Those files are:
None of these methods have worked.

I should also mention that, although both the working and non-working players show, via fdisk, one partition that starts at sector 63 and has length 11718945, the contents of the first 64 sectors of the two /dev/diskn files, as copied using dd, are very different. In particular, the first $1BF (447) bytes on the non-working player are all zeroes, while those on the working player include lots of pseudo-random binary data as well as the following three null-terminated strings:

"Invalid partition table"
"Error loading operating system"
"Missing operating system"

I'd really like to know, ASAP, how to install the firmware, and how, if it is in fact necessary, to correct the first 63 sectors of the disk as well. (dd apparently won't write to them.)

aarons510 06-01-2010 04:53 AM

I was able to get the second player working by cloning the working one. I had to do a device clone, not a volume clone. On my Mac, I created the disk image (.dmg file) using Disk Utility, but was only able to write the image file to the second device using a program called CopyCatX, since Disk Utility seemed to only allow writing to a volume, not an entire device. (It may be that I was doing something wrong, however.)

In any case, dd showed the contents of the first 64 sectors of the two devices to be the same after cloning. Whether or not it's the change in these sectors that allows the second player to work, or if there was another change that is not visible, I'm not sure. And it would still be useful to know how to get a player working if you don't have another one to clone.

All times are GMT -5. The time now is 05:26 PM.