abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Sansa Clip / Clip+ / Clip Zip Rockbox (http://www.anythingbutipod.com/forum/forumdisplay.php?f=228)
-   -   Does anyone have 3.8 with the USB patch? (http://www.anythingbutipod.com/forum/showthread.php?t=62104)

rEUD0yNGneUGi9n 03-17-2011 05:12 PM

Does anyone have 3.8 with the USB patch?
 
Does anyone have a Rockbox 3.8 build for the Clip+ with the USB patch?

Thanks.

Pennhaven 03-18-2011 03:24 PM

Provided the post 3.8 SVN is now stable we can hope that dfkt will find time to compile another build with the USB and Meier cross feed patches.

Maybe if we all say "please". :cool:

Astral_Milk 03-18-2011 04:08 PM

Please. :D

dfkt 03-18-2011 04:52 PM

The USB patch is out of sync, it will not apply to newer revisions. Nothing I can do about it, that needs some seriously deep understanding of the Rockbox source code, of USB transfer, and so on.

Also, 3.8 is a forked stable release, outside of SVN. It's not an ongoing revision - you can't take that code and still call it "3.8 release" after you apply some patches to it. This is something completely different to applying patches to SVN.

Pennhaven 03-18-2011 07:25 PM

Oh well, thanks anyway. Your previous builds are working fine for my needs.

marc2003 03-18-2011 08:10 PM

Quote:

Originally Posted by dfkt (Post 544343)
The USB patch is out of sync, it will not apply to newer revisions.

it was still working for me a couple of days back?? i can't test against latest SVN right now though.

edit: how embarrassing. i just checked the date and it was infact 12 days ago. still well after 3.8 was released but not nearly as recent as i thought. where does the time go. :o

funman 03-20-2011 11:06 AM

Just uncomment #define USE_ROCKBOX_USB in firmware/export/config/sansaclipplus.h and it should "work"

ted209 03-21-2011 04:35 PM

Here's a build I made yesterday. It contains the following patches:

FS#9305 - Context sensitive backlight on key press (updated to work with radio)
FS#11304 - higher quality audio hw settings for AS3543
FS#11767 - Meier crossfeed V3

Plus:
USB enabled (as described by Funman above):
"uncomment #define USE_ROCKBOX_USB in firmware/export/config/sansaclipplus.h"
Button mapping:
Long-press home (was Quickscreen) is now the "WPS Hotkey".
Home+power is now Quickscreen
Database view:
Removed <All tracks> and <Random> items from database.

This version does NOT include the very latest SD patches in the SVN:

r29624: SD amsv2: remove double assignement

r29625: SD AMSv2: fix r29169

Restore access to the last AMS_OF_SIZE == 0xF000 sectors of internal drive
Mostly visible when using USB (or database?)

r29627: AMSv2 SD: use a sleep instead of a udelay for 100 ms delay

I made a compile with these included, and my 16gb PNG SD card no longer works with it. I have tested it quickly, and all seems fine. Enjoy!

http://www.mediafire.com/?q1dbossawfg343b

PS. There's active development on SD card access (new patch just after I posted "r29628: AMSv2 SD: wait for previous data transfer completion before sending a command"). I'll make another build soon and see if SD card access is working again.

saratoga 03-21-2011 04:44 PM

Does anyone actually have a player where FS#11304 solves some problem? I don't mind committing that if someone could show it actually does something. At least on my hardware it literally does nothing at all.

ted209 03-21-2011 04:51 PM

Quote:

Originally Posted by saratoga (Post 544847)
Does anyone actually have a player where FS#11304 solves some problem? I don't mind committing that if someone could show it actually does something. At least on my hardware it literally does nothing at all.

Haha, yes it's my understanding that it has no proven positive or negative effect on output. I had no rational reason for including it!

marc2003 03-21-2011 07:08 PM

Quote:

Originally Posted by funman (Post 544604)
Just uncomment #define USE_ROCKBOX_USB in firmware/export/config/sansaclipplus.h and it should "work"

i tried this on my clip v2 (editing sansaclipv2.h, obviously) against latest SVN and it doesn't appear to fully work. it seems to be fine in ubuntu 10.10 but my windows 7 isn't recognising it properly. no errors - just the "safely remove" icon appears but nothing in explorer. if i try and open disk management or device manager, the window just hangs.

is anybody else with a clipv2 having any joy? :)

saratoga 03-21-2011 07:47 PM

Quote:

Originally Posted by marc2003 (Post 544877)
i tried this on my clip v2 (editing sansaclipv2.h, obviously) against latest SVN and it doesn't appear to fully work. it seems to be fine in ubuntu 10.10 but my windows 7 isn't recognising it properly. no errors - just the "safely remove" icon appears but nothing in explorer. if i try and open disk management or device manager, the window just hangs.

And now you know why its disabled by default :)

marc2003 03-21-2011 07:50 PM

well i wasn't asking for it to be enabled by default. :p

besides, i've manually synced the original patch from flyspray to current SVN and that's working so i'm happy.

telliott 03-22-2011 12:28 PM

Quote:

Originally Posted by marc2003 (Post 544890)
well i wasn't asking for it to be enabled by default. :p

besides, i've manually synced the original patch from flyspray to current SVN and that's working so i'm happy.

Could you provide us less technical people with your build?

Thanks

marc2003 03-22-2011 03:18 PM

ok here you go, my build for the clip v2.

http://cid-649d3bfeaf541fbb.office.l...clipv2-usb.zip

telliott 03-22-2011 05:21 PM

Quote:

Originally Posted by marc2003 (Post 545032)
ok here you go, my build for the clip v2.

http://cid-649d3bfeaf541fbb.office.l...clipv2-usb.zip

Thanks but I have a clip+ I guess I should have specified.

marc2003 03-22-2011 05:55 PM

i assumed you had a clip v2 because my post was quite specific about creating a v2 build for myself. :p

edit: clip plus build removed - it doesn't work.

telliott 03-22-2011 08:27 PM

No luck. Rockbox detects the USB plug but the computer (Windows 7) doesn't.

Thanks anyway

marc2003 03-22-2011 08:42 PM

oh well, nowt i can do about that. i'll take the link down to save anybody else wasting their time with it.

marc2003 03-22-2011 08:58 PM

can you try another clip+ usb build? this time it's using the simpler method funman mentioned above that doesn't work on my v2.

http://cid-649d3bfeaf541fbb.office.l...p-plus-usb.zip


All times are GMT -5. The time now is 09:37 AM.