abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Archos Generation 8 Android Devices (http://www.anythingbutipod.com/forum/forumdisplay.php?f=219)
-   -   How could I open an Archos 32 unit? (http://www.anythingbutipod.com/forum/showthread.php?t=62150)

nachenko 03-20-2011 02:00 PM

How could I open an Archos 32 unit?
 
Hi everyone.

Long story short, the Archos customer service in Europe refuses to get my unit repaired, although it's still in guarantee. (full story here: How to lose a customer in three easy steps, my experience with Archos).

The problem with my unit is just the power button. I'm pretty sure it's a spring out of place or something that simple. After two months trying to contact the custoemr service for repair, I give up. I've sent a complain to the European Union Consumer Office, but I'm pretty sure I'll get a response by 2014, so I'll try to fix this crappy power button myself.

The problem is... there are no screws!! How the hell is this supposed to be opened?

Any help is appreciated.

dfkt 03-20-2011 02:02 PM

The back metal plate slides upwards when you push it (hard) from the bottom to the top. Some plastic prying tools or a sturdy finger nail might help.

nachenko 03-20-2011 02:38 PM

Wow, that was fast! Thank you!

Still in problem, though, the power button is not visible. By removing the case I have access to the volume buttons, but not to the power button. How much a man can suffer due to a power button?

dfkt 03-20-2011 03:00 PM

I don't have my A32 at hand to check, but digging deeper inside might be more complicated. If I remember correctly, the battery and screen are glued together, and both are glued to the digitizer and transparent front plate. Tearing that contraption out might lead to damage. As for the PCB where the power button is attached, I'm not sure if it's screwed or clipped in.

Best you use common sense and don't use force in trying to remove the PCB. Good luck.

nachenko 03-20-2011 03:15 PM

Thanks again for your help.

Myles 04-02-2011 08:48 AM

Have you had any luck? I dropped mine, and although it did not land hard, it must have landed right on the power button. The button still presses a little, but won't turn the unit off. I didn't want to pull the back off if it was of no help to you. By the way, when you slide the back off, does it take the volume control with it?

nachenko 04-02-2011 05:56 PM

Your unit seems to have the same disease. Exactly the same.

I had no luck repairing it. The power button is still not visible after removing the back plate, so access is very difficult. I could not repair mine.

If you find a way to repair it, please let me know.

MrTechRat 11-20-2011 01:29 AM

seems to be a big issue
 
I bought the 32 'tablet' to replace an old ipod touch. Gave it to my sister next month for xmas because i hated the screen. anyway she has recently had an issue with her sleep/power button. The device will not turn off or go into sleep mode. I was able to open the device and there are to clips you need to pry carefully no doubt. I did get the entire unit apart but can't seem to get the power button to do much of anything.

Dean Fairburn 01-05-2012 03:45 PM

I had a similar problem and have thankfully resolved, although not in a particularly technical way as follows:-

1) I opened the rear panel by applying a reasonable amount of downwards force

2) As mentioned below, the power button is not visible by doing this. However, using a tiny screwdriver, I managed to pry the display panel/battery/circuit board away from the casing. Note that the circuit board is retained by plastic at either side but this is easily unclipped. This doesn't take much force, so take care not to scratch the lcd panel.

3) If you have successfully done the above, you should be able to gently pull everything down slightly, including the circuit board ## take care though - there are a couple of ribbon cables attached to the circuit board - take note of where these are placed & don't damage these! ## You will now see the power button on the left of the circuit board.

4) Now for the non-technical part. My power button had come away from the circuit board and I didn't fancy trying to re-solder as the solder would have to be tiny. I super-glued the switch back to the circuit board and the connection was re-established. ## another word of caution - don't get any glue on the switch itself, or it's game over! ## I used to tiny amount of glue on a tiny screwdriver and held it in place. Once it had set, I applied further glue at each side of the switch to secure it.

5) Wait until the glue has completely set and then reassemble the unit. Make sure the ribbon cables don't get trapped when you put it back together.

This worked for me and the unit is still working 2 weeks on. As other forums have suggested, the power button seems to be a significant weakness of the Archos 32 and when you see the micro switch and contacts, you will see why. If the unit fails and it is under warranty, return it. If it has been dropped and you have no option, I'd give this a try! :)

DJ3030 01-06-2012 12:39 PM

hope this website helps.

http://beyondthekeeboard.wordpress.c...f-lcd-screens/


All times are GMT -5. The time now is 03:49 PM.