abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Sansa Fuze Rockbox (http://www.anythingbutipod.com/forum/forumdisplay.php?f=229)
-   -   database building freezes with rockbox 3.9 and newest daily build on v2 fuze! (http://www.anythingbutipod.com/forum/showthread.php?t=64267)

Tmansdc 07-14-2011 03:12 AM

database building freezes with rockbox 3.9 and newest daily build on v2 fuze!
 
I just received another sansa fuze. A refurb black 8gb one. Well I went about installing rockbox and all that. However every time I try to use the database it freezes at a certain point!


I have an 8gb microsdhc transcend class 6 card in the slot. On my other fuze (which has a busted headphone jack and thus only works out of the right channel) it works flawlessly in both rockbox 3.9 and OF 02.22.26a.


My refurb came with 02.33.33a. Well I even went so far as the long/complete format both the card and the player and recopy all my music to both again. Again, database freezes up.


I've tried chkdsk on both the player and the card, that didn't help.


I tried the metadata logging file format and then deleting whatever songs come up as being "misread". Nothing.


I don't think the player is bad as the OF reads all the OF supported songs off of the card and the player just right and plays fine.


Every other aspect I've tried of rockbox works fine. File browsing, rockboy, plug-ins, etc. Just not the database!


What is going on? I don't think I can return it now since I rockboxed it but I'm not sure.


What can I do to help alleviate this problem? I know it was a problem in build 3.8 but was fixed between then and 3.9 so the fact that it's doing it on my refurb is weird.


BTW, my non refurb fuze i've had since april 2010 (where the headphone jack broke) works FLAWLESSLY on this. What to do? Please help! Thanks.


edit: database building works perfectly when I don't have the microsd card in the fuze. However, as soon as I put it back in, it falters again! Please help! All the same files and the same card worked flawlessly on my other fuze.

Progweed 07-14-2011 09:40 AM

I'd say that this has nothing to do with your refurb device, Tmansdc. I'm encountering database related problems as well and there is this bug description on the tracker:

http://www.rockbox.org/tracker/task/12175

Did you try turning the directory cache off? This has helped in my case.

Tmansdc 07-14-2011 06:11 PM

Also whenever I delete the database files that doesn't help.



It'll always hang up on some random number. The most it's ever gotten to is 1847 out of 3300. Then it freezes. What is going on? Help please!


I even used SD Formatter 3.0 and Full Overwrite formatted both the sdhc card and the fuze itself. Also I used H2testw 1.4 after both had been formatted and there were absolutely no errors on either the fuze or the microsdhc card.


What am I to do? Please help! Thanks.


All times are GMT -5. The time now is 02:43 PM.