abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Cowon iAudio X5 (http://www.anythingbutipod.com/forum/forumdisplay.php?f=27)
-   -   SD mod for X5L, successful, but strange things happened (http://www.anythingbutipod.com/forum/showthread.php?t=66799)

benyeung 12-02-2011 07:11 AM

SD mod for X5L, successful, but strange things happened
 
I own my X5L since 2007, and installed rockbox (with dual boot) 1 week after I got it. Last week, I realize that the HDD inside X5L is defective after replacing the batteries, I followed the steps taken by Razorblader:

http://anythingbutipod.com/forum/sho...7&postcount=47

Apart from the SD card I used (I'm using a Trendcend 4GB class 6 SDHC), I'm using "parts with exactly the same look as Razorblader", but I formatted the card with partition type set to "0x0b", which is also a FAT32 partition type, my X5L finally boots up, and something strange happened afterwards.......

1. I can still boot into official firmware, but some folders were not shown in the player, including the "MUSIC" folder.

2. I can boot to rockbox and play music, but I cannot boot it up again (for both rockbox and official firmware) after it is powered down for 15 minutes unless:
a) Unplug and reconnect the CF-IDE adaptor
b) Plug in the subpack with USB cable connected to the computer
c) Plug in the subpack with charger

3. I tried to update the firmware, but my X5L shows no response to the firmware file inside the "FIRMWARE" folder when the charger is plugged in at the first 10+ trials. After updating the latest version of rockbox bootloader (no dual boot), the problem mentioned in (2) remains.

Could anyone tell me what exactly the problem is?

benyeung 12-02-2011 08:04 AM

Just changed the partition type to 0x0C, it doesn't resolve the problem........It freezes at the bootloader page and powered off by itself after ~10 seconds.

benyeung 12-05-2011 05:39 AM

Just changed a Transcend 64Gb SDXC today, it doesn't resolve the problem also.........

Suddenly, I got and idea about the problem!!!

Should I make the partition inside the SD card "BOOTABLE"???

I just did the change, and performing some testing, will post the result here later!

razorblader 12-05-2011 07:48 AM

You should try to make it bootable, depending on the SD/CF adapter used this might or might not be necessary to get the OF to boot. I'll update my original howto accordingly. Sometimes the boot process can get stuck, you could either reset the X5 or just hold the on-switch until it switches off and try to boot up again.

benyeung 12-06-2011 01:33 AM

Razorblader, thanks for your help.

After changing the partition to "BOOTABLE", I'm still having the same problem, startup sequence is stucked at the rockbox bootloader if my X5L was shutdown by "idle power off" of rockbox for around 15 mins. Bootloader I tested were:

1. Instant power off V4 bootloader from DFKT
2. V2 bootloader + OF (2.10e) dualboot compiled by mkboot.exe

After that, I tried to use OF (2.10e), no startup problem anymore up to this moment, but I realize that the tracks being played sometimes jumps to another location (and sometimes jumps to the previous track of the playlist) while playing FLAC (haven't tested other formats), which looks like "buffer overflow"........

According to my own tests, if my X5L is stucked at bootloader, I can make it boot up again by only these ways, reset/power off and on again just won't help:

a) Unplug and reconnect the CF-IDE adaptor
b) Plug in the subpack with USB cable connected to the computer
c) Plug in the subpack with charger

Even I'm using "V2 bootloader + OF (2.10e) dualboot compiled by mkboot.exe", if rockbox bootloader is stucked once, it shows "HDD ERROR" when I power off and power on again with OF.

benyeung 12-09-2011 11:45 PM

After further testing for a few days, to summarize:

1. With using OF, apart from the skipping issues, my X5L freezes and require reset during playing.

2. With considering the fact that the startup problems could be fixed after the original firmware is executed (when connected to a charger or connected to the computer via usb), I changed back to "V2 bootloader + OF (2.10e) dualboot compiled by mkboot.exe".

3. After changing back to the dualboot firmware, the startup problem remains, but the skipping and freezing problem doesn't appear in rockbox anymore. At the same time, I got a solution now (although it is not a complete one):

When starting up rockbox, and X5L freezes at bootloader, wait and let it power off by itself, rockbox bootloader should report "ATA ERROR XX" before shutting down. If "ATA ERROR -32" was shown, startup rockbox again, if "ATA ERROR -1" was shown, start OF, it should show "HDD ERROR" and shutdown by itself. After that, rockbox can be startup without problem.


NOTE: I tried to start OF right after "ATA ERROR -32" is displayed by rockbox bootloader and shutdown, the OF will freeze and need to reset.


I don't understand the real reason behind these problems, these results were obtained by trial and error methods, I hope these information would help other X5 series owners.


All times are GMT -5. The time now is 12:28 PM.