abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Sansa Fuze (http://www.anythingbutipod.com/forum/forumdisplay.php?f=163)
-   -   Boot problem (http://www.anythingbutipod.com/forum/showthread.php?t=68147)

JPP 02-18-2012 03:49 PM

Boot problem
 
Hi Guys
My son's 4gb Fuze has a problem booting. It worked fine for a year. He tried to use a new Samsung microSD card, and started to have the following problem:
At power on, white 'sansa' appears on black screen, then dissolves to 'fireworks', but 'flower' is not rebuilt from the colored specks. There is then a solid white screen for about 1/4 second, then 'sansa' appears again, dissolves into 'fireworks' and freezes right there. Our only solution to do anything at this point is to power off by holding the power switch to 'on' for 10 secs.
I've tried to reset (hold switch, hold down << while plugging in the connector already in the computer). I tried doing this many times, all no help. Tried holding down 'home' while powering on, tried 'play' while powering on, no go. My computers will not recognize it at all, I think because it has not gotten to the point in the boot sequence where it CAN be recognized.


Anyone have any thoughts on what I can do next?

Thanks!

WalkGood 02-18-2012 04:29 PM

Does it do all the same you describe when the microSD card is not in the player? Iíd try to see if you can get it connected to your computer without the card in the player. If you can get it recognized I would format and re-firmware it before you reload tunes. Sounds like some system/firmware files or onboard files are corrupted. Aside from that, you can look http://www.rockbox.org/wiki/SansaAMS...ing_using_JTAG but I canít help more as Iíve not owned the Fuze.

JPP 02-18-2012 09:27 PM

Hi WalkGood
It does the same thing whether the MicroSD card is in or out, or with a different (known good) card in. Also, none of my computers will recognize it, and they will all recognize our other Fuze players, so it's not the computer or cord.
I think you're right, though, that it seems to be a corruption of boot files.
Does anyone know how to bootstrap the boot files?

JPP

saratoga 02-18-2012 10:03 PM

The only way to recover a bad flash rom on the Fuze is to open up the player and short two of the pins on the memory chip together. Even then, as far as I know that has only worked for people who have flashed their player with a bad firmware, never heard of it being used on a device that stopped working on its own. You're probably out of luck if you can't get it to boot into the sandisk software.

JPP 02-18-2012 11:29 PM

Shorting Pins
 
Thanks, Saratoga. At this point I have nothing to lose. Could you point me to the link(s) which show me how to short the right pins? And how to open it up?

Thanks again

saratoga 02-19-2012 01:20 AM

Quote:

Originally Posted by JPP (Post 599629)
Thanks, Saratoga. At this point I have nothing to lose. Could you point me to the link(s) which show me how to short the right pins? And how to open it up?

See Walkgood's link above. You can pry it open, but be extremely careful that you don't rip out the ribbon cable that connects the wheel (on the top half of the shell) to the motherboard (on the bottom half of the shell) when you open it.

JPP 02-19-2012 01:29 PM

OK, got it open and shorted the pins, not able to run "sudo fdisk -l" though; my Win7 computer doesn't recognize the command. Any workaround?
Thanks,
JPP

skip252 02-19-2012 01:41 PM

"sudo fdisk -l" is a Linux command. IIRC there's directions on how to download and run Ubuntu Linux from a Live CD. You'll need to get that done to use those commands.

WalkGood 02-19-2012 04:18 PM

https://help.ubuntu.com/community/LiveCD


All times are GMT -5. The time now is 10:42 PM.