abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Cowon X7 (http://www.anythingbutipod.com/forum/forumdisplay.php?f=240)
-   -   Can't connect via USB (http://www.anythingbutipod.com/forum/showthread.php?t=69056)

TimTDP 04-24-2012 11:01 AM

Can't connect via USB
 
I have just received a new X7. I have charged the battery - until I received a message saying that the battery is full.

I am running a computer with Windows 7

When I connect the X7 to the computer via the supplied USB cable, the X7 displays:
* the USB logo, and "Connected"
* "Terminating"
* "Updating database"
* "Updating metadata"
* "Now turn off"

The screen goes blank.
I do not see the X7 in Windows Explorer

I have tried pressing the RESET button on the X7. I have also rebooted my PC

I notice that the USB connection on the X7 is very loose. Not a nice solid connection.

Is my new X7 broken?

Resiak 04-24-2012 01:05 PM

If you go into "system" from the X7 screen...on the second page, beside USB mode, does it say MSC or MTP? It should be MSC. That should connect the X7 to the PC. MTP won't.

TimTDP 04-24-2012 10:13 PM

Quote:

Originally Posted by Resiak (Post 607977)
If you go into "system" from the X7 screen...on the second page, beside USB mode, does it say MSC or MTP? It should be MSC. That should connect the X7 to the PC. MTP won't.

Thanks

Your reply has confirmed my decision to return the unit for a refund.

I should not have to check settings like this. Nowhere in the manual is this explained.:confused:

The USB connection is also so loose that if I bump the X7 it comes out.:eek:

This is such a pity because the X7 has had great reviews and I was really looking forward to it. Back to the drawing board for a new device!

Resiak 04-25-2012 02:46 AM

I have the Cowon X7 for quite a while and honestly it is the best sounding player, especially of that capacity. If changing it to MSC hasn't worked, then there is definitely something wrong with the one you have. But if it has, then by all means have it replaced because of the loose cable but not for any other reason. Just my opinion!!

dmiddleton006 04-25-2012 11:31 AM

Are you sure that you have pushed the USB plug all the way in? You need to be quite firm with it. I have seen a few people having this sort of problem in the past. Once the USB plug is properly in there is no way it should fall out!

Give it a try - what have you got to lose?!

WalkGood 04-25-2012 01:08 PM

Quote:

Originally Posted by TimTDP (Post 608055)
Your reply has confirmed my decision to return the unit for a refund. I should not have to check settings like this. Nowhere in the manual is this explained.:confused:

I will agree with you, the manual is piss poor at best but every cowon I’ve ever tried connects the same way. Also many other brands don't even give you the choice between MTP and MSC, which is a real advantage in the first place. On the other hand, cowons are mainly sold to a niche market outside of Korea so maybe it’s not for you.

Quote:

Originally Posted by TimTDP (Post 608055)
The USB connection is also so loose that if I bump the X7 it comes out.:eek:

I’ll have to agree with dmiddleton006 here, “Are you sure that you have pushed the USB plug all the way in”? On the first few connects with my i9 I noticed it had to be pushed in really hard. After a few connects disconnects it becomes easier to insert the right way

Quote:

Originally Posted by TimTDP (Post 608055)
This is such a pity because the X7 has had great reviews and I was really looking forward to it. Back to the drawing board for a new device!

Not every little thing about each player is covered in their manuals, that’s how a lot of members first found abi … as they were searching for information about their players they joined up here because they saw a benefit to much of the information provided and they began to share their learning’s with other members. You can always go back to the “drawing board” as you state but if I were in your shoes I’d cut the X7 some slack and enjoy it …

You can find information about it here on abi X7 forum or on our sister site iAudiophile.com on their X7 forums

tienbasse 04-26-2012 12:12 PM

Quote:

Originally Posted by dmiddleton006 (Post 608121)
Are you sure that you have pushed the USB plug all the way in? You need to be quite firm with it. I have seen a few people having this sort of problem in the past. Once the USB plug is properly in there is no way it should fall out!

Give it a try - what have you got to lose?!

THIS!

I got the same issue initially.
Just push the plug HARDER until it really clicks into the port.

Then it won't disconnect by mistake (which is exactly what happened to you).

bth73 07-22-2012 07:47 AM

I just went through the same problem last month. I could not get the usb Proprietary plug to stay in the unit. It would just fall out. pressed it in as hard as I could to no avail. Needless to say it would only make sporadic contact, so would never connect to computer. Just a junk connector on a otherwise decent player that makes it worthless.
Sent back for refund.
Any X7 lovers think it is worth another try? I know that this is a known issue with these players. How about someone that has had one for a while, does the usb cable still work? Will it last through 200 to 500 connections? ( usb's have a rated life expectancy).


All times are GMT -5. The time now is 04:58 PM.