abi>>forums

abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Sansa Clip / Clip+ / Clip Zip Rockbox (http://www.anythingbutipod.com/forum/forumdisplay.php?f=228)
-   -   Rockboxed Clip Zip not recognizing 64GB SDXC card (http://www.anythingbutipod.com/forum/showthread.php?t=69330)

Tyrone F. Horneigh 05-18-2012 04:27 AM

Rockboxed Clip Zip not recognizing 64GB SDXC card
 
Hi all,

I have a SanDisk 64GB SDXC card which works fine on the host computer, but my Rockboxed Clip Zip does not recognize it.

I did format the card as appears to be conventional net wisdom, to get rid of exFAT.

# mkfs.vfat -v -n SIXTYFOUR /dev/sdc1

(and then copied 32+ GB of files over)

That didn't work. I thought there was a chance mkfs didn't pick the right FAT size (however unlikely), and tried again:

# mkfs.vfat -v -F 32 -n SIXTYFOUR -m /tmp/NOBOOT /dev/sdc1

(and copied files over)

Still no dice. The filesystem mounts and works fine on my desktop machine.

The player behaves as if no card is inserted. No <microSD1> in the Files menu, and System->Rockbox Info says "HD1 not present".

Any tips? Who has gotten this to work?

TackyTiger 05-18-2012 05:44 AM

I think you also have to set the partition type to FAT32 in fdisk (or the like).

WalkGood 05-18-2012 05:48 AM

TackyTiger your right. While I'm running with a 32GB, so I don't have the 64, from all that I've read it does need to be formatted to FAT32 then it should work fine.

Tyrone F. Horneigh 05-18-2012 12:57 PM

TT, that sounds extremely plausible. Thanks!

Bah. My fdisk is mac-fdisk so it doesn't recognize the DOS partition map and wants to make an Apple one. Gar. Off to hunt up a utility for creating DOS partmaps...

WalkGood, what he's talking about, and the filesystem format are two subtly different things. DOS partition tables include an entry (just a single byte, really) which claim the intended use for the partition. Most of the time it indicates a filesystem type for the partition, so that a boot loader or OS kernel can load appropriate functionality which will then be used to interpret the data on the partition. (An alternative would simply be to scan the first several bytes of the partition and use heuristic methods.)

A list of DOS partition table type fields is available here: http://www.win.tue.nl/~aeb/partitions/partition_types-1.html

What probably happened is SanDisk (the manufacturer)'s partition map still has the only partition on the disk marked as exFAT and RockBox is happily ignoring it. When I formatted the disk, I formatted only the existing partition (sdc1, not sdc), not the whole drive, and I certainly did not use dd to zero out the whole device first. :)

I'll report back later. Thanks again, TT. Even if this doesn't turn out to be it, it's a damn good guess. :)

Tyrone F. Horneigh 05-18-2012 02:28 PM

That fixed it. Slid the card into an SD adapter and slid that into an x86 Linux laptop.

Unmounted the filesystem, which auto-mounted on insert.

# fdisk /dev/sdb

p
t
b
p
w
q

Pop the card back out, slap it into Rockboxed Clip Zip, and whammo. <microSD1>

Thank you, TackyTiger. Clue needed, clue applied!


All times are GMT -5. The time now is 02:32 AM.