abi>>forums (http://www.anythingbutipod.com/forum/index.php)
-   Sansa Fuze Rockbox (http://www.anythingbutipod.com/forum/forumdisplay.php?f=229)
-   -   Files Vanishing (http://www.anythingbutipod.com/forum/showthread.php?t=69731)

Capt. Z 06-19-2012 08:54 AM

Files Vanishing
I do have a rockboxed Fuze and usually all works fine. However, I had bought some 32 gb chips to expand the memory.

The problem comes in when I try to load some files on the chip. I have tried over and over to copy files on the mini chip. My windows explorer shows the file on the chip and will play the file on the PC.

When I place the chip back into the Fuze I see the file, but its empty. When I put the chip back into the PC the file show empty their as well.

Not sure what's going on here and how to fix it.:confused:

Forgot to mention that sometimes the files transfer successfully to the chip and then can be read by the Fuze.

skip252 06-19-2012 09:08 AM

Sounds like you didn't reset the USB transfer mode to MSC after installing Rockbox. Files loaded in MTP can't be seen in Explorer if the players is in MSC. That works both ways. If you load in MSC you won't see the files in Explorer if the player is in MTP USB mode.

I'd unload the player and pick MSC and lock it in. All your files should show once they get transferred then. Rockbox doesn't work well with MTP.

Vanishing files should only be a problem if you're transferring files using the sandisk firmware. Rockbox USB isn't working for you?

Capt. Z 06-19-2012 09:27 AM

Just checked. The Fuze is in MSC mode.

I bought the Fuze about 2 years ago and it came Rockboxed.

The USB is recognized 95 % of the time by the Computer.

NOW, I was only able to check the USB mode while using the sandisk firmware, afte unplugging the Fuze from the USB cable.

Is there a place to check the USB mode using the Rockbox firmware?

FreeZ5 06-19-2012 09:31 AM

skip might be better able to comment on this, but isn't this description typical of fake memory cards, ie they claim to be 32GB and show as 32Gb but are actually smaller.

I haven't had a fake card so can't speak from experience, just what I recall reading.


Capt. Z 06-19-2012 09:45 AM

I just ordered another 16 gb card from San Disc.

I have 2 32 gb cards from Kingston.

Interesting thing was that I was able to put the files on the chip, and play it with the computer while the chip was still in the computer.

But after removing the chip from the computer to place it in the Fuze made the file GO EMPTY, meaning that the file name still showed up, but it was empty. After moving the chip back into the computer showed the file name, but an empty file.

WalkGood 06-19-2012 09:51 AM

Have you tried to format the card and reload?

skip252 06-19-2012 09:56 AM

There's no place to check the USB transfer mode in Rockbox because it's always MSC mode. MTP is sandisk firmware only.

If you've been transferring all your files using Rockbox I would test using the sandisk firmware by trying to move a few GB back and forth. If the files transfer using the sandisk firmware and not Rockbox, it's a Rockbox problem. There's been some problems reported with Rockbox USB recently. The transfer may be silently aborting giving the impression a transfer has occurred and it hasn't.

If they don't transfer properly using the sandisk firmware I'd get a copy of h2testw and check to see if the card is what it claims to be. Steve's right that vanishing files can also be a symptom of a bogus card. h2testw reads/writes to every sector of the card and will let you know it's true capacity.

BTW have you updated from the Rockbox version that was installed when you got it? If you decide to update you'll want to be aware there's been a couple of theme breaking skin syntax changes that will almost certainly cause you to need to update any skin you are using now.

If you decide to or want to upgrade I'd use the automated installer. There's been a lot of work put into it recently and it install updates even better than it did in the past.


Are you safely removing after the file transfer? Removing a connection during USB transfer can cause file corruption. One of the symptoms of that can be "ghost" files that show names but no content.

Capt. Z 06-19-2012 11:52 AM

Thanks for all the info.

At the moment I am formatting the external chip. Will go on the above mentioned test site and test the chip once it has finished formatting.

I have not update Rockbox since I've got the player. What is the best way to update it?

I don't think it's a case of ghost files, since I usually transfer them on the external memory, while the external memory chip is in my laptop for file transfer. The content of the file vanishes after the memory card has been put back into the fuze.

FreeZ5 06-19-2012 12:23 PM

Here's another suggestion...

I read recently that by default Rockbox has a limit of 1000 files per folder. I don't know for certain that this is true, but how many files are you putting per folder on the memory card?

That might explain why the files work on the PC, but not after the card is put in the Fuze.



Capt. Z 06-19-2012 12:26 PM

there are usually no more than 20 or so files in one folder.

WalkGood 06-19-2012 12:34 PM

Another thought, files do not have to be tagged for you to see them on you pc but depending on how you are viewing them in rockbox they do (via db browser). Are the files properly tagged? If you don't have any software, download mp3tag and look at the files via it to check tags or correct. http://www.mp3tag.de/en/ BTW it's free.

Capt. Z 06-19-2012 04:50 PM

Well, it looks like the chip is bad.

Only 1 Gb ok, 30 Gb bad

Der Datenträger ist wahrscheinlich defekt.
989 MByte OK (2025472 Sektoren)
30,0 GByte DATEN VERLOREN (63066112 Sektoren)
0 KByte überschrieben (0 Sektoren)
0 KByte leicht verfälscht (< 8 Bit/Sektor, 0 Sektoren)
30,0 GByte mit Datenmüll (63066112 Sektoren)
0 KByte mehrfach genutzt (0 Sektoren)
Erster Fehler bei Offset: 0x000000003cdebe00
Soll: 0x000000003cdebe00
Ist: 0x0000000000000000
H2testw Version 1.3
Schreibrate: 3,07 MByte/s
Leserate: 6,27 MByte/s
H2testw v1.4

Capt. Z 06-20-2012 02:12 AM

Second 32 gb chips is not much better.

Der Datenträger ist wahrscheinlich defekt.
951 MByte OK (1947648 Sektoren)
30,1 GByte DATEN VERLOREN (63143936 Sektoren)
0 KByte überschrieben (0 Sektoren)
0 KByte leicht verfälscht (< 8 Bit/Sektor, 0 Sektoren)
30,1 GByte mit Datenmüll (63143936 Sektoren)
0 KByte mehrfach genutzt (0 Sektoren)
Erster Fehler bei Offset: 0x000000003a8ebe00
Soll: 0x000000003a8ebe00
Ist: 0x0000000000000000
H2testw Version 1.3
Schreibrate: 3,41 MByte/s
Leserate: 6,20 MByte/s
H2testw v1.4

Capt. Z 06-20-2012 02:14 AM

Thanks guys for your super fast response and support.

Will scan each chip I buy in the future with H2yestw.

skip252 06-20-2012 07:56 AM

Sorry to here you got bad cards. I don't hear of as many fakes as I did when the 32 GB cards first hit the market but it seems they're still being made.

Could you post the name of the vendor? Knowing who to avoid might help the next person avoid the hassles you had.

Capt. Z 06-20-2012 08:23 AM

The chips show the name kingston. Thought that was a descent brand.

Bought them of eBay.co.uk about 3/4 of a year ago. Seller was from Ireland. It took forever for the chip to arrive. So I inquired, no response from seller.

Shorty later the chip arrived, probably from Japan or China. Then a few weeks later I received another chip. I thought I 'hit the jackpot' when I got 2 32gb chips for a low price. But now it turns out their are rubbish.

Just like this one.

WalkGood 06-20-2012 08:26 AM

Yea that sucks and I didn’t think that could have been it with all that’s been written about scam/fake SD cards :/

Two points when it comes to cards; one – I never buy SD cards from ebay, no matter how great one’s rating is. Two - if the deal is too good to believe, don’t fall for it if it’s not from a reputable dealer that will allow returns/exchanges. Hope you can get exchange or your money back ...

All times are GMT -5. The time now is 07:38 PM.