android
  #1  
Old 02-20-2010, 01:06 AM
chlore chlore is offline
Junior Member
 
Join Date: Feb 2010
Posts: 1
Default 'clix'ing

I've been using my clix2 for about two years now, and I love it to bits (almost literally-I've dropped it a few times :/ )
Everything was working perfectly for a while until about a month ago when I noticed the down button didn't make an audible clicking sound when I used it.(The up and left made perfectly audible sounds.)
It didn't seem to be a problem, but upon closer inspection, I noticed the ridge between the clicking part of the mp4 and the part that 'recieved' the click was larger on the upper side than it was on the lower.
They don't seem to affect my mp4's performance, but I can't help but wonder if any dust won't get in between the upper gap, and if this could be a looming sign of more problems?
Thanks 8D
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 05-11-2010, 07:03 AM
fiode fiode is offline
Junior Member
 
Join Date: May 2010
Posts: 5
Default

The button has somewhat sunk down, have the same thing with my left button disassemble if you wanna see.

Clix, mah clix's dead it's battery or USB or something or everything is dead and I dunno why I barely even touched it for 2 month it's got all dusty and Dead... it used to work fiiine T_T
God why have you forsaken me?

Last edited by fiode; 05-11-2010 at 07:30 AM.
Reply With Quote

Reply

Tags
click, clicking sound, dust, gap

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 04:49 PM.