android
  #1  
Old 05-06-2010, 06:56 PM
Coolvibes's Avatar
Coolvibes Coolvibes is offline
Member
 
Join Date: May 2008
Location: Spain
Posts: 353
Default How do M1 Feature Album art?

I have Version 1.23 firmware set to MTP in Eu region with Mp3 files
I have no problem with Album art using ID3 tag software until now
When using several album arts inside a album M1 picks the album art for feature display it likes best for no reason

What i want to do is use more than one album art for 1 album
but then i want the album art i have at Song nr.1 to apear featured in the album browser.

This is normaly not problem when there is just one album art for all song in that album but since i have many M1 choose the album art it want

For me it picked album art from song nr.15
I though maybe M1 pick the album art from about the middle of the songs
(is 25 songs in that album)
I then i changed that album art to something else and expected it to still pick song nr.15 with the new album art when browsing albums

but now it featured album art from song nr.23 instead.

I then though M1 must choose the album art by random each time
i conect m1 or change a album art
so I changed the album art on song nr.15 back to what it was
expecting M1 to pick another new album art
but instead M1 now pick song nr.15 again

I then cheched if it could be the image Jpg Size of the album art if is the biggest size that is choosen but that was not the case.
i even checked in the ID3 tags but could not find any reason why M1 would pick the album art from song nr.15 (And song nr.23 when album art in nr.15 was changed)
Is not Random either.

Can anyone try to find this out
I have like 10 different Albums arts for a special album
but i want Sonr nr.1 to be the featured album art when browsing album selection menu...

IT is just so strange how M1 pick the album art
I like to find out how M1 chooe what song in the album to feature the album from in menu
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 05-07-2010, 08:02 PM
pgh1969pa pgh1969pa is offline
Senior Member
 
Join Date: Jul 2007
Posts: 578
Default

Usually, a mp3 player will only display one of the album images in an id3 file. The one it displays is the one listed as 'cover' and the others are ignored. I would first check my tags to make sure that you have the right image listed as 'cover'. Because of the problems with compatibility, I always only place one image in each song and tag every song with that same image.
Reply With Quote

  #3  
Old 12-07-2010, 03:55 AM
MrHaze's Avatar
MrHaze MrHaze is offline
Junior Member
 
Join Date: Jul 2007
Location: Milano, Italy
Posts: 43
Default album art problems

Hi folks.
i have some problems too with album art displayin in YP-M1...
I know my typical situation is slightly different from other's, due to the fact that I use only linux systems.
btw, let's get straight to the point.
Yesterday i was at home charging some music on the player. Banshee was the program choosen to manage all of those kind of operations.
No problem at all, must I say, BUT, once fired the player, i found some album art showing like the one in the image attached.
This happened randomly, because I first deleted some music to adjust album tag and id3 tag, then recharged the same album (for example Sia - Healing is difficult) that was previously shownig correctly, but the second time is showing itself like the one in the image...
The image in particular is referring to "How I got over" from the Roots.
Is someone aware of this problem and know how to solve it?
I did some tryouts.
first i deleted all the album from M1
then i deleted the .alb file referred to the album.
third passage was to recharge again the same album, corretly tagged with album art and so on...and the album is still showing badly when playing.
Could it be determined by the starting cover image size? are some dimensions best than others?
i really don't know how to act now to correct the problem.
any help / ideas?
Attached Images
File Type: jpg CIMG0043.jpg (21.0 KB, 15 views)
__________________
Proudly endorsing anything not Apple!
Reply With Quote

  #4  
Old 12-11-2010, 06:33 AM
MrHaze's Avatar
MrHaze MrHaze is offline
Junior Member
 
Join Date: Jul 2007
Location: Milano, Italy
Posts: 43
Default

nothing to do.
after i did a memory format from the player, i started to some tests with album art, using variuos linux players to transfer music.
The problem of the last post, must be related to a particular portion of the transfer process, OR, as I see it, it must depends from the original album art cover dimension.
By the way those are the test result so far.
Banshee 1.9 - transfer music without problem, but keep me returning bad covers on the player. it's a random process. sometimes cover are included correctly, sometimes not. for example: first time i transferred the whole album "wake up" by john legends and the roots, cover on the player was screwed up. second time it transferred good.
Clementine 5.3 - music transfer is as flawless as for banshee, maybe quicker, but same result for cover art. the "American Gangster" OST transferred correctly. the "A place to call home" cover by joey tempest has visualizing errors on the player.
I will do some more tests (Rhythmbox, Exaile and so on) but as i perceive the thing, is libmtp and THIS player not going hand in hand.
For instance, same music on P2 has never had any difficulties. cover art are ALL correct, and same for the music.
Again, any suggestion/help/trick?
Uh, almost forgot. some albums, worked with easy tag on ubuntu, and so, every song on an album has his own cover, are not recognized by the player. so it will use the standard vinyl image. is the case for "The Future is Now" by Non Phixion.
any help will be appreciated. thank you
(i hate not having cover art on my pmp)
__________________
Proudly endorsing anything not Apple!
Reply With Quote

  #5  
Old 12-13-2010, 04:12 PM
meetooman's Avatar
meetooman meetooman is offline
Member
 
Join Date: Oct 2009
Posts: 488
Default

Quote:
Originally Posted by MrHaze View Post
Clementine
Have I ever heard of this one?
Searching on the net I learn it's cross-platform and inspired by Amarok 1.4! Call it a dream definition! A big thank you for this incident information!
Reply With Quote

  #6  
Old 12-14-2010, 02:35 PM
MrHaze's Avatar
MrHaze MrHaze is offline
Junior Member
 
Join Date: Jul 2007
Location: Milano, Italy
Posts: 43
Default

glad to be useful
I must say that the player is very valid, though it still has some transfer problem with some element (such as album or cover art)
It also support (only under linux) the wiimote via usb bluetooth dongle adapter and the Wiimotedev package.
That said, I did some more testing.
AND FINALLY SOLVED!
it was, after all the damn ID3 v2.4
Now working with Kid3-qt and Clementine is everything almost perfect
Puddletag can only tag v2.4 cause of the library used.
Under GNU/Linux is an hard life....but when u succed...it's just satisfaction.
now the M1 rock at full potential, since with 1.35 fw they solved the transfer via linux too.
__________________
Proudly endorsing anything not Apple!

Last edited by MrHaze; 02-21-2011 at 12:22 PM. Reason: Solved.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 03:40 AM.