android
  #1  
Old 10-26-2007, 08:05 AM
Zeddicus Zu'l Zorander's Avatar
Zeddicus Zu'l Zorander Zeddicus Zu'l Zorander is offline
Ultra Senior Member
 
Join Date: Dec 2006
Location: Perth, Australia
Posts: 1,283
Default UMS firmware for the T10

A UMS (MSC) firmware (version 1.27) may now be downloaded, here.

It might not be possible to install a UMS firmware on the T10 (which is already running MTP firmware) since this is the case with the U3 and possibly the P2 which revert back to MTP firmware when trying to install a UMS version. Neither of these two players are damaged, or effected in any way when failing to install another firmware, so if anyone wants their T10 to be a UMS device, it's worth a try.

Here are the steps posted by Samsung:
Quote:
How to upgrade YP-T10 Firmware

- Before upgrade process, please check your battery status.
- Connect the player to your computer.
- unzip downloaded zip file on your PC
- Copy the 2 files into the root directory of the YP-T10.
- Select Safely Remove Hardware and remove the YP-T10 from the USB port of the computer.
- When you turn the player on, firmware updates are automatically performed during booting.
- To confirm an update,
Select MENU -> SETTING -> SYSTEM INFO from the menu to view the firmware version

Not sure what the difference between MTP and UMS is?

Very basically, they are two different means that the T10 can be connected to a computer, each having some advantages and disadvantages: Only MTP firmware is compatible with WMA-DRM files which many online music download services provide, while UMS firmware will connect the T10 in the same way as an ordinary storage device allowing it to connect to almost any computer (regardless of its operating system).
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 10-29-2007, 04:04 PM
initer initer is offline
Junior Member
 
Join Date: Oct 2007
Posts: 3
Default

Has anyone actually been able to install this update? I've tried the instructions above but the player doesn't update the firmware (or any other firmware for that matter). I have a YP-T10JAB.
Reply With Quote

  #3  
Old 10-29-2007, 09:19 PM
f-rouz f-rouz is offline
Junior Member
 
Join Date: Oct 2007
Location: Germany - so please excuse my poor English ;)
Posts: 34
Default

Unfortunately, it also didn't work with my European YP-T10JCB which actually has the 1.20 MTP running...
__________________
Samsung YP-T10JCB (2007, 8GB), IRiver H120 (2004, 20GB), 3x broken Trekstor Vibez (2006-2007, 12GB)
Reply With Quote

  #4  
Old 10-30-2007, 11:48 AM
Zolxen Zolxen is offline
Member
 
Join Date: Oct 2007
Posts: 220
Default

Quote:
Originally Posted by initer View Post
Has anyone actually been able to install this update? I've tried the instructions above but the player doesn't update the firmware (or any other firmware for that matter). I have a YP-T10JAB.
I've run into that too. I havent tried installing this firmware, and I might not. I think i'll keep it MTP for now. But question, The Samsung Media Studio software has an option to upgrade firmware on a connected player. Does this feature actually work? I tried it with the "new" firmware released (1.20) and even though I have 1.19 BB (i guess the BB is a country code from what I've read), it wouldnt find the update and install it. And I never really noticed if it did or not on my old T9.
Reply With Quote

  #5  
Old 10-30-2007, 02:07 PM
initer initer is offline
Junior Member
 
Join Date: Oct 2007
Posts: 3
Default

I've tried the upgrade firmware option in Samsung Media Studio as well and haven't had any luck. It seems like it is doing a website check, but even though version 1.20 is on the website it still says there are no updates (my player has v.1.99 BB). Does anyone know if this firmware update feature is looking somewhere on the harddrive for a firmware to update with?
Reply With Quote

  #6  
Old 11-04-2007, 05:19 PM
sir_rath sir_rath is offline
Junior Member
 
Join Date: Nov 2007
Posts: 23
Default

I'm sorry, this might sound a bit dumb, but I'm unable to copy anything into the root directory. I just can copy files to the "data" and "media" folders. What do I do wrong?
Reply With Quote

  #7  
Old 11-04-2007, 10:49 PM
Zeddicus Zu'l Zorander's Avatar
Zeddicus Zu'l Zorander Zeddicus Zu'l Zorander is offline
Ultra Senior Member
 
Join Date: Dec 2006
Location: Perth, Australia
Posts: 1,283
Default

Do you have WMP10 installed by any chance? If so, you may have to use the System/Data folder instead of the root.
Reply With Quote

  #8  
Old 11-05-2007, 02:06 AM
sir_rath sir_rath is offline
Junior Member
 
Join Date: Nov 2007
Posts: 23
Default

Yes, I have wmp10 installed. I already tried the system/data folder, because I guessed it would make sense to put the files there, but nothing happened, as I restarted the player. Has anybody sucsessfully done this firmwarechange yet? It is pretty essencial for me, because I'm using a mac and it absolutely s***cks to reboot and start windows via bootcamp just to put some songs on my musicplayer.
Would it help to format the player, using the windows format tool (via right mouse button) and the copying the firmware files to the blank player?
Reply With Quote

  #9  
Old 11-05-2007, 03:51 AM
sir_rath sir_rath is offline
Junior Member
 
Join Date: Nov 2007
Posts: 23
Default

Okay, I've got it. The files had to be renamed to T10J.* and the kopied into the data folder. The player starts updating, but then says "please update rsc file. So no luck. Is there a more recent ums firmware from samsung?
Reply With Quote

  #10  
Old 11-05-2007, 04:00 AM
Zeddicus Zu'l Zorander's Avatar
Zeddicus Zu'l Zorander Zeddicus Zu'l Zorander is offline
Ultra Senior Member
 
Join Date: Dec 2006
Location: Perth, Australia
Posts: 1,283
Default

I'd say you were doing nothing wrong by putting the files in the Data directory. Looks like you've had the same response as everyone else who haven't had success either.
Reply With Quote

  #11  
Old 11-06-2007, 01:17 AM
sir_rath sir_rath is offline
Junior Member
 
Join Date: Nov 2007
Posts: 23
Default

Is there any chance for an ums firmware for this device? I'm not quite sure if I may ask such questions in this forum, but are there in general firmware hacks for mp3 players like there are for, let's say, Sony's PSP?
Reply With Quote

  #12  
Old 11-06-2007, 07:37 AM
Zeddicus Zu'l Zorander's Avatar
Zeddicus Zu'l Zorander Zeddicus Zu'l Zorander is offline
Ultra Senior Member
 
Join Date: Dec 2006
Location: Perth, Australia
Posts: 1,283
Default

Hacked or alternate firmware have never been developed for any Samsung players that I know of. That doesn't mean it isn't possible in the future though. The best hope of a UMS support is if Samsung decides to release a compatible firmware. This is more likely to happen, as misterx has reported here.
Reply With Quote

  #13  
Old 12-04-2007, 11:45 AM
foxx foxx is offline
Junior Member
 
Join Date: Dec 2007
Location: Germany
Posts: 44
Default

Does anyone got it working? I have an YP-T10JAW with 1.29 EU firmware and nothing is happening when I try to use these firmware files :-/

foxx
Reply With Quote

  #14  
Old 12-04-2007, 02:38 PM
BlueFyre BlueFyre is offline
Junior Member
 
Join Date: Dec 2007
Posts: 4
Default

Are there any new than 1.29 firmwares?
Reply With Quote

  #15  
Old 12-10-2007, 06:50 PM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,686
Default

I need some people to try this way:

download the 1.29 UMS here:
http://www.samsung.com/he/Support/Pr...55881119983375

Copy the files T10.ROM, T10.RSC AND the config.dat file in "attach files" in the T10.

I hope it will become UMS!
Attached Files
File Type: zip CONFIG.zip (135 Bytes, 171 views)
Reply With Quote

  #16  
Old 12-12-2007, 04:53 PM
fde fde is offline
Junior Member
 
Join Date: Dec 2007
Posts: 20
Default

Hi lebellium! I tried what you propose with a European (Belgian) MTP YP-T10. It did not work. In a first time, I thought it was just because of the name of the firmware (in Europe it must be "T10J.ROM" and "T10J.RSC" and not just "T10"), but even after having renamed them, my player says "invalid firmware".
Reply With Quote

  #17  
Old 12-12-2007, 05:31 PM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,686
Default

Yep that's a pity.
That does not work on a french T10 too...

I don't understand why it works on the P2 and not on the T10 whereas they both have the same base
Reply With Quote

  #18  
Old 12-14-2007, 04:07 PM
fde fde is offline
Junior Member
 
Join Date: Dec 2007
Posts: 20
Default

Still no solution?
Reply With Quote

  #19  
Old 12-14-2007, 04:40 PM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,686
Default

At the same time, nobody seems to be looking for a solution....
Reply With Quote

  #20  
Old 12-14-2007, 08:08 PM
shinobi00 shinobi00 is offline
Member
 
Join Date: Apr 2007
Posts: 274
Default

Guys, please call samsung and send them an email about this issue. We want to install other firmwares on our player. If we bug them enough(as the tech said) they'll eventually get to it.
Reply With Quote

Reply

Tags
firmware, msc, t10, ums

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 03:33 PM.