android
  #1  
Old 10-01-2008, 11:19 PM
ipod-killah ipod-killah is offline
Junior Member
 
Join Date: Sep 2008
Posts: 13
Default S60 only runs with AC, replaced battery

I did post a similar thread but it was in the sub category and i think it isnt as buisy as here.

anyway. my tioshiba giabeat S-60gb will only turn on via the AC wall charger, there is no battery icon at all.
so i went on ebay and bought a 1000mah mes60 GB battery. i put it in and the same thing.
it will only turn on via the AC charger. i have turned the battery switch (at the bottom) on and off several times. so it IS on.

*replaced battery
*turned battery switch ON
*i re-oppened the case after the player was off, and plugged into the charger for over 3.5 hours. it would normaly be charging. the battery felt warm, but could this be from the HDD (i had it on for ~1minute before re-oppening) or even just the power running through it.

is there anyway that the battery switch is broken, as if a wire has come of it.

but for now i guess its prety much screwed and know more toshiba GB for me, but hell no to ipoofter.

thankyou,
ipod-killah
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 10-24-2008, 03:57 PM
thomascw thomascw is offline
Junior Member
 
Join Date: Oct 2008
Posts: 1
Default

I've got the exact same problem with an s30. also replaced with 1000mah battery from ebay. still only runs on ac. Any luck with yours? My son went jogging in the rain just prior to mine giving up. It works fine plugged in. Battery life was terrible(2 hours with only music) when new.

Tom
Reply With Quote

  #3  
Old 11-13-2008, 03:26 PM
soap soap is offline
Rockbox Staff
 
Join Date: Nov 2008
Posts: 19
Default

I would start by using a multimeter to verify that the battery switch itself is not faulty.
Since you felt warmth on the battery, there is a good chance it is receiving power - can anyone with a working unit verify if Gigabeats will charge with the switch in the "off" position?

EDIT: Been informed by toffe82 that the switch can not be the problem IF indeed the battery is charging. You need to verify that yes indeed the battery is receiving power and that the battery fuse is not open.
If there is anyone outside Toshiba who knows what is what under the hood of a Gigabeat, it is toffe82.

Last edited by soap; 11-16-2008 at 07:24 AM.
Reply With Quote

  #4  
Old 11-15-2008, 05:13 PM
toffe82 toffe82 is offline
Junior Member
 
Join Date: Nov 2008
Posts: 1
Default

There is a fuse between the switch and the battery, the only problem is to find it.
Check the power diagram here :
http://www.rockbox.org/twiki/bin/vie...ck_diagram.png

Sorry I didn't read the reply of Soap.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:27 AM.