android
  #1  
Old 06-23-2008, 09:09 AM
mcbobie mcbobie is offline
Junior Member
 
Join Date: Mar 2008
Posts: 9
Default Freezing when deleting media

My Fuze has just started acting up whenever I ry to delete something with the player it freezes up, I then have to turn it off and back on, then I get the refrshing media bar and all is well, till I try to delete again. Anybody else have this problem?
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 06-23-2008, 12:38 PM
V3ndetta's Avatar
V3ndetta V3ndetta is offline
Member
 
Join Date: Jun 2008
Location: Ontario
Posts: 196
Default

It hasn't happened before? But it jsut started now?
Reply With Quote

  #3  
Old 06-23-2008, 05:35 PM
mcbobie mcbobie is offline
Junior Member
 
Join Date: Mar 2008
Posts: 9
Default

Quote:
Originally Posted by V3ndetta View Post
It hasn't happened before? But it jsut started now?
Correct I've had for over a month now and this just started.
Reply With Quote

  #4  
Old 07-16-2008, 10:44 AM
201d 201d is offline
Junior Member
 
Join Date: Jul 2008
Location: San Juan, Puerto Rico
Posts: 13
Default

I've had that problem since day one :-(

I just decided i'd delete the stuff when sync-ing
Reply With Quote

  #5  
Old 10-22-2008, 01:45 AM
rogerbinns rogerbinns is offline
Junior Member
 
Join Date: Oct 2008
Posts: 2
Default

I just got a new Fuze the other day and see this with podcasts which I delete after listening to. Firmware 15 and MSC mode. Basically it is actually deleting the file, it is just that the firmware is eye wateringly slow at it and doesn't update while the deletion is happening. If you wait long enough things will resume. In my case long enough is about a minute. Amusingly it often has long pauses just entering the yes/no delete confirmation where the wheel has no effect for about 15 seconds.

My best guess at the underlying cause is that the firmware is trying to remove the tag information from the tag database. mp3 tags can be stored at the begining or end of file depending on version etc. Chances are the player is reading the entire file from the begining to end to find all tags. Combine that with the VBR bug (where it slows the cpu on low bitrate frames and then is too slow on a following high bitrate frame) and it all makes for good speculation.
Reply With Quote

  #6  
Old 11-11-2008, 02:08 AM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Help

Quote:
Originally Posted by mcbobie View Post
My Fuze has just started acting up whenever I ry to delete something with the player it freezes up, I then have to turn it off and back on, then I get the refrshing media bar and all is well, till I try to delete again. Anybody else have this problem?
Quote:
Originally Posted by 201d View Post
I've had that problem since day one :-(

I just decided i'd delete the stuff when sync-ing
Quote:
Originally Posted by rogerbinns View Post
I just got a new Fuze the other day and see this with podcasts which I delete after listening to. Firmware 15 and MSC mode. Basically it is actually deleting the file, it is just that the firmware is eye wateringly slow at it and doesn't update while the deletion is happening. If you wait long enough things will resume. In my case long enough is about a minute. Amusingly it often has long pauses just entering the yes/no delete confirmation where the wheel has no effect for about 15 seconds.

My best guess at the underlying cause is that the firmware is trying to remove the tag information from the tag database. mp3 tags can be stored at the begining or end of file depending on version etc. Chances are the player is reading the entire file from the begining to end to find all tags. Combine that with the VBR bug (where it slows the cpu on low bitrate frames and then is too slow on a following high bitrate frame) and it all makes for good speculation.
I've also been deleting while syncing the last few days, since this happened to me.....but tomorrow I'll try again and try to remember to be patient and see if it actually is just going really slow. It has made no difference whether or not my microsdhc is inserted.....so one variable eliminated, anyway
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #7  
Old 11-11-2008, 11:09 AM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

figures.....it works perfectly today...lol
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #8  
Old 11-17-2008, 01:04 PM
ranger67 ranger67 is offline
Junior Member
 
Join Date: Apr 2007
Posts: 47
Default

Just a thought on why the "delete" is soooo slow. What if, Instead of just deleting entries, the unit is also performing a "refreshing media" in the background. I've timed it, and the delete and initial "refreshing media" seem to be almost identical.
Reply With Quote

  #9  
Old 11-17-2008, 01:40 PM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Quote:
Originally Posted by ranger67 View Post
Just a thought on why the "delete" is soooo slow. What if, Instead of just deleting entries, the unit is also performing a "refreshing media" in the background. I've timed it, and the delete and initial "refreshing media" seem to be almost identical.
That makes sense, except that mine stopped doing it....so I dunno
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 02:47 AM.