android
  #1  
Old 09-30-2008, 06:09 AM
ipod-killah ipod-killah is offline
Junior Member
 
Join Date: Sep 2008
Posts: 13
Default my S60 only turn on via charger, replaced battery

i thought it was the battery so i replaced it. and it still doesnt work. its been charging for over three hours and still no icon. i opened it back up again and pushed the wires to see if they were loose.

so what do i do now? never buy a toshiba product again. seeing as my first player was a gigabeat F. and i though my next would be some ultimate thing created by toshiba. well screw them.

thankyou anyone.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 09-30-2008, 01:39 PM
jac0b jac0b is offline
Member
 
Join Date: Nov 2006
Posts: 136
Default

Is the battery switch, switched to on?
__________________
Player: Gigabeat F40/S30
Firmware: Rockbox Simple F Series Branch, Rockbox Simple S Series Branch
Headphone: MDR-V150 / HA-FX34 / HA-FX66 / KSC75
Reply With Quote

  #3  
Old 09-30-2008, 07:13 PM
ipod-killah ipod-killah is offline
Junior Member
 
Join Date: Sep 2008
Posts: 13
Default

yes it is turned on.
Reply With Quote

  #4  
Old 12-18-2008, 11:14 PM
mgps mgps is offline
Junior Member
 
Join Date: Jul 2007
Posts: 16
Default

Your "new" battery may have been DOA. These lithium ion batteries have a shelf life of a couple years. If it had been sitting on the dealers shelf for a couple years, that could explain it.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:41 PM.