android
Prev Previous Post   Next Post Next
  #1  
Old 11-05-2009, 03:59 PM
Golden Ears's Avatar
Golden Ears Golden Ears is offline
Junior Member
 
Join Date: Nov 2009
Location: England, United Kingdom
Posts: 2
Default Sony NWZ-B143 too quiet/poor quality.. help needed

Hello abi people, I've benn a lurker for quite a fair while here. However, I really need a solution to a problem I have with my new dap I bought a few weeks ago.

Background: I was happily owning a Sony NW-E013 lipstick style player for a couple of years, until a couple of weeks ago when I left it on a shop counter, and when I went back some tosser had nicked it.
It had superb sound quality (considering it was the no bells and whistles model at the time), brilliant max volume, and a very user-friendly interface with a little LCD colour display. Even though I had to use SonicStage to transfer files, it didn't bother me too much because the hassle pays off with a great organisation of music/albums etc.

So, I couldn't go without a dap, you know. It just feels wrong to not have your music with you wherever you are, it's a basic fundamental human right. So I went to the nearest store selling mp3 players, and found out that my previous model was no longer produced by sony. Damn. So I went with what looked like the replacement, the B series stick type (because I don't care about video, radio, bluetooth, internet whatever). Just the basic Sony mp3 player. It looked uglier than my previous model, but I thought "ahh, you can't judge a book by it's cover, right?" Wrong.

Got home, charged it up by usb, found out that it no longer needed SonicStage (to my dissapointment actually), and only needed drag n drop or MTP by WMP. So a few of my favourite albums on there, and put in the stack cans. It sounded terrible. So quiet, I thought I had AVLS on, I checked, it was off. All my mp3s are encoded at 320kb/s and no less, becasue sound quality is top priority for me. But the tracks sounded more like 96kb/s, like Myspace Music quality. No punch, no life or crisp to the music, limited dynamic range.

I have been searching and searching and searching for an answer for my model, and I swear there must be a fix, either something to do with EU volume restriction or bad microcode in the ICs controlling the DAC circuitry whatever, firmware whatnot. But all the fixes online are for the NWA-xxx series players, and Apple iPods. I cannot find a way to get into the service menu of my stick, or hack the firmware, or whatever hocus-pocus needs to be done to get it sounding good.

Please, somebody shed their attention to this disgraceful model of players - they all seem to be receiving great reviews from people all over the place, have I got a duff model? Is it that Sony have decided after two years that the sound quality of their low-end players is no longer important compared to the HD video and other stuff of their high end models? Can I replace the DAC with one from my old Sony Discman?

Music is so important to me, even though I am not made of money, please help. Thankyou.
Reply With Quote

Advertisement [Remove Advertisement]

 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 10:11 AM.