android
  #1  
Old 12-05-2009, 01:40 PM
shopao shopao is offline
Junior Member
 
Join Date: Nov 2009
Posts: 36
Default audio doesnt match with the video

a while ago i tried converting a movie using the ipod touch settings in handbrake, after transferring the movie, i tested it, video works fine with only one thing, audio doesnt match the video! it's like 2-4 seconds delayed. what seems to be the problem? a little help here. thanks guys. sorry for the noobish question.

handbrake settings :

audio codec : AAC (faac)
mixdown : stereo
sample rate : auto
bitrate : 128
DRC : 0
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 12-07-2009, 05:44 PM
TomCat39's Avatar
TomCat39 TomCat39 is offline
Member
 
Join Date: May 2009
Posts: 406
Default

I would notice this effect with videos I converted to my cell phone.

What I found is if I put the video settings to more than the phone could handle (higher Frame Per Second, higher resolution, etc) the audio would get out of sync with the video.

I don't know if this has anything to do with your issue..... But that is one possible culprit I think.
Reply With Quote

  #3  
Old 12-08-2009, 09:19 AM
triarii117's Avatar
triarii117 triarii117 is offline
Senior Member
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 554
Default

What are the video properties set at?
__________________
PMPs: Cowon J3, Samsung P3(touchscreen problems), Creative Zen (4GB, black)
Headphones: Panasonic RP-HTX7, Philips, JVC Marshmallow IEMS (why not)
Reply With Quote

  #4  
Old 12-08-2009, 12:12 PM
shopao shopao is offline
Junior Member
 
Join Date: Nov 2009
Posts: 36
Default

@ TOMCAT : yep, im suspecting that one as well.. but still, i cant get the right settings for my videos to work..

@ TRIARII117 : here it is,

source info

- AVI. 1.6gb file size
- XviD (Mpeg-4), 704x304, 25.00fps, 1.8mbps
- AC3, 6 ch, 48.0khz, 384kbps

and the output info using handbrake with the iphone presets

- container mp4
- 480x272
- video codec : h.264
- about the FPS, im wondering if i set it to "same as source" or i set it to "25fps".
- quality : didnt change anything so it was set at "constant quality 60.78% RF:20

thats it, i hope i didnt miss anything..
Reply With Quote

  #5  
Old 12-08-2009, 01:49 PM
TomCat39's Avatar
TomCat39 TomCat39 is offline
Member
 
Join Date: May 2009
Posts: 406
Default

Quote:
Originally Posted by shopao View Post
@ TOMCAT : yep, im suspecting that one as well.. but still, i cant get the right settings for my videos to work..

@ TRIARII117 : here it is,

source info

- AVI. 1.6gb file size
- XviD (Mpeg-4), 704x304, 25.00fps, 1.8mbps
- AC3, 6 ch, 48.0khz, 384kbps

and the output info using handbrake with the iphone presets

- container mp4
- 480x272
- video codec : h.264
- about the FPS, im wondering if i set it to "same as source" or i set it to "25fps".
- quality : didnt change anything so it was set at "constant quality 60.78% RF:20

thats it, i hope i didnt miss anything..
I wonder if it is only taking the rear channels for sound for the downmix of the audio. Doesn't the rear channel lag behind front and center a touch for surround?

Is there a way to downmix from only the front sound channels?

And 25 FPS is about right for the P3, so not sure there.

Also be sure it's resampling the audio to 44.1Khz. Not sure if the P3 likes 48Khz sampling, but I know without any doubt that it likes 44.1Khz.
Reply With Quote

  #6  
Old 12-08-2009, 04:38 PM
triarii117's Avatar
triarii117 triarii117 is offline
Senior Member
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 554
Default

Yea, changing it to 44.1Hz sampling should fix. It is the standard; why yours is set to 48Hz is beyond me.
__________________
PMPs: Cowon J3, Samsung P3(touchscreen problems), Creative Zen (4GB, black)
Headphones: Panasonic RP-HTX7, Philips, JVC Marshmallow IEMS (why not)
Reply With Quote

  #7  
Old 12-09-2009, 11:13 AM
shopao shopao is offline
Junior Member
 
Join Date: Nov 2009
Posts: 36
Default

Quote:
Originally Posted by shopao View Post
handbrake settings :

audio codec : AAC (faac)
mixdown : stereo
sample rate : auto
bitrate : 128
DRC : 0
so maybe i didnt set the sample rate to 44.1khz.. ok then, i'm giving it another shot. thanks guys. will post the results later.
Reply With Quote

  #8  
Old 12-09-2009, 01:00 PM
shopao shopao is offline
Junior Member
 
Join Date: Nov 2009
Posts: 36
Default

after an hour of converting a movie...







.... it was a SUCCESS!! now i know the proper settings for my handbrake and for my videos as well.. thanks guys. that 44.1khz saves the day!
Reply With Quote

  #9  
Old 12-09-2009, 06:28 PM
triarii117's Avatar
triarii117 triarii117 is offline
Senior Member
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 554
Default

Good
__________________
PMPs: Cowon J3, Samsung P3(touchscreen problems), Creative Zen (4GB, black)
Headphones: Panasonic RP-HTX7, Philips, JVC Marshmallow IEMS (why not)
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 12:06 PM.