android
  #1  
Old 11-01-2010, 04:12 AM
Nausicaa's Avatar
Nausicaa Nausicaa is offline
Junior Member
 
Join Date: May 2010
Posts: 65
Default v1 (rb'd) Cannot connect to PC

I have a Clip that doesn't want to connect to PC. It charges and plays but it doesn't wanna connect.

In rockbox it cannot see the files if I use the explorer, but I refreshed the database and it works via database! What the hell?!
It also goes into media mode for one second and then goes back to the regular screen if that helps. This is bugging me, I need to put new music on it.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 11-01-2010, 04:32 AM
epithetless's Avatar
epithetless epithetless is offline
Ultra Senior Member
 
Join Date: Jul 2007
Location: Boston, Mass
Posts: 1,610
Default

The Clip does not have USB data capability in Rockbox at this time. You'll need to boot into the original firmware (by holding the left/rewind button or the home button during bootup) first, and use that to transfer files. As for the song files not being visible on your player, I'd check two things:

1. If those songs were transferred to the player in MTP mode, they may be in the ##Music# folder created by the Sansa firmware (the Sansa firmware handles MTP-transferred content and MSC-transferred content differently for some reason). I'd suggest clearing out all the content on your player, re-transferring it in MSC mode, and making sure you're only connected in MSC mode from now on (there is a setting for this in the Sansa firmware).

2. In Rockbox, make sure 'Settings --> General Settings --> File View --> Show Files' is not set to "Playlists" (I'd recommend setting it to "Supported"), as this setting hides any type of content other than what's selected.
__________________
Rockbox Themes:
Sansa Fuze: XL Fuzed // Sansa Clip/Clip+: Cliplined
Reply With Quote

  #3  
Old 11-01-2010, 11:14 AM
Mikerman Mikerman is offline
Ultra Senior Member
 
Join Date: Dec 2007
Posts: 2,468
Default

Slight correction: the original Clip (with original hardware structure) has USB capability with Rockbox. The subsequent Clip hardware version and the Clip+ still await that capability within Rockbox.
Reply With Quote

  #4  
Old 11-01-2010, 01:14 PM
Nausicaa's Avatar
Nausicaa Nausicaa is offline
Junior Member
 
Join Date: May 2010
Posts: 65
Default

They were always transfered through MSC mode. That is why I found it odd. It suddenly disconnected from my PC as I was about to transfer songs, so I think that there is hardware problem.

There indeed is a USB mode on Rockbox for v1.

Thank you for your comment on playlists. I must have pressed something randomly in my pocket.

I still cannot connect it to my PC.

(I love clips but my v2 died when the battery overheated, and this one is kinda not that useful if I can't move songs on it. What a pity, I love these, they are durable as everyone says, but I have had debilitating problems with them.)
Reply With Quote

  #5  
Old 11-01-2010, 01:46 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,241
Default

If you have your file view set to "All" and can't see your music files in the Rockbox File browser then that would indicate that they were transferred in MTP mode. I've had the USB connection mode change on both a V1 and V2 Clip when I know that I didn't make the change. Unfortunately the only way to check that for sure is to connect in MTP mode and check in Windows explorer and you can't do that.

The only things I can suggest that might help would would be try a different USB cable or port on your computer. I've read were a cable has gone partially bad and allowed charging but not data transfer. I've also have had a USB port that was working to transfer files just stop working properly. When I uninstalled then reinstalled the USB controllers in the Windows Device Manger it fixed that.

Resetting the player from the Sansa menu may help. You shouldn't lose your music but it may give it the kick in the butt it needs to start connecting properly again. Doubtful, but I guess it's possible. Formatting the player from the Sansa menu wouldn't be one of my recommendations. As long as you have music files on there and it charges you have some functionality. Once you format the player even that little bit would be gone.
Reply With Quote

  #6  
Old 11-01-2010, 01:57 PM
Nausicaa's Avatar
Nausicaa Nausicaa is offline
Junior Member
 
Join Date: May 2010
Posts: 65
Default

I have reset it, and tried different cables on different ports and on different computers. They don't work. That was my problem, I didn't want to reset it completely, since it still is a music player, but I just can't add any new music to it. This is very frustrating for me.
Reply With Quote

  #7  
Old 11-01-2010, 02:07 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,241
Default

Sorry to hear that. I can't think of anything else except a hardware failure. I wouldn't be able to give any suggestions on that except to RMA it if it's still under warranty.
Reply With Quote

  #8  
Old 11-01-2010, 03:57 PM
epithetless's Avatar
epithetless epithetless is offline
Ultra Senior Member
 
Join Date: Jul 2007
Location: Boston, Mass
Posts: 1,610
Default

Quote:
Originally Posted by Mikerman View Post
Slight correction: the original Clip (with original hardware structure) has USB capability with Rockbox. The subsequent Clip hardware version and the Clip+ still await that capability within Rockbox.
Huh. I somehow completely missed that the v1 Clips gained USB data support...Guess it's 'cause I never use mine. Thanks for the news.

Nausicaa, sorry to hear your player's problems are more extensive than I had assumed.
__________________
Rockbox Themes:
Sansa Fuze: XL Fuzed // Sansa Clip/Clip+: Cliplined
Reply With Quote

  #9  
Old 11-01-2010, 05:31 PM
Mikerman Mikerman is offline
Ultra Senior Member
 
Join Date: Dec 2007
Posts: 2,468
Default

Quote:
Originally Posted by epithetless View Post
Huh. I somehow completely missed that the v1 Clips gained USB data support...Guess it's 'cause I never use mine. Thanks for the news.
Pretty wonderfully amazing, isn't it?
Reply With Quote

  #10  
Old 11-01-2010, 11:34 PM
Nausicaa's Avatar
Nausicaa Nausicaa is offline
Junior Member
 
Join Date: May 2010
Posts: 65
Default

No problem. I assume its because I use an Apple charger for it, or something of that nature. I am thinking of taking it apart and trying to fix it, but I don't know what would be the problem. Would the USB have a fuse that broke? Maybe I should just send it back, it was a refurb.

But yes the v1 has USB support its really neat, if it worked for me lol.
Reply With Quote

  #11  
Old 11-02-2010, 04:43 PM
johnnykarr johnnykarr is offline
Junior Member
 
Join Date: Mar 2009
Posts: 5
Default

I had the same problem with my Clip +, try this:

(1) Unplug from computer
(2) Power off Clip
(3) Push in, and hold down middle button (on clip)
(4) Plug into USB port--IT WORKED FOR ME, GOOD LUCK!
Reply With Quote

  #12  
Old 11-03-2010, 05:38 AM
Nausicaa's Avatar
Nausicaa Nausicaa is offline
Junior Member
 
Join Date: May 2010
Posts: 65
Default

I just get a
"Removed from GoList." message.
gg Sansa Clip v1.
Reply With Quote

  #13  
Old 11-03-2010, 06:20 AM
Nausicaa's Avatar
Nausicaa Nausicaa is offline
Junior Member
 
Join Date: May 2010
Posts: 65
Default

Decided to format it.

To my lack of surprise, it didn't work.

I noticed that the Sansa Firmware stopped trying to scan for new music even after I recorded something on rockbox. Just a little heads up for anyone who suffers what I just went though.
Reply With Quote

  #14  
Old 11-03-2010, 06:57 AM
WalkGood's Avatar
WalkGood WalkGood is offline
Moderator
 
Join Date: Aug 2006
Location: FL
Posts: 12,579
Default

Quote:
Originally Posted by johnnykarr View Post
I had the same problem with my Clip +, try this:

(1) Unplug from computer
(2) Power off Clip
(3) Push in, and hold down middle button (on clip)
(4) Plug into USB port--IT WORKED FOR ME, GOOD LUCK!
This has saved my v1's a few times, but I added one step. While player is off, put it into the lock position, then hold the center button while plugging into PC and don't let go of the center button until it gets recognized as a drive. Then I've removed rb, reinstalled latest fw and disconnected, let it do it's fw upgrade and refresh. Once disconnected it seems to always switch itself to auto and I've switched that back to MSC, connected again and reloaded rockbox.
__________________
WalkGood,
Ramón

abi >> | Forum Rules | Glossary | Why Rockbox | FLAC or MP3? | irc
Reply With Quote

  #15  
Old 11-03-2010, 08:19 AM
johnnykarr johnnykarr is offline
Junior Member
 
Join Date: Mar 2009
Posts: 5
Default

Must be a Sansa bug, I had an e260 before the clip and had to reformat when I loaded new music just like on my clip.
Reply With Quote

  #16  
Old 11-04-2010, 12:00 AM
Nausicaa's Avatar
Nausicaa Nausicaa is offline
Junior Member
 
Join Date: May 2010
Posts: 65
Default

Quote:
Originally Posted by WalkGood View Post
This has saved my v1's a few times, but I added one step. While player is off, put it into the lock position, then hold the center button while plugging into PC and don't let go of the center button until it gets recognized as a drive. Then I've removed rb, reinstalled latest fw and disconnected, let it do it's fw upgrade and refresh. Once disconnected it seems to always switch itself to auto and I've switched that back to MSC, connected again and reloaded rockbox.
I'm never letting go.
Haha.

It didn't work so I think I have to RMA it.

I love these players, but they really don't like me. They don't last long, I wasn't even rough with it, and its broken now.
I guess refurbs have their downsides, it doesn't bother me that much, but I bought an iPod mini that I put a CF 16GB in and its my favorite rockbox player because its so reliable, these things are breakable and have awesome sound quality, but its so sad they always break on me.
Reply With Quote

  #17  
Old 11-04-2010, 08:27 AM
nycbone nycbone is offline
Junior Member
 
Join Date: Jul 2010
Location: NYC
Posts: 16
Default

Is player actually in MSC mode when running the Sansa firmware? Yesterday, mine ended up in MTP mode (not sure how - but it was after charging using an external charger), I switched it and the PC was then able to recognize it for file transfer.
__________________
Clip+ (Rockbox) --> RE0 | KSC75
Reply With Quote

  #18  
Old 12-17-2010, 03:14 PM
Nausicaa's Avatar
Nausicaa Nausicaa is offline
Junior Member
 
Join Date: May 2010
Posts: 65
Default

I tried again to make sure, and yes its in MSC mode. I tried both modes, they do not work.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 02:42 AM.