android
  #1  
Old 12-17-2010, 09:09 AM
Kodeen Kodeen is offline
Junior Member
 
Join Date: Dec 2010
Location: Nashville
Posts: 2
Default Flawed gapless playback with Rockbox

Hello, I just recently got my Clip+ and almost immediately Rockboxed it. I'm having a weird issue, however, with the gapless playback. When the music is transitioning from track to track, there is the slightest hiccup, just a fraction of a second. This occurs with both crossfade off and with it on at 0 seconds. My files are 256kbps MP3's ripped with Rhythmbox (LAME).

One thing I thought might be the cause is that I manage my library with iTunes (since I also have a couple iPods), and that my songs are all checked as gapless in the file options, and that that might be creating a compatibility issue. So I unchecked that box for one of my albums, but the hiccup remains (again with crossfade on and off).

This is odd because the OF was able to play gaplessly perfectly, much better than what I've read. Am I missing something to enable true gapless with Rockbox?
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 12-17-2010, 09:27 AM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

LAME should be perfectly gapless on Rockbox. Maybe it's indeed some tag issue. Try checking/rewriting the tags with MP3Tag, possibly removing ID3v1 and APE tags, only leaving ID3v2 tags. Rewriting the files with Foobar might be another option to try.

EDIT: D'oh, Rhythmbox - you're on Linux. Sorry, don't know any apps with similar functionality as the ones I mentioned above.
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #3  
Old 12-17-2010, 09:31 AM
Kodeen Kodeen is offline
Junior Member
 
Join Date: Dec 2010
Location: Nashville
Posts: 2
Default

I have a Linux and a Windows computer, so I'll fiddle with the ID3 tags when I get home.
Reply With Quote

  #4  
Old 12-24-2010, 06:13 AM
SneakySneaky SneakySneaky is offline
Junior Member
 
Join Date: May 2008
Posts: 10
Default

I'm afraid I'm not knowledgeable enough, but I've also got gapless playback issues. I tried listening to the same album using the OF and the "click" sound was actually shorter than the one in RB. Any ideas?
Reply With Quote

  #5  
Old 12-24-2010, 06:47 AM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,142
Default

What file format and encoder are you using? LAME encoded .mp3, Vorbis, FLAC, .m4a and Musepack all play with no clicks or gaps for me. I haven't tested any others.

I do get a slight click in the OF with the formats it supports. None in Rockbox.
Reply With Quote

  #6  
Old 12-24-2010, 10:06 AM
SneakySneaky SneakySneaky is offline
Junior Member
 
Join Date: May 2008
Posts: 10
Default

I 'm not sure what encoding windows media player uses, I just rip my cd's to mp3. When I play them on my computer they sound fine though.
Reply With Quote

  #7  
Old 12-24-2010, 10:24 AM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Quote:
Originally Posted by SneakySneaky View Post
I 'm not sure what encoding windows media player uses, I just rip my cd's to mp3. When I play them on my computer they sound fine though.
WMP does not use the LAME MP3 encoder...that's probably the cause of the problem.
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #8  
Old 12-24-2010, 11:18 AM
SneakySneaky SneakySneaky is offline
Junior Member
 
Join Date: May 2008
Posts: 10
Default

But then how is it gapless when played on my computer? It's the same mp3 files. Or are they affected after I convert them to a lower bit rate when synching?

Last edited by SneakySneaky; 12-24-2010 at 11:24 AM.
Reply With Quote

  #9  
Old 12-24-2010, 12:53 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,142
Default

WMP uses the FHG encoder which is definitely not true gapless. There's information in the LAME encoded mp3 file that tells a decoder to where start playing. The FHG encoder doesn't provide that information. Some desktop software and some players can take a guess where the music starts and give a type of gapless playback that works most of the time.

If you want true gapless playback you need to use files that were encoded with that information .That's why I named the LAME encoder.

You've got a little work to do if you want gapless playback. If you want to take full advantage of Rockbox has to offer retire WMP. There's nothing that it does that other free software and freeware won't do infinitely better for a Rockboxed player. If you just want to re-rip your discs to a format that will play gaplessly with minimum effort I'd get of copy of fre:ac (it used to be called Bonkenc) Be sure to get the Snapshot version.. It's a free software but donations are happily accepted. Like Rockbox

The setup is very simple and intuitive. No installation is needed. Just unzip it to a folder of your choice and you're done. Go through the configuration menu and pick the format of your choice. It's all ready has the latest encoders in the download. If you're going to use .mp3 choose VBR Custom=> VBR. Pick a quality setting and go. That's it. You're set for gapless playback. There's a lot more settings you can play with but that there is enough to get you started.

Drop in a disc and re-rip some of your discs and load them up in Rockbox. You should hear true gapless play back. If you're are tempted to just transcode the files you have now I wouldn't. They will play gaplessly but there's an unavoidable loss in quality. You could always test some files to see if the loss in quality is acceptable to you.
Reply With Quote

  #10  
Old 12-24-2010, 01:03 PM
Adub's Avatar
Adub Adub is offline
Moderator
 
Join Date: Jan 2010
Location: T DOT
Posts: 1,604
Default

Not all mp3 files are alike, different encoders produce a different quality of file. LAME encoded mp3 produce the highest quality mp3 files when transcoding.

As a rule you never want to transcode lossy to lossy ever.

Rockbox produces gapless on LAME encoded mp3s, if you lack LAME encoded mp3s you will not get perfect gapless. Though rockbox has perfect gapless with other formats, for mp3 you need to encode with LAME.
__________________
last.fm#abi ircrockboxnoobglossaryhiphopthreadhorrormoviethread
XBLive Tag: wuaffiliate
Battle.net Tag: wuaffiliate#1677
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:21 PM.