android
Go Back   abi>>forums > MP3 Players By Brand > iRiver > iriver SPINN

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-26-2010, 10:09 AM
sepia_chant sepia_chant is offline
Junior Member
 
Join Date: Aug 2010
Posts: 2
Default old problem when trying to charge the spinn for the 1st time

i've just received my spinn this morning and when I tried to connect it with the PC for charging, there's no sign that it's alive. the screen doesn't even bother to light up or show something. and the PC doesn't recognize the spinn either. and the problem is not because of the USB port. I think it's either the device or the usb cable.

yeah i know that somebody else has answered this before but the thing is i'm not a pro at electrical things and I don't have the tools to play with the battery. so is there any other way to fix it??? would it work if I plug the spinn into the PC for a long time and wait?

please help!

and sorry for my English...
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 08-26-2010, 10:14 AM
dfkt's Avatar
dfkt dfkt is offline
Ultra Senior Member
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Quote:
Originally Posted by sepia_chant View Post
would it work if I plug the spinn into the PC for a long time and wait?
Yes, that often helps with depleted batteries. Just leave it connected for a day or two, then try again. Preferably, use an USB port directly on your PC, not on a USB hub - hubs may deliver less power, especially passive ones.
Reply With Quote

  #3  
Old 08-26-2010, 10:46 AM
sepia_chant sepia_chant is offline
Junior Member
 
Join Date: Aug 2010
Posts: 2
Default

Quote:
Originally Posted by dfkt View Post
Yes, that often helps with depleted batteries. Just leave it connected for a day or two, then try again. Preferably, use an USB port directly on your PC, not on a USB hub - hubs may deliver less power, especially passive ones.
thank u very much I'll try it. but everybody please make more solutions here in case the 1st one fail xD i think it's good for the ones who need these solutions afterward too.
Reply With Quote

  #4  
Old 01-22-2011, 06:37 PM
rufix rufix is offline
Junior Member
 
Join Date: Aug 2010
Posts: 2
Default

http://www.anythingbutipod.com/forum...ad.php?t=54225 - read post #5 by me (rufix). This is how i resolve problem.
But I have this problem all the time. It means-I take off rear panel all the time and give some start voltage for charging. That's not good at all.
Or you can everyday keep it on charger. :d
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 03:37 AM.