android
  #21  
Old 02-15-2011, 02:38 AM
Progweed's Avatar
Progweed Progweed is offline
Junior Member
 
Join Date: Oct 2010
Location: Germany
Posts: 73
Default

Hey lestatar, I encountered the same issue with this build! The database wouldn't update past a certain point, after that I had a few dozen corrupted files on my player.
__________________
Bands I dig: Genesis, Jethro Tull, Marillion, Pink Floyd, Mike Oldfield, Arena, Savatage, Threshold, Twelfth Night, Flower Kings, Magenta, Mostly Autumn, Transatalantic, Vanden Plas, Deep Purple, Metallica, R.E.M., Cake, and, yes, Katie Melua.
Reply With Quote

Advertisement [Remove Advertisement]

  #22  
Old 02-15-2011, 02:45 AM
lestatar's Avatar
lestatar lestatar is offline
Ultra Senior Member
 
Join Date: Dec 2009
Location: Hong Kong now, but NYC always
Posts: 4,657
Default

A-ha! That is EXACTLY what happened! r29305, right?

Have you upgraded beyond that, using current build? Any issues?

@saratoga: Also, some more clues for you on this. I had a tough time deleting the .rockbox folder under Win7 Explorer. I noticed that the .rockbox folder was set as READ-ONLY somehow and recall seeing that no db files were created in the .rockbox root.

Is this helpful at all?

Thanks a ton Progweed!
-les
__________________
DAPs:2xRBFuze8+16GB|SonyE345|ZenV+,Micro,Xtra40GBx2|RBG igabeatFX|RCAOpal
IEMs:PanaHJE900|Nuforce 700x|HippoVB|iMetal590,i490|SM PL-21|CX300|EP630,Aurvana
Guitars:IbanezS540,JS1200|Ovation
PoolCues: a bunch
A Glossary for Newbies
Reply With Quote

  #23  
Old 02-15-2011, 02:57 AM
Progweed's Avatar
Progweed Progweed is offline
Junior Member
 
Join Date: Oct 2010
Location: Germany
Posts: 73
Default

Quote:
Originally Posted by lestatar View Post
A-ha! That is EXACTLY what happened! r29305, right?
Yepp, exactly. And I think it choked on a perfectly fine MP3 file. At least that's what the debug screen told me.

Quote:
Originally Posted by lestatar View Post
Have you upgraded beyond that, using current build? Any issues?
I think I will revert back to the custom build I had installed before, r29128. Only a few language files were changed since r29305: http://www.rockbox.org/since-release.html
__________________
Bands I dig: Genesis, Jethro Tull, Marillion, Pink Floyd, Mike Oldfield, Arena, Savatage, Threshold, Twelfth Night, Flower Kings, Magenta, Mostly Autumn, Transatalantic, Vanden Plas, Deep Purple, Metallica, R.E.M., Cake, and, yes, Katie Melua.
Reply With Quote

  #24  
Old 02-15-2011, 03:38 AM
akbarhash akbarhash is offline
Junior Member
 
Join Date: May 2010
Location: Muscat, Oman
Posts: 58
Default

Me too the database won't update after file number 5497,
so i went to an old version of rockbox i had backed up and am using that database but my new additions are not there
I am using the 29305 version,
currently running the metadata check to see what the problem is will report if it is a file problem or rockbox issue.
Reply With Quote

  #25  
Old 02-15-2011, 04:44 AM
lestatar's Avatar
lestatar lestatar is offline
Ultra Senior Member
 
Join Date: Dec 2009
Location: Hong Kong now, but NYC always
Posts: 4,657
Default

Hmmm, well now it seems that with 3 people possibly reporting similar issues with the same build, r29305, odds are pretty good I think this build might have some problems, as saratoga alluded to earlier.

Thanks for chiming in guys! Glad to see I am not a alone - I was starting to think I knew less about this than I already do
__________________
DAPs:2xRBFuze8+16GB|SonyE345|ZenV+,Micro,Xtra40GBx2|RBG igabeatFX|RCAOpal
IEMs:PanaHJE900|Nuforce 700x|HippoVB|iMetal590,i490|SM PL-21|CX300|EP630,Aurvana
Guitars:IbanezS540,JS1200|Ovation
PoolCues: a bunch
A Glossary for Newbies
Reply With Quote

  #26  
Old 02-15-2011, 04:59 AM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Quote:
Originally Posted by lestatar View Post
Hmmm, well now it seems that with 3 people possibly reporting similar issues with the same build, r29305, odds are pretty good I think this build might have some problems, as saratoga alluded to earlier.

Thanks for chiming in guys! Glad to see I am not a alone - I was starting to think I knew less about this than I already do
Although skip252 was correct earlier when he described 3.7.1 as an old build, what you're experiencing reminds me why I went back to 3.7.1, after experimenting with some custom builds, like the ones with USB patch, etc....because the fact remains that they call 3.7.1 the "stable release" for good reason...in day in and day out use, nothing goes wrong for me, it just plain works.

In fact, I know that since 3.7.1, there was a patch added to the current builds to bump the battery life of the V1 Fuze a little bit, yet I still have stuck with 3.7.1, for the sake of peace of mind (and the battery gets me through a day at work, which is all that matters).
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #27  
Old 02-15-2011, 05:17 AM
lestatar's Avatar
lestatar lestatar is offline
Ultra Senior Member
 
Join Date: Dec 2009
Location: Hong Kong now, but NYC always
Posts: 4,657
Default

Thanks man. So any suggestions? As you can see, I have not needed/wanted to upgrade my build in a very long time. This new embedded art support is something I would like to explore however.

Any ideas on what I should try next? Just install the latest stable build for v2 Fuze via Rockox utility? This latest build I am assuming will contain the embedded art support/update and I prolly should have opted for that one in the first place.
__________________
DAPs:2xRBFuze8+16GB|SonyE345|ZenV+,Micro,Xtra40GBx2|RBG igabeatFX|RCAOpal
IEMs:PanaHJE900|Nuforce 700x|HippoVB|iMetal590,i490|SM PL-21|CX300|EP630,Aurvana
Guitars:IbanezS540,JS1200|Ovation
PoolCues: a bunch
A Glossary for Newbies
Reply With Quote

  #28  
Old 02-15-2011, 05:59 AM
Progweed's Avatar
Progweed Progweed is offline
Junior Member
 
Join Date: Oct 2010
Location: Germany
Posts: 73
Default

The latest release build is from November, but there is message in the changelog saying that a new release is due soon. I'd simply wait for that.
__________________
Bands I dig: Genesis, Jethro Tull, Marillion, Pink Floyd, Mike Oldfield, Arena, Savatage, Threshold, Twelfth Night, Flower Kings, Magenta, Mostly Autumn, Transatalantic, Vanden Plas, Deep Purple, Metallica, R.E.M., Cake, and, yes, Katie Melua.
Reply With Quote

  #29  
Old 02-15-2011, 07:40 AM
akbarhash akbarhash is offline
Junior Member
 
Join Date: May 2010
Location: Muscat, Oman
Posts: 58
Default

Hmm... I am out now, it was one of the Bon Jovi (320kbps) song that had the problem it was not a tag problem because even after changing the tag with easytag in linux the problem was still there then i changed the song using sound converter in linux to lame 3.98 at highest bitrate then it started working, don't know what the problem was. Also checking the filesystem showed no problems.(I know its not a big change the format is the same and before it was lame 3.97 but it fixed the problem don't know how though.)

Thanks for the suggestion of the metatag thing. It really works well go to system>debug>metatag log
It will show a message that metatag log has been enabled.
Now go to Database Long Hold then initialize database...
Now if there is a problem in any file then the database will hang, if so the Files>metadata.log file will show the file which is causing the database to hang as the last line of the metadata.log.
Finally just check the file which is causing the error and try to modify it till the error is gone.
Hope that is simple enough.
I don't know if the feature is explained in the rockbox manual but i am putting it out there for the people.
Reply With Quote

  #30  
Old 02-15-2011, 08:14 AM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,351
Default

Do you still have the original file that was causing the problem? I've known the developers to ask for them to be uploaded so they can try to track down what's causing the problem.
Reply With Quote

  #31  
Old 02-15-2011, 09:06 AM
akbarhash akbarhash is offline
Junior Member
 
Join Date: May 2010
Location: Muscat, Oman
Posts: 58
Default

Oops, i deleted it from the player but i will try to copy the original file from my hard disk back to the player and update the database to try to recreate the error, if it is recurring then i will upload the file here and hope saratoga is following the thread.

Actually i wanted to do that integrity checker thing but wine is acting up and foobar is not working.
Reply With Quote

  #32  
Old 02-15-2011, 09:38 AM
akbarhash akbarhash is offline
Junior Member
 
Join Date: May 2010
Location: Muscat, Oman
Posts: 58
Default

No problem with the file from the hard disk, can't help if it happens again though will surely keep the file causing the problem.
Reply With Quote

  #33  
Old 02-24-2011, 03:27 AM
Progweed's Avatar
Progweed Progweed is offline
Junior Member
 
Join Date: Oct 2010
Location: Germany
Posts: 73
Default

Quote:
Originally Posted by Progweed View Post
Hey lestatar, I encountered the same issue with this build! The database wouldn't update past a certain point, after that I had a few dozen corrupted files on my player.
Mhm, the problem still persists in r29387. Guess I'll file a bug report.
__________________
Bands I dig: Genesis, Jethro Tull, Marillion, Pink Floyd, Mike Oldfield, Arena, Savatage, Threshold, Twelfth Night, Flower Kings, Magenta, Mostly Autumn, Transatalantic, Vanden Plas, Deep Purple, Metallica, R.E.M., Cake, and, yes, Katie Melua.
Reply With Quote

  #34  
Old 02-24-2011, 09:20 PM
sduck sduck is offline
Junior Member
 
Join Date: Feb 2008
Posts: 38
Default

You guys need a new thread.
Reply With Quote

  #35  
Old 03-02-2011, 09:46 PM
eboyer93's Avatar
eboyer93 eboyer93 is offline
Senior Member
 
Join Date: Mar 2009
Location: Southeastern Pennsylvania
Posts: 838
Default

Quote:
Originally Posted by Progweed View Post
Mhm, the problem still persists in r29387. Guess I'll file a bug report.
Yeah this is happening to me in 3.8 on both my fuze and clip+
__________________
foobar2000 | Last.fm | Get Mozilla Firefox | Rockbox
Players: SanDisk Sansa Fuze 8GB + 2GB card (w/Rockbox), SanDisk Sansa Clip+ 4GB + 8GB card (Red) (w/Rockbox)
Reply With Quote

  #36  
Old 03-03-2011, 03:17 AM
lestatar's Avatar
lestatar lestatar is offline
Ultra Senior Member
 
Join Date: Dec 2009
Location: Hong Kong now, but NYC always
Posts: 4,657
Default

Hmmm...have not had a chance to try again, and also not with RB 3.8.

Seems I might just still wait awhile
__________________
DAPs:2xRBFuze8+16GB|SonyE345|ZenV+,Micro,Xtra40GBx2|RBG igabeatFX|RCAOpal
IEMs:PanaHJE900|Nuforce 700x|HippoVB|iMetal590,i490|SM PL-21|CX300|EP630,Aurvana
Guitars:IbanezS540,JS1200|Ovation
PoolCues: a bunch
A Glossary for Newbies
Reply With Quote

  #37  
Old 03-03-2011, 03:30 AM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Quote:
Originally Posted by lestatar View Post
Hmmm...have not had a chance to try again, and also not with RB 3.8.

Seems I might just still wait awhile
It's working flawlessly for me....my database updates without issue, even more album art shows than before....and my music plays at the proper speed too!
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #38  
Old 03-03-2011, 03:35 AM
lestatar's Avatar
lestatar lestatar is offline
Ultra Senior Member
 
Join Date: Dec 2009
Location: Hong Kong now, but NYC always
Posts: 4,657
Default

^ blah blah blah...

Mine ain't broke - no reason to fix it. And the speed on my Fuzes is just fine to me
__________________
DAPs:2xRBFuze8+16GB|SonyE345|ZenV+,Micro,Xtra40GBx2|RBG igabeatFX|RCAOpal
IEMs:PanaHJE900|Nuforce 700x|HippoVB|iMetal590,i490|SM PL-21|CX300|EP630,Aurvana
Guitars:IbanezS540,JS1200|Ovation
PoolCues: a bunch
A Glossary for Newbies
Reply With Quote

  #39  
Old 03-03-2011, 07:36 PM
eboyer93's Avatar
eboyer93 eboyer93 is offline
Senior Member
 
Join Date: Mar 2009
Location: Southeastern Pennsylvania
Posts: 838
Default

3.7.1 works fine for me. I'm going to wait till they fix it.
__________________
foobar2000 | Last.fm | Get Mozilla Firefox | Rockbox
Players: SanDisk Sansa Fuze 8GB + 2GB card (w/Rockbox), SanDisk Sansa Clip+ 4GB + 8GB card (Red) (w/Rockbox)
Reply With Quote

  #40  
Old 03-03-2011, 07:50 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,351
Default

I believe it has been fixed. At least it's working for me now. I tried upgrading my V2 Clip yesterday and things didn't work out well. I was keeping an eye on FS #11965 that Progweed had started. Tried a current build as suggested and things seem to be OK again.

Wrestled my Fuze back from my kid and tried it there. The database builds and there's no file system problems when I check. That may be different for each person so YMMV.
Reply With Quote

Reply

Tags
embedded art, jpeg, rockbox, tags

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:53 PM.