android
  #1  
Old 03-21-2011, 12:58 AM
sunami88's Avatar
sunami88 sunami88 is offline
Junior Member
 
Join Date: Sep 2007
Location: Ontario
Posts: 98
Default SD Card Problems With r29625

I just updated to the most recent revision of Rockbox, and now my SD Card doesn't show up under Rockbox unless I take the card out and reinsert it with the player on. I've been using the same player+card for quite some time now. The SD Card works just fine under the OF, and once the card has shown up, playback/building the DB seems to be unaffected.
Anybody else having this problem?

FuzeV2 with a 16 gig Sandisk MicroSD, r29625-110320 (the versions I compiled were r29625M-110321). Compiled twice, and I'm currently using a revision downloaded from the Rockbox website. Tried clearing my config too, problem persisted.
__________________
=Players in use=
Sansa FuzeV2 (8 + 16 gigs) [RB]|Sansa Clip+ (4 + 8 gigs) [RB]
=Headphones in use=
SoundMagic PL50|SoundMagic PL30|Bang&Olufsen Form 2
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 03-21-2011, 09:16 AM
eboyer93's Avatar
eboyer93 eboyer93 is offline
Senior Member
 
Join Date: Mar 2009
Location: Southeastern Pennsylvania
Posts: 838
Default

Yeah my 8gb card is not showing up either on the Clip+ with r29625.
__________________
foobar2000 | Last.fm | Get Mozilla Firefox | Rockbox
Players: SanDisk Sansa Fuze 8GB + 2GB card (w/Rockbox), SanDisk Sansa Clip+ 4GB + 8GB card (Red) (w/Rockbox)
Reply With Quote

  #3  
Old 03-22-2011, 05:00 PM
sunami88's Avatar
sunami88 sunami88 is offline
Junior Member
 
Join Date: Sep 2007
Location: Ontario
Posts: 98
Default

I see there have been a lot of changes pertaining to the SD Card on the AMSv2, so that probably has something to do with it.

I still have to re-insert the card on r29635, but hopefully it'll be sorted out soon.
__________________
=Players in use=
Sansa FuzeV2 (8 + 16 gigs) [RB]|Sansa Clip+ (4 + 8 gigs) [RB]
=Headphones in use=
SoundMagic PL50|SoundMagic PL30|Bang&Olufsen Form 2
Reply With Quote

  #4  
Old 03-22-2011, 06:56 PM
eboyer93's Avatar
eboyer93 eboyer93 is offline
Senior Member
 
Join Date: Mar 2009
Location: Southeastern Pennsylvania
Posts: 838
Default

Reinserting the card didn't work for me on Clip+ so I just installed the daily build from the 19th which is r29613 and it works fine.
__________________
foobar2000 | Last.fm | Get Mozilla Firefox | Rockbox
Players: SanDisk Sansa Fuze 8GB + 2GB card (w/Rockbox), SanDisk Sansa Clip+ 4GB + 8GB card (Red) (w/Rockbox)
Reply With Quote

  #5  
Old 03-22-2011, 07:26 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,617
Default

Its r29625 that broke card detection, unfortunately it fixes a bug reading the internal memory, so I'm not going to revert it until I know whats going on. For now either use an older build or just pop the card out and back in on boot.
__________________
Interested in Google's Summer of Code ? PM me.
Reply With Quote

  #6  
Old 03-22-2011, 09:03 PM
sunami88's Avatar
sunami88 sunami88 is offline
Junior Member
 
Join Date: Sep 2007
Location: Ontario
Posts: 98
Default

Thanks for the info saratoga.

@eboyer: Make sure you haven't clicked on "Files" before you insert the microSD. I'm pretty sure this has something to do with dircache being enabled and, not seeing the card the first time, it doesn't always refresh and add the microSD. I could be wrong though...

Oh, and uhh... If that's the case it totally wasn't my idea to enable dir cache by default :P .
__________________
=Players in use=
Sansa FuzeV2 (8 + 16 gigs) [RB]|Sansa Clip+ (4 + 8 gigs) [RB]
=Headphones in use=
SoundMagic PL50|SoundMagic PL30|Bang&Olufsen Form 2
Reply With Quote

  #7  
Old 03-22-2011, 10:24 PM
eboyer93's Avatar
eboyer93 eboyer93 is offline
Senior Member
 
Join Date: Mar 2009
Location: Southeastern Pennsylvania
Posts: 838
Default

Build I have installed now works fine so I am just going to use that until they fix it.
__________________
foobar2000 | Last.fm | Get Mozilla Firefox | Rockbox
Players: SanDisk Sansa Fuze 8GB + 2GB card (w/Rockbox), SanDisk Sansa Clip+ 4GB + 8GB card (Red) (w/Rockbox)
Reply With Quote

  #8  
Old 03-24-2011, 06:17 AM
funman funman is offline
Rockbox Developer
 
Join Date: Jul 2008
Posts: 161
Default

fixed in r29637 (based on saratoga's patch)
Reply With Quote

  #9  
Old 03-24-2011, 12:51 PM
eboyer93's Avatar
eboyer93 eboyer93 is offline
Senior Member
 
Join Date: Mar 2009
Location: Southeastern Pennsylvania
Posts: 838
Default

Great I will try it out when I get home.
__________________
foobar2000 | Last.fm | Get Mozilla Firefox | Rockbox
Players: SanDisk Sansa Fuze 8GB + 2GB card (w/Rockbox), SanDisk Sansa Clip+ 4GB + 8GB card (Red) (w/Rockbox)
Reply With Quote

  #10  
Old 03-24-2011, 03:57 PM
eboyer93's Avatar
eboyer93 eboyer93 is offline
Senior Member
 
Join Date: Mar 2009
Location: Southeastern Pennsylvania
Posts: 838
Default

It is fixed on both my Fuze and Clip+ on r29642.
__________________
foobar2000 | Last.fm | Get Mozilla Firefox | Rockbox
Players: SanDisk Sansa Fuze 8GB + 2GB card (w/Rockbox), SanDisk Sansa Clip+ 4GB + 8GB card (Red) (w/Rockbox)
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 01:17 PM.