android
  #1  
Old 04-30-2011, 04:18 PM
eightbitsprite's Avatar
eightbitsprite eightbitsprite is offline
Junior Member
 
Join Date: Mar 2011
Location: Cupertino, CA. The irony.
Posts: 33
Default Problem playing some vorbis files

So I've been using Mediamonkey for a while now, and been using it to sync my music files to my Clip+. And while listening to one of the playlists I have synced over, I noticed it completely skipped over one song, claiming a 'codec failure'. Curious, I looked in the folder and played it, and it simply skipped over all the files in there, over and over again (I have repeat all on). None of the files seemed to work, so I thought MM had just botched up the transfer.
Thinking this, I resynced it, but still nothing. However, MM played the file straight off the Clip fine, and when I tried working it with the OF, it played fine (but there was delay before the music started). I'm guessing it's a problem with RB, but none of the other files that I've ripped using MM (using same settings) seem to have this problem.
I tried transferring the other songs in the album, and they didn't play either. It skipped through them, then froze.
I'm guessing I should file a bug report, but in the meantime, I'd like to know what the issue is. Perhaps it's my tags? I suppose I could rerip that album- but it'd be a bit of a pain.
Any suggestions are appreciated!
__________________
Sansa Clip+ 4GB w/ 16GB mSD, Rockboxed
MEElectronics M6-CL [replaced due to excellent customer service]
MEElectronics M9-BK

Come see my Fallen London's Mantelpiece!
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 04-30-2011, 04:23 PM
lestatar's Avatar
lestatar lestatar is offline
Ultra Senior Member
 
Join Date: Dec 2009
Location: Hong Kong now, but NYC always
Posts: 4,657
Default

yeah, check the tags first with something like mp3tag...

may be that you have some other ID3 tag stuff there that is causing the choke...
__________________
DAPs:2xRBFuze8+16GB|SonyE345|ZenV+,Micro,Xtra40GBx2|RBG igabeatFX|RCAOpal
IEMs:PanaHJE900|Nuforce 700x|HippoVB|iMetal590,i490|SM PL-21|CX300|EP630,Aurvana
Guitars:IbanezS540,JS1200|Ovation
PoolCues: a bunch
A Glossary for Newbies
Reply With Quote

  #3  
Old 04-30-2011, 04:29 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,584
Default

No sense asking until you've posted one of the files.
__________________
Interested in Google's Summer of Code ? PM me.
Reply With Quote

  #4  
Old 04-30-2011, 04:45 PM
eightbitsprite's Avatar
eightbitsprite eightbitsprite is offline
Junior Member
 
Join Date: Mar 2011
Location: Cupertino, CA. The irony.
Posts: 33
Default

Oh. Sorry about that. Here's one of the files. *Link to copyrighted material removed*

As for the tags, everything seems to be fine. Unless I'm missing something here?

Anyways, thanks for the quick response!
Attached Images
File Type: jpg Capture.jpg (63.1 KB, 9 views)
__________________
Sansa Clip+ 4GB w/ 16GB mSD, Rockboxed
MEElectronics M6-CL [replaced due to excellent customer service]
MEElectronics M9-BK

Come see my Fallen London's Mantelpiece!

Last edited by eightbitsprite; 05-01-2011 at 11:09 PM.
Reply With Quote

  #5  
Old 04-30-2011, 05:28 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,584
Default

Weird, works fine on the sim so its not tags, but fails on the clip+.

Ah I see, that file requests way more decode memory then is available on the device. Normal Ogg files only ask for a small amount of RAM, but this one is special and asks for 3x as much as normal. I'm not sure how that file was created, but we're not likely to ever support giving that much RAM to codecs.
__________________
Interested in Google's Summer of Code ? PM me.
Reply With Quote

  #6  
Old 04-30-2011, 06:02 PM
eightbitsprite's Avatar
eightbitsprite eightbitsprite is offline
Junior Member
 
Join Date: Mar 2011
Location: Cupertino, CA. The irony.
Posts: 33
Default

Strange... all I did was rip it using Mediamonkey. I'll just rerip the whole thing again and hope it does it properly this time (And if that fails, I might use iTunes...). :P

Thanks for the help, though.
__________________
Sansa Clip+ 4GB w/ 16GB mSD, Rockboxed
MEElectronics M6-CL [replaced due to excellent customer service]
MEElectronics M9-BK

Come see my Fallen London's Mantelpiece!
Reply With Quote

  #7  
Old 04-30-2011, 06:07 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,584
Default

Quote:
Originally Posted by eightbitsprite View Post
Strange... all I did was rip it using Mediamonkey.
That file was encoded with some ancient vorbis encoder. Updating to a more modern one would probably resolve the problem.
__________________
Interested in Google's Summer of Code ? PM me.
Reply With Quote

  #8  
Old 04-30-2011, 06:20 PM
eightbitsprite's Avatar
eightbitsprite eightbitsprite is offline
Junior Member
 
Join Date: Mar 2011
Location: Cupertino, CA. The irony.
Posts: 33
Default

I'll do that then. Thanks for your help!
__________________
Sansa Clip+ 4GB w/ 16GB mSD, Rockboxed
MEElectronics M6-CL [replaced due to excellent customer service]
MEElectronics M9-BK

Come see my Fallen London's Mantelpiece!
Reply With Quote

  #9  
Old 05-02-2011, 10:31 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,584
Default

I was wrong. Looking at that file again, its got a huge embedded image in it, which for some reason is using up memory in Rockbox. I'll file a bug report on it. In the meantime, if you replace the album art with something a little smaller, it should work with rockbox.
__________________
Interested in Google's Summer of Code ? PM me.
Reply With Quote

  #10  
Old 05-03-2011, 12:44 AM
eightbitsprite's Avatar
eightbitsprite eightbitsprite is offline
Junior Member
 
Join Date: Mar 2011
Location: Cupertino, CA. The irony.
Posts: 33
Default

Hm. Well, I had inadvertently dodged the problem because I found a more appropriate (and smaller) piece of album art off of Amazon and tagged all the files with it. :P

But thanks for telling me that, and also for filing the bug report for me.
__________________
Sansa Clip+ 4GB w/ 16GB mSD, Rockboxed
MEElectronics M6-CL [replaced due to excellent customer service]
MEElectronics M9-BK

Come see my Fallen London's Mantelpiece!
Reply With Quote

  #11  
Old 05-03-2011, 01:50 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,584
Default

I spent a couple hours digging through the code and I'm not really sure how to fix this problem. The vorbis format seems to assume that you won't have enormous comments, so if you throw a really big piece of album art in there a lot of stuff needs to be changed, and when I tried reworking it more things just broke. For now I strongly recommend not putting more then a 100KB of album art inside Vorbis files.
__________________
Interested in Google's Summer of Code ? PM me.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:25 AM.