android
Go Back   abi>>forums > MP3 Players By Brand > Creative > Zen

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 05-27-2011, 12:41 PM
Bigwig Bigwig is offline
Junior Member
 
Join Date: May 2011
Posts: 2
Default Zen Problem: "Creative Screen", "Zen Screen" then a permanent dark screen.

I've owned my Zen since 2008 and I've loved it. It's small, sleek, and plays video extremely well (I can get through three whole movies on a single charge!). However, recently I've had problems.

I had run the battery down, and plugged it into a friends USB wall charger. Blue light lit up and then oscillated in brightness as usual. Unplugged it and took it home. When I tried to turn it on nothing happened. I hit the reset button and the player then turned on and started to boot as normal: "Creative screen" then "ZEN" screen, the battery indicator comes up for a second, and then the screen would go blank. It will stay blank until the battery dies, and the power button will not shut it off.

So I booted into recovery mode. I clicked clean up, then reboot. Same blank screen.

I downloaded the latest firmware. I went to recovery mode, format all, then upgrade firmware, plugged in the USB, upgraded firmware (with recovery tool and regular firmware program). Firmware seems to install, the program tells me player is rebooting...player automatically reboots...creative screen, zen screen, a second of the battery meter, then blank screen. Program on the computer continues to display "player rebooting, please wait" - for 20 minutes at least.

I've also opened the Zen up and changed the battery to a different one. Same problem.

Anyone else have any ideas? It's really strange!
Reply With Quote

Advertisement [Remove Advertisement]

 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 12:02 AM.