android
  #1  
Old 08-19-2011, 02:29 AM
Lee3333 Lee3333 is offline
Junior Member
 
Join Date: Aug 2011
Posts: 3
Default Blue light flickers

Just found my Zen W again and want to use it. I plugged it in with both USB to computer and USB to car charger, but the screen doesn't go on and the blue light flickers for about a minute then shuts off.

I would guess it was the battery, but I tried running it without the battery hooked up and the screen would not power on. I dont want to buy a battery only to learn that something else is wrong with it. What do you think it could be? It worked fine the last time I used it, about a year ago.

Thanks for any help you can give me.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 08-19-2011, 02:27 PM
Lee3333 Lee3333 is offline
Junior Member
 
Join Date: Aug 2011
Posts: 3
Default

Got frustrated trying to get a phone number for Creative. Just want to find out if it could only need a battery. I don't want to buy a new one if the unit is dead.
Reply With Quote

  #3  
Old 10-11-2011, 02:59 PM
digitania digitania is offline
Junior Member
 
Join Date: Oct 2011
Posts: 4
Default

Did you try giving the battery some time to charge?

If it's been unused and not charged for a significant period of time, chances are there's not enough power to run the player -- even just off the charger. I've seen that before when the battery is depleted. Give it a couple of hours to charge and see if that doesn't help.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:23 AM.