android
  #1  
Old 04-02-2010, 05:28 PM
brettreading brettreading is offline
Junior Member
 
Join Date: Jan 2009
Posts: 31
Default Replacement battery wont take a charge

Hi

I bought a replacement battery for my 60gb Zen M (running 1.21.2 firmware) and it just won't charge. The player works when connected to the charger but after hours of charging it still says low battery and switches off.

I downgraded my firmware to 1.11.04 as I read on Amazon that newer firmwares didnt support replacement batteries but it still wont charge.

Any thoughts?

Thanks
Brett
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 10-24-2010, 05:37 PM
jadoreabi jadoreabi is offline
Junior Member
 
Join Date: Oct 2010
Posts: 4
Default

I have a similar problem with my 30gb Zen M. It has been like this for months & months. I was ready to buy a new mp3 player but thought I'd try again and found this website.

I simply don't know what to do.
Reply With Quote

  #3  
Old 11-01-2010, 07:49 PM
carverjerry carverjerry is offline
Junior Member
 
Join Date: Nov 2010
Posts: 1
Default

I had the same problem with a new battery not taking a charge. I ended up breaking the plug off the main board and had to buy a new mother board. Still haven't found a way to charge a new battery, wish someone would find out how.
Reply With Quote

  #4  
Old 11-03-2010, 12:57 PM
jamganz jamganz is offline
Junior Member
 
Join Date: Feb 2009
Posts: 18
Default

what type of battery did you get? i've read in different places that with the 1700 mAh there are capatibility issues with the firmware. i think you need to 'rollback' to 1.41.01 firmware. i had to change my battery about a year ago and went with the 1400 mAh and had no issues. hope this helps.
Reply With Quote

  #5  
Old 03-31-2011, 01:13 AM
Audiobooks4Me Audiobooks4Me is offline
Junior Member
 
Join Date: Aug 2010
Location: California
Posts: 73
Default

Hey, there could be a variety of issues at this point but the above member is right. the 1.41.01 is the best FW for the Cameron Sino batteries.
PM me is you need help with this as I wont come back to this post.
Reply With Quote

  #6  
Old 12-31-2011, 01:24 AM
Zekerbox Zekerbox is offline
Junior Member
 
Join Date: Oct 2010
Posts: 1
Default

I have this same problem with my 60gb. I want to roll back the firmware, but I can't get the old battery to charge. My zen won't connect either. It just blinks the blue LED. *sigh* I miss my zen!
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:23 PM.