android
Prev Previous Post   Next Post Next
  #21  
Old 01-17-2012, 11:53 PM
jsc315 jsc315 is offline
Junior Member
 
Join Date: Jul 2007
Location: Joliet,IL
Posts: 90
Default

Sorry to bring up such an old topic but I figured there is no point in starting a new topic on this issue. Well I had a similar issue. I have had my Fuze for years now and was recently having issues with the wheel as well.

I was going to try alcohol as it wont hurt electronics in a small dose but its not a good lubricant. I then got an idea. I have this oil specifically for my electric razor, as it sometimes needs to be oiled similar to a shredder once in a while. It's a very small bottle that I can slowly dab a few drops and then spin the wheel with a tissue and spun it for a while back and forth for a good minute and it seemed to have fixed the problem for now. It wont hurt the electronics as it is used for my electronic razor and is meant as a oil/lubricant for it.

So I hope maybe this helps some people out there in the future with this issue. I'll make any updates if there is problems again or if it does not hold long.
Reply With Quote

Advertisement [Remove Advertisement]

 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 01:32 AM.