android
  #1  
Old 06-19-2012, 03:19 PM
ezzony ezzony is offline
Junior Member
 
Join Date: Mar 2011
Posts: 1
Default X5L Fell...oh hell

Yeah so I dropped my recently acquired second hand X5L and I'm just sick about it. Best player I ever had. Sounds better than my D2 to me.

Anyway the screen just flashed white when turned on. I opened her up and a red wire had become detached I noticed but soldering it back made no difference. I played with it for a while and found that if I plugged in the power charger through the sub pack AND attached the unit to my PC using the usb cable then the unit would turn on okay !

I should have left it at that but tinkered with it more. For some odd reason I decided to format the drive. Since then I haven't been able to turn the unit on even using the method as described above. I couldn't be sure that formatting the drive caused this as I did tinker around the insides of it at some point and could possibly have damaged the main board.

I really don't know what to do with it now I really wan't to repair it but I dont' know what's wrong with it. It's odd the way the screen just goes white when I turn it on and starts to flash white when I plug in the charger as if were a programmed code to tell one something. Btw the hard drive is not recognises by the PC now but I suspect it's not the HD that's at fault.

So, anyone have any suggestion what I can do. Chuck it? Sell the HD on ebay? Anyone got a faulty one to sell and and I could join the 2 together ? All suggestions welcome
Reply With Quote

Advertisement [Remove Advertisement]

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 04:28 AM.