android
  #1  
Old 04-02-2011, 01:09 PM
scally2112 scally2112 is offline
Junior Member
 
Join Date: Mar 2011
Posts: 7
Default D3 FLAC tag problem

There seems to be an issue with with FLAC tags missing the artist name.

No problems with my tags on the J3, anyone know an easy way round this? I'm not using extended tags, which seem to do even weirder things.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 04-02-2011, 01:14 PM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Maybe removing the ALBUM ARTIST tags helps: http://anythingbutipod.com/forum/sho...3&postcount=20
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #3  
Old 04-16-2011, 01:01 AM
jakeroux jakeroux is offline
Junior Member
 
Join Date: Jan 2009
Posts: 21
Default

Similar problem here, but my D3 displays the Artist name, but no Album name. My Flac rips were created using dBpoweramp, and I know the album tags are in the metadata info.

Perhaps just a current quirk of the D3 software? I know my S9 could never display album art for the mp3 files I had originally created in WMP - I had to manually add it using mp3tag.
Reply With Quote

  #4  
Old 04-16-2011, 09:03 AM
scally2112 scally2112 is offline
Junior Member
 
Join Date: Mar 2011
Posts: 7
Default

Quote:
Originally Posted by dfkt View Post
Maybe removing the ALBUM ARTIST tags helps: http://anythingbutipod.com/forum/sho...3&postcount=20
Thanks for the advice however it doesn't help me as ALBUM ARTIST is not in the tags. If I add it, it messes up the tag even more, as described in the article. It's just not reading the ARTIST and just says <unknown> against everything. I have the exact same files loaded in a J3 (and previously an S9) which both read them OK, so I guess it's a problem with the D3 ware.
Reply With Quote

  #5  
Old 04-19-2011, 09:20 AM
jakeroux jakeroux is offline
Junior Member
 
Join Date: Jan 2009
Posts: 21
Default

^^^

Just occurred to me that if yours can read album titles but no artists, and mine can read artists, but no album titles, there has to be some workaround on this.

What program did you use to create your FLACs? Have you looked at the metadata info in mp3tag to see if there is a value in artist name? Perhaps you can re-write it in mp3tag? I'll try the same for my album titles tonight.
Reply With Quote

  #6  
Old 04-19-2011, 01:47 PM
viblog viblog is offline
Junior Member
 
Join Date: Mar 2011
Posts: 6
Default

I had the issue with missing artist info, even though it was in the tag. I fixed it by re-saving the tags with musicbrainz picard. Check the options to "clear existing tags" and "remove ID3 tags from FLAC files" and just drag the flacs onto musicbrainz and hit save.
Reply With Quote

  #7  
Old 09-16-2012, 11:14 AM
summersky summersky is offline
Junior Member
 
Join Date: Sep 2012
Posts: 2
Default

Sorry to bump an old thread, but I'm having the same problem with artist name on my Z2...

Did anyone manage to find a solution pls?
Reply With Quote

  #8  
Old 09-20-2012, 12:39 PM
Copperface Copperface is offline
Junior Member
 
Join Date: Mar 2011
Location: UK
Posts: 6
Default

Quote:
Originally Posted by summersky View Post
Sorry to bump an old thread, but I'm having the same problem with artist name on my Z2...

Did anyone manage to find a solution pls?
The only workaround I found was to install Poweramp or Playerpro or some such player which gave you the option to edit tags on the D3 itself, rather than on the PC.
Most of the time I just added and deleted a letter to the artist name and resaved and seemed then that the D3 was happy and took the 'new' tag.

There was hoever, still the odd track that, no matter what you did, stubbornly refused to display the artist.

Last edited by Copperface; 09-20-2012 at 12:45 PM.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 09:30 AM.