Old 01-30-2013, 01:06 AM
Datawrangler Datawrangler is offline
Junior Member
Join Date: Jan 2013
Posts: 1

I found this thread

and something the guy said about half way down that clicked with me was
"Log in as Anonymous if you disabled password-protected sharing earlier. If you didnít, try to log in with your Windows username and password Ė this never worked for me, however." and he has a screenshot that has all the username, passwd, and the domain etc stuff above the username and password blank as well. I did that, blanked out the fields, checked anonymous, and turned off password protected sharing, and that got me in.

Good Luck.
Reply With Quote

Advertisement [Remove Advertisement]

Old 02-26-2013, 01:03 AM
mattwesterville mattwesterville is offline
Junior Member
Join Date: Feb 2013
Posts: 1

New problem here. I have ES File Explorer on Android and want to access a Windows File Share (XPSP3 Home). I added file security in safe mode (home hides file security). However, if I use the user login and password in ESFX it says "Can not find server". I tried "black/username" and also "username" (black is the computer name) for user.

But - If I check Anonymous, it will "log in". Except for the one I locked to only two users. That folder will kick me out with an error "No permissions". Better stated "Anon users can't view this". Anyhow, how can ES File Explorer use passwords associated with a Windows User? I even created a new user for this express purpose. FTP is way too clunky and SLOW for random access file sharing as I require. So far the SMB such as ES file uses works great (without passwords) but I see no good in sharing without passwords. Many people seem to have posted and are not sure how the passwords in Windows and ESFX relate and likewise me. Let me know. Baby crying so I gotta run.
Reply With Quote

Old 03-13-2013, 09:52 PM
MrVivona MrVivona is offline
Junior Member
Join Date: Mar 2013
Posts: 17

If all you want to do is transfer files back and forth between your PC and the SGP, try the Wi-FI File Browser app. Free and simple to use. ES File Explorer and shared folders is better if you want to play files from your PC without having to first copy them over to the SGP.
Reply With Quote

Old 07-12-2013, 08:34 AM
rojocru rojocru is offline
Junior Member
Join Date: Jul 2013
Posts: 1

To mattwesterville: I had the same problem as you. I could only log on via Anonymous. I have seen several tutorials where people have also mentioned this for both Windows XP and 7, and so they log in as anonymous as well, because that works.

Now I can login with my username and password,though I can't quite figure out how to disable / prevent Anonymous login, so there isn't much of a purpose in logging in with my username and password. (I mention one purpose below at the end of this post)

I am using a Windows XP Professional computer with SP3, and wanted to access it from my phone. I have a folder and some others that I created years ago as sharable.

So, what I did worked, but am not sure what it did, because when I undid it, I can still login with the username and password.

O.k. On to finally what I did.

1) I went to My Computer > Tools > Folder Options > View
2) Scrolled to the end of the list and Unchecked "Use simple file sharing (Recommeneded)" so that I can see the Security tab for folders.
3) I right clicked on the folder that I already have as sharable and chose Properties
4) I then went to the Security Tab and clicked once on the username of "Everyone"
4b) If Everyone is not there, just click on the Add button below, and in the box that comes up, in the area to the bottom where you can type, type in the word "Everyone" without quotes, click on Check Names to the right if you want to confirm that what you typed in is correct, and then click O.K.
5) Below it I noticed that only a few permissions were allowed for Everyone. So, I clicked on Full Control
6) And lo and behold, I was able to log on with the new user account that I had created. I was also able to logon with my current / default user account.
7) The weird thing though is that even after unchecking Full Control and only leaving Read & Execute, List Folder Contents, and Read Checked, I was still able to log on. I am pretty sure those were the original options checked. And if not, well then Read and Execute was the additional one not checked.

So, I guess doing this activated / woke up something in Windows or created some file or permissions that ES File Explorer was looking for.

You may already know of this, but I will mention it just in case.

To be able to write to the folder (save files, paste files from your phone), you will need to give the correct share permissions for the correct users. Make sure that Simple File sharing as described in Steps 1 and 2 is still unchecked. O.k. To set the shareable permissions, do the following:

1) Right click on the shareable folder and choose Properties
2) Click on the Sharing Tab and then click on Permissions located lower down on the right
3) If you want to allow only a specific user that logs in with a username and password in ES File Explorer to be able to put files on the folder on your computer, select that user by clicking on the name, and then below for the Permissions, click on the checkbox for full control under Allow.

If you also want anyone who logs on Anonymously on your phone via ES Explorer to also or instead of a specific user to have access and control of your shareable folder, then select Everyone in the first box at the top and below choose Full Control by checking the check box. If you don't want anonymous users creating files, but rather only seeing them, check only the Read checkbox under allow.

Well, I guess it was worth it being able to logon with a username and password because this way an unauthorized person can't read, delete, and/or write files from / to my shareable folder. Though this person would most likely first have to be near by your wi-fi connection and also get through the encrypted key on the wi-fi network to connect.
Reply With Quote

Old 08-27-2013, 10:03 PM
constant constant is offline
Junior Member
Join Date: Aug 2013
Posts: 1
Cool How do I make network sharing on my pc recognize my SGN2?

Thanks so much for the information you give, for even though I did not need all that info, it helped me to find out I just needed to turn on sharing. I was having the same problem like BlackDog.

I have another problem you or someone else maybe able to help me with: After my SGN2 found my pc, I clicked on it and it brought up 3 folders: 1. ADMIN$ 2. C$ 3. IPC$
When I clicked on any of those folder I got an error message the says: Login fails
This maybe caused by:
-The account has no permission

Do you know what I can do? Do you now how I can get the info like IP address and the rest for my SGN2 so I can register it with network sharing on my pc, for that maybe the problem.

Thanks for your help!

Originally Posted by alljokingaside View Post
This was very annoying to set up (in addition to setting up the home network for the first time), but I encountered the same problem and resolved it in 2 main steps with a few sub-steps (using Windows 7; I think Windows Vista should be similar):

1. Go to "Change Advanced Sharing Settings" in "Network and Sharing Center". Toggle on "Network Discovery" and "File and Printer Sharing". Turn off "Password Protected Sharing". Assuming you're in Homegroup, modify the option under "homegroup".

2. Right-click on the file you want to share (assuming it's more than just the Public Folders). Click on "Properties", then on the "Sharing" tab. From here, I believe you click on the "Share" button and add "Guest" (I also added Homegroup, but I don't think that this had any bearing on the SGP).

In the SGP, in ES File Explorer, under LAN, once you locate the computer (via scan is easiest [that capacitive button on the bottom left, click "add", click "scan"), double click on the IP address (your computer's) and, I believe, you leave the user name blank or add the user name you use to log on to Windows (even if you don't add a password).

(Since I haven't set up a password for my User Name in Windows 7, my assumptions could be wrong, but I believe that you have to switch "Password Protected Sharing" off. Otherwise, you'll need to create a user name for whatever device is accessing your computer. But then, I did just learn how to set this thing up myself (network sharing), so I could be wayyy off base here. If anyone else knows how to enable password without having to create a new User, please post. I did so initially with no success.)

If it's a Linux system, then you just have to right click on the folder icon and modify "share options" to allow access, after having (presumably) installed and configured Samba (user name, password)

If this doesn't work, let me know. There's a bunch of steps that I did and don't remember atm
Reply With Quote

Old 09-12-2013, 09:08 PM
Goucham's Avatar
Goucham Goucham is offline
Join Date: Nov 2011
Location: Jamaica, W.I.
Posts: 167

Originally Posted by constant View Post
I have another problem you or someone else maybe able to help me with: After my SGN2 found my pc, I clicked on it and it brought up 3 folders: 1. ADMIN$ 2. C$ 3. IPC$
When I clicked on any of those folder I got an error message the says: Login fails
This maybe caused by:
-The account has no permission

Do you know what I can do? Do you now how I can get the info like IP address and the rest for my SGN2 so I can register it with network sharing on my pc, for that maybe the problem.

Thanks for your help!
Those particular shares are considered administrative shares and not normally used [or seen] by end users. e.g. C$ is a share that gives access to the root of the C: drive and is only accessible to users/services that are a part of the Administrative Group and the IPC$ share is used with temporary connections between clients and servers.

On a Windows network, those shares would not be advertised because they are hidden; that is what the "$" at the end of the share name does. Pretty much every other operating system will expose these shares however. If you are interested, MS has a KB article on the subject

In short, you don't need to worry about them.
Reply With Quote

Old 04-04-2014, 08:26 AM
JPinBJ77's Avatar
JPinBJ77 JPinBJ77 is offline
Junior Member
Join Date: Apr 2014
Posts: 1
Lightbulb Dev. site info

Don't know if anyone has posted this yet but here's the dev site:

...and the page that talks about networking:

I was playing around with the remote manager, turned it on and put the provided FTP address into my browser. All my folders on my phone showed up and that was pretty cool. After that, I went back to Network (which didn't work before) and tried getting onto my desktop through wifi and it finally worked! Seems like Remote Manager turned on SMB file sharing or something. Hope it helps.
Reply With Quote


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 09:20 PM.