android
  #1  
Old 12-15-2006, 10:18 PM
The Few The Few is offline
Junior Member
 
Join Date: Dec 2006
Posts: 4
Default Broken Screen!!

I placed my Zen in my car's storage compartment and accidentally broke the screen. It still plays, but, the screen is hosed. What can I do? Can I repair it? Where do I get parts? Creative wants $140 parts and labor! Help!!
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 12-16-2006, 04:22 PM
Brodey Brodey is offline
Junior Member
 
Join Date: Dec 2006
Posts: 12
Default

If creative wants 140$ that's as much as the player itself or more!
Reply With Quote

  #3  
Old 01-05-2007, 11:26 PM
kidmullet kidmullet is offline
Junior Member
 
Join Date: Dec 2006
Posts: 2
Question Zen V Plus Screen Problems

yea i was just wondering y my screen keeps getttin darker like i was at school and i was lisenting to it and in the corner it was really dark there then i turned it off then after school i turned it on and i can bearly read the letters across the screen can some body help me about this???
Reply With Quote

  #4  
Old 01-06-2007, 05:07 PM
Steeev Steeev is offline
Junior Member
 
Join Date: Dec 2006
Posts: 15
Default

STUPID QUESTION ALERT!!!

Is it charged up?
Reply With Quote

  #5  
Old 01-06-2007, 08:35 PM
bionicslim bionicslim is offline
Junior Member
 
Join Date: Jan 2007
Posts: 1
Default My screen broke. i need help

I just got my Zen V. Then a week later, it froze up. I didnt have time to look up info on what was wrong with it, and i made the mistake of taking it apart. now my screen doesnt work. Can someone link me to a help page on how to reassemble it?
Reply With Quote

  #6  
Old 01-19-2007, 02:40 PM
alt-master alt-master is offline
Junior Member
 
Join Date: Jan 2007
Posts: 3
Default

the question is not stupid anyway

unfortunately I have the same problem.
actually, this definetely refers to physical breakage/defect, therefore it should be taken to creative and fixed there.

however maybe someone else has experienced such problem? have you found any solution?
Reply With Quote

  #7  
Old 01-19-2007, 02:44 PM
alt-master alt-master is offline
Junior Member
 
Join Date: Jan 2007
Posts: 3
Default

maybe you should look there
http://www.anythingbutipod.com/forum...ead.php?t=7095
Reply With Quote

  #8  
Old 01-19-2007, 03:14 PM
ZenChick's Avatar
ZenChick ZenChick is offline
Ultra Senior Member
 
Join Date: Jul 2006
Location: Right... Behind... You...
Posts: 7,427
Default

This sounds like the backlight failing to me. There's no solution for that.
__________________
ZenChick - The one them iPod-owners warned you about!
Creative Zen Vision:M 30GB * Creative MuVo N200 1GB * Philips GoGear Vibe 4GB
Resident Linux Geekette ** Got IRC? Look me up on irc.freenode.net #AnythingButiPod
Reply With Quote

  #9  
Old 01-20-2007, 01:56 AM
emar5 emar5 is offline
Junior Member
 
Join Date: Dec 2006
Posts: 3
Default

maybe the OLED pixels died or something. my player had a distinct vertical blue line on the left side of the screen, at first it disappears and re-appears every now and then, after a while it didn't go away anymore. i returned it to the store where i bought it to have it replaced. they said that they have to send it to their tech guys to check the problem. its been a week already, but the sales clerk said that they sent the player to the distributor cause they don't know how to fix it. hopefully i just get a new player.
Reply With Quote

  #10  
Old 01-22-2007, 04:40 PM
Chensington's Avatar
Chensington Chensington is offline
Member
 
Join Date: Dec 2006
Location: Vermont, United States
Posts: 317
Default

Quote:
Originally Posted by ZenChick View Post
This sounds like the backlight failing to me. There's no solution for that.
If I'm not mistaken, the Zen V/Zen V Plus has an OLED screen, and OLED screens do not require backlighting, since they emit their own light.

Anyways, OLED screens are pretty sketchy, are known to have a far shorter lifespan than LCD screens, not to mention that certain pixels can wind up dying before others, and this is mainly due to the sensitivity of the organic materials uses in such screens.

Assuming that you haven't had the player for very long, however, this shouldn't be your problem. It's probably just physical abuse, maybe a defective battery or screen (judging by the fact that it's an OLED screen, it may be the latter). However, you should give us a little more information in order to receive a proper diagnosis.
__________________
[size=1]Sennheiser EH350 Headphones, Sennheiser HD202 Headphones, Koss KSC75, JVC HA-FX34, Creative Zen Mozaic (16GB, Black)
Reply With Quote

  #11  
Old 03-18-2007, 07:06 PM
Kie Kie is offline
Junior Member
 
Join Date: Mar 2007
Posts: 2
Default Broken Screen

My Creative Screen doesn't work after the player got squashed. Externally it is fine but the warranty is up. Is there any way I could fix this myself, and is it worth taking into a repair shop or would they not be able to fix it.
Reply With Quote

  #12  
Old 03-19-2007, 03:30 AM
SalamandoX's Avatar
SalamandoX SalamandoX is offline
Junior Member
 
Join Date: Feb 2007
Location: Portland, OR
Posts: 21
Default

I wouldn't be worth it. Just get a new one. Taking it apart is risky and taking it to repair would cost more in the long run.
__________________
PC: Athlon XP 2600+, Nvidia GeForce FX 5200, Creative Sound Blaster Live 5.1, 512 MB Ram, Seagate Baracuda 7200 RPM HD. (It is the best crappy computer you can get!)

Mp3 Player: White/Orange Zen V 1GB (Small is cute, right?)
Reply With Quote

  #13  
Old 04-26-2007, 12:26 PM
tambu tambu is offline
Junior Member
 
Join Date: Apr 2007
Posts: 2
Default Problem with screen

Hello, i got my Zen V+ back from warranty about week ago. (froze and didnt start up on 3rd day, firmware was latest). Yesterday i saw that white color is being drawn to the upper and lower edge of the screen (there is also in the right place, just lighter). Today the screen is very dark, at the first place i tought it didnt start up. Brightness is at 100%, got latest firmware and im kind of annoyed about it. Second problem with only like week after ordering.
Reply With Quote

  #14  
Old 04-26-2007, 01:38 PM
ZenChick's Avatar
ZenChick ZenChick is offline
Ultra Senior Member
 
Join Date: Jul 2006
Location: Right... Behind... You...
Posts: 7,427
Default

Call them back up and send it back!

I'm sorry this is happening to you. Sometimes these things happen - it doesn't matter what kind of device it is or who made it. I once had a computer - a Commodore 64 - that I had to have fixed three times before I finally gave up and fixed it myself.

I don't suggest that extreme, though. You player is under warranty, and they are responsible for giving you back a fully-functioning player when doing warranty work. Hold them to that, and don't give up!
__________________
ZenChick - The one them iPod-owners warned you about!
Creative Zen Vision:M 30GB * Creative MuVo N200 1GB * Philips GoGear Vibe 4GB
Resident Linux Geekette ** Got IRC? Look me up on irc.freenode.net #AnythingButiPod
Reply With Quote

  #15  
Old 04-27-2007, 06:06 AM
tambu tambu is offline
Junior Member
 
Join Date: Apr 2007
Posts: 2
Default

Thanks. The reason why i didn't send it right away was because there is no warranty in my city. have to send to other city and when i keep sending it many times, i lose money for their mistake. If it breaks 3rd time i call to consumer protection.
Reply With Quote

  #16  
Old 06-30-2007, 03:14 PM
RAPCAT's Avatar
RAPCAT RAPCAT is offline
Junior Member
 
Join Date: May 2007
Posts: 23
Exclamation My Zen Vplus screen is missing pixels?

So one day I turned on my 2 week old Zen V plus and the screen has a
black line across the top!! It kinda went on and off as I went through the menus. I reset the player,but it didnt do anything. What do i Do?
__________________
Get Hyphy Stipid DumbRetarded
GHOSTRIDETHEWHIP!!!
Reply With Quote

  #17  
Old 06-30-2007, 03:29 PM
RAPCAT's Avatar
RAPCAT RAPCAT is offline
Junior Member
 
Join Date: May 2007
Posts: 23
Default

oops you guys can delete this thread I got my answer in this forum...
__________________
Get Hyphy Stipid DumbRetarded
GHOSTRIDETHEWHIP!!!
Reply With Quote

  #18  
Old 07-01-2007, 10:13 AM
RAPCAT's Avatar
RAPCAT RAPCAT is offline
Junior Member
 
Join Date: May 2007
Posts: 23
Default

wait a second..I still need help! would the filmware fix this problem or should I return it for an exchange?????
__________________
Get Hyphy Stipid DumbRetarded
GHOSTRIDETHEWHIP!!!
Reply With Quote

  #19  
Old 07-02-2007, 12:55 PM
SDZenVPlus's Avatar
SDZenVPlus SDZenVPlus is offline
Junior Member
 
Join Date: Jun 2007
Posts: 11
Default

Exchange it ASAP.
Reply With Quote

  #20  
Old 07-02-2007, 09:51 PM
RAPCAT's Avatar
RAPCAT RAPCAT is offline
Junior Member
 
Join Date: May 2007
Posts: 23
Default

so more pixels will go away?
__________________
Get Hyphy Stipid DumbRetarded
GHOSTRIDETHEWHIP!!!
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 10:55 AM.