android
Go Back   abi>>forums > MP3 Players By Brand > Insignia > Insignia Pilot

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 05-05-2008, 12:11 PM
dbzzx dbzzx is offline
Junior Member
 
Join Date: Oct 2006
Posts: 14
Default Im getting aggravated with this....Dust under screen!

Ok so it started as a few specks of dust, now its all over the screen...Are they all like this? I had it since release.

Another problem, my battery dies every few hours now...about4-5 to be exact.

I only use it for about 5 hours a day, are the batterys this crappy?
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 05-05-2008, 07:07 PM
RCM's Avatar
RCM RCM is offline
Ultra Senior Member
 
Join Date: Mar 2007
Location: I'm not telling
Posts: 1,549
Default

Sounds like the battery is not holding a charge as well as it should, as for the dust, try opening it and cleaning it, I'm not taking any responsibility for you maybe messing up your player if you do decide to open it.
__________________
Sansa View 16GB (DEAD)
Sony Walkman NWZ-S544 (DEAD has a mind of it's own and don't feel like fixing it!)
Zune HD 32GB (Retired)
Samsung Galaxy tab 2 7.0
Motorola Droid razr m
Reply With Quote

  #3  
Old 05-05-2008, 11:34 PM
dbzzx dbzzx is offline
Junior Member
 
Join Date: Oct 2006
Posts: 14
Default

How would I go about opening it?
Reply With Quote

  #4  
Old 06-05-2008, 04:32 AM
elpyro elpyro is offline
Junior Member
 
Join Date: May 2008
Posts: 25
Default

for the battery power, you should lower the brightness level mine was high and my battery was gone in just a couple hours
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:01 AM.