android
  #1  
Old 11-06-2008, 04:28 PM
LenG58 LenG58 is offline
Junior Member
 
Join Date: Nov 2008
Posts: 8
Default No Display

Hello All,

My daughter's 4GB Zen V display no longer works. It was purchased new in December 2006, so no longer under warranty. It still takes a charge (although you do not see the charging icon...you do see the blue light pulsing on and off), it still plays music and it is still recognized when plugged into a pc.

I have tried reset (no help) and...
I have tried Creative's MP3 Recovery Tool (no help) and...
I even tried reseating the battery (also no help)

Is there anything else I might try?

Thanks in advance.

-Len
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 11-06-2008, 05:46 PM
BobbyRS's Avatar
BobbyRS BobbyRS is offline
Ultra Senior Member
 
Join Date: Oct 2007
Location: USA
Posts: 6,575
Default

Hello LenG58. Welcome. It sounds like your display has gone out and would need replaced (Ebay is your friend). It is a common problem for the Zen V's. See this thread here for more information.
__________________
.
~Light travels faster than sound, which is why some people appear to be bright until they speak~

Zen FAQ
Reply With Quote

  #3  
Old 11-07-2008, 02:05 PM
LenG58 LenG58 is offline
Junior Member
 
Join Date: Nov 2008
Posts: 8
Default

Thank you, BobbyRS.
Reply With Quote

  #4  
Old 11-07-2008, 02:25 PM
BobbyRS's Avatar
BobbyRS BobbyRS is offline
Ultra Senior Member
 
Join Date: Oct 2007
Location: USA
Posts: 6,575
Default

No problem. Good luck!
__________________
.
~Light travels faster than sound, which is why some people appear to be bright until they speak~

Zen FAQ
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:28 PM.