android
Go Back   abi>>forums > MP3 Players By Brand > Creative > Zen

Reply
 
Thread Tools Search this Thread Display Modes
  #21  
Old 01-13-2008, 06:55 PM
ZenChick's Avatar
ZenChick ZenChick is offline
Ultra Senior Member
 
Join Date: Jul 2006
Location: Right... Behind... You...
Posts: 7,427
Default

If the product you got was defective, the store is obligated to let you exchange it for another one, regardless of the condition of the packaging (since you had to get the thing open to find out it doesn't work, right?).
__________________
ZenChick - The one them iPod-owners warned you about!
Creative Zen Vision:M 30GB * Creative MuVo N200 1GB * Philips GoGear Vibe 4GB
Resident Linux Geekette ** Got IRC? Look me up on irc.freenode.net #AnythingButiPod
Reply With Quote

Advertisement [Remove Advertisement]

  #22  
Old 01-13-2008, 07:47 PM
creativezenlover creativezenlover is offline
Junior Member
 
Join Date: Jan 2008
Posts: 19
Default

Quote:
Originally Posted by ZenChick View Post
If the product you got was defective, the store is obligated to let you exchange it for another one, regardless of the condition of the packaging (since you had to get the thing open to find out it doesn't work, right?).
Yes you are absolutely right thanks for the comment i should check it out but lets just say that im in a situation like this. What if they don't believe me? Saying that the problem was not the players fault and it was blamed to the person using the player like it's forcefully damaged then what should I do? =( Not that I did this Im just very skeptic right now =( since im kind of sad that it didnt work for me on the first day I bought it.
Reply With Quote

  #23  
Old 01-13-2008, 07:49 PM
RCM's Avatar
RCM RCM is offline
Ultra Senior Member
 
Join Date: Mar 2007
Location: I'm not telling
Posts: 1,549
Default

Well if you didn't sit on this one (sorry couldn't resist) then you can return it, they will take it back no matter what the packaging looks like.
__________________
Sansa View 16GB (DEAD)
Sony Walkman NWZ-S544 (DEAD has a mind of it's own and don't feel like fixing it!)
Zune HD 32GB (Retired)
Samsung Galaxy tab 2 7.0
Motorola Droid razr m
Reply With Quote

  #24  
Old 01-13-2008, 08:04 PM
creativezenlover creativezenlover is offline
Junior Member
 
Join Date: Jan 2008
Posts: 19
Default

Quote:
Originally Posted by RCM View Post
Well if you didn't sit on this one (sorry couldn't resist) then you can return it, they will take it back no matter what the packaging looks like.
lol thanks for the comment I feel a lot relieved after reading your comment, I'm just confused, mad, and sad at the same time since I paid more than 200 dollars for it, I'd be really mad if I couldn't return it at all I would've wasted my money thanks again I just wanted to make sure that I'd be able to return it. But one question what are the chances of this happening to me again? I mean seriously this is the first time i've bought something defective from creative, and bestbuy, come to think of it, i've never bought something defective in my life =p
Reply With Quote

  #25  
Old 01-13-2008, 08:24 PM
creativezenlover creativezenlover is offline
Junior Member
 
Join Date: Jan 2008
Posts: 19
Default

I really don't want people at bestbuy to say that the ZEN had customer abuse towards it... LETS just hope... thats what I really want to know
Reply With Quote

  #26  
Old 01-13-2008, 09:14 PM
TheElite TheElite is offline
Junior Member
 
Join Date: Aug 2007
Posts: 48
Default

I doubt this would happen to you again; its just a matter of bad luck when you get a defective player. You can exchange it as long as nothing 'physically' has happened to it.
Reply With Quote

  #27  
Old 01-13-2008, 10:17 PM
creativezenlover creativezenlover is offline
Junior Member
 
Join Date: Jan 2008
Posts: 19
Default

Thank you Elite I'll return it as soon as possible it's good to know that it was just bad luck.. which i normally have... its all KARMA I do too many bad things...
Reply With Quote

  #28  
Old 01-13-2008, 10:21 PM
RCM's Avatar
RCM RCM is offline
Ultra Senior Member
 
Join Date: Mar 2007
Location: I'm not telling
Posts: 1,549
Default

Quote:
Originally Posted by creativezenlover View Post
Thank you Elite I'll return it as soon as possible it's good to know that it was just bad luck.. which i normally have... its all KARMA I do too many bad things...
My first E200 was defective, I returned it and got another no problems at all
__________________
Sansa View 16GB (DEAD)
Sony Walkman NWZ-S544 (DEAD has a mind of it's own and don't feel like fixing it!)
Zune HD 32GB (Retired)
Samsung Galaxy tab 2 7.0
Motorola Droid razr m
Reply With Quote

  #29  
Old 01-14-2008, 12:40 AM
ZenChick's Avatar
ZenChick ZenChick is offline
Ultra Senior Member
 
Join Date: Jul 2006
Location: Right... Behind... You...
Posts: 7,427
Default

Quote:
Originally Posted by creativezenlover View Post
I really don't want people at bestbuy to say that the ZEN had customer abuse towards it... LETS just hope... thats what I really want to know
Honey, I think you're getting yourself all worked up over nothing. Stores - particularly places like Best Buy - deal with customer returns all the time, so it's likely going to be a non-event. However, if worst really did come to worse, your player is still under full warranty, and you could contact Creative to arrange for its repair or replacement.

Relax, it'll be fine.
__________________
ZenChick - The one them iPod-owners warned you about!
Creative Zen Vision:M 30GB * Creative MuVo N200 1GB * Philips GoGear Vibe 4GB
Resident Linux Geekette ** Got IRC? Look me up on irc.freenode.net #AnythingButiPod
Reply With Quote

  #30  
Old 01-15-2008, 02:30 PM
creativezenlover creativezenlover is offline
Junior Member
 
Join Date: Jan 2008
Posts: 19
Default

Okay guys..... thanks for all the help but my ZEN still HAS PROBLEMS!!! Im not even joking. I returned my defective one yesterday but when I chose another one it has the same results.... Am I doing something wrong? is it not charged enough cause I'm charging through USB is it normal for it to have a white screen? Until the whole battery is charged full? How Do I make it work, Am I missing something please help
=,( I'm not playing around i'm being serious this actually happened to me again with a new zen.....
Reply With Quote

  #31  
Old 01-15-2008, 02:38 PM
creativezenlover creativezenlover is offline
Junior Member
 
Join Date: Jan 2008
Posts: 19
Default

Quote:
Originally Posted by creativezenlover View Post
Okay guys..... thanks for all the help but my ZEN still HAS PROBLEMS!!! Im not even joking. I returned my defective one yesterday but when I chose another one it has the same results.... Am I doing something wrong? is it not charged enough cause I'm charging through USB is it normal for it to have a white screen? Until the whole battery is charged full? How Do I make it work, Am I missing something please help
=,( I'm not playing around i'm being serious this actually happened to me again with a new zen.....
I'm really depressed cause of this situation.... I don't understand... I really think I'm not doing something properly I mean all there is to it is charge it and then it turns on correct? Maybe I should wait longer? Cause once I turn it on after 5 hours it had the same results with my previous ZEN that was returned. I'll charge it more to see what would happen... I thank you all deeply for all the support you have given me.
Reply With Quote

  #32  
Old 01-15-2008, 04:57 PM
ZenChick's Avatar
ZenChick ZenChick is offline
Ultra Senior Member
 
Join Date: Jul 2006
Location: Right... Behind... You...
Posts: 7,427
Default

Five hours? That's all you've been giving it for first-time charge? I would recommend 24 hours for first-time charge, though I don't think it will take quite that long.
__________________
ZenChick - The one them iPod-owners warned you about!
Creative Zen Vision:M 30GB * Creative MuVo N200 1GB * Philips GoGear Vibe 4GB
Resident Linux Geekette ** Got IRC? Look me up on irc.freenode.net #AnythingButiPod
Reply With Quote

  #33  
Old 01-15-2008, 06:12 PM
TheElite TheElite is offline
Junior Member
 
Join Date: Aug 2007
Posts: 48
Default

Lol mine didn't even take 5 hours...it took 3.5 hours for me =/
Since it has the same problem as the previous player, I'd just return it and get another one. Nothing much you can do now.
Reply With Quote

  #34  
Old 01-15-2008, 06:44 PM
creativezenlover creativezenlover is offline
Junior Member
 
Join Date: Jan 2008
Posts: 19
Default

So, basically I should charge it for over 24 hours... and the ZEN would boot up? since right now I dont even see the battery image and plus the screens just plain white/gray... well its been 8 hours so far... wonder how much longer it needs to charge... im just curious would it boot up if its fully charged? I cant even tell if it's half charged or even full without the battery display thingy... PLUS I already returned my player once... yesterday and got a new one so... there must be something I'm not doing properly... probably the battery needs a lot of juice or something I don't know =/
Reply With Quote

  #35  
Old 01-16-2008, 01:08 AM
ZenChick's Avatar
ZenChick ZenChick is offline
Ultra Senior Member
 
Join Date: Jul 2006
Location: Right... Behind... You...
Posts: 7,427
Default

Is there any kind of blue light around the power switch? If so, is the light steady or is it flashing?
__________________
ZenChick - The one them iPod-owners warned you about!
Creative Zen Vision:M 30GB * Creative MuVo N200 1GB * Philips GoGear Vibe 4GB
Resident Linux Geekette ** Got IRC? Look me up on irc.freenode.net #AnythingButiPod
Reply With Quote

  #36  
Old 01-16-2008, 01:56 AM
Hmpf Hmpf is offline
Junior Member
 
Join Date: Jan 2008
Posts: 2
Default

Quote:
So, basically I should charge it for over 24 hours... and the ZEN would boot up? since right now I dont even see the battery image and plus the screens just plain white/gray... well its been 8 hours so far... wonder how much longer it needs to charge... im just curious would it boot up if its fully charged?
I don't think that charging the player even longer will help...

When i got mine, i installed the software, and the player booted up the second i plugged it in.


I'd guess that your Zen tries to boot and charge, but the USB port it is connected to doesn't provide enough current. So if it's connected to a front USB port, try one on the back of your PC.
Reply With Quote

  #37  
Old 01-16-2008, 01:36 PM
ZenChick's Avatar
ZenChick ZenChick is offline
Ultra Senior Member
 
Join Date: Jul 2006
Location: Right... Behind... You...
Posts: 7,427
Default

Quote:
Originally Posted by Hmpf View Post
I'd guess that your Zen tries to boot and charge, but the USB port it is connected to doesn't provide enough current. So if it's connected to a front USB port, try one on the back of your PC.
I was just beginning to think that as well. Perhaps what he needs is a wall charger.
__________________
ZenChick - The one them iPod-owners warned you about!
Creative Zen Vision:M 30GB * Creative MuVo N200 1GB * Philips GoGear Vibe 4GB
Resident Linux Geekette ** Got IRC? Look me up on irc.freenode.net #AnythingButiPod
Reply With Quote

  #38  
Old 01-16-2008, 02:29 PM
creativezenlover creativezenlover is offline
Junior Member
 
Join Date: Jan 2008
Posts: 19
Default

I'm was actually charging from the usb ports on the back of my pc all along... And yes the blue light on the side is flashing I think thats indicating that it's still charging but for some weird reason it stops flashing sometimes and continues to flash after 5 minutes or so... PLUS when I try turning off the ZEN it just restarts again SO I CANT EVEN CLOSE MY ZEN! this is even worse than before the only way for me to close it was through the reset hole... maybe I should refund it to look for another mp3 player... probably something like... a Creative Zen Vision M
Reply With Quote

  #39  
Old 01-16-2008, 03:25 PM
Einstazella Einstazella is offline
Junior Member
 
Join Date: Jan 2007
Posts: 24
Default White screen after removing hold

I bought a zen 8gb 2day and i get a white screen right after i remove the hold after the screen turns off , and i have to turn the device off and on again for the screen to display properly , any help ???

thx in advance
Reply With Quote

  #40  
Old 01-16-2008, 05:22 PM
TheElite TheElite is offline
Junior Member
 
Join Date: Aug 2007
Posts: 48
Default

That's very odd...well, I'd return it and try your luck with another one. If it happens again, I'd say there was something wrong with your USB port. You've got nothing to lose - might as well return it and see how that goes. =]
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 04:59 AM.