Go Back   abi>>forums > MP3 Players By Brand > Creative > Zen Vision:M

Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 12-12-2008, 11:26 PM
wheredjaredgo wheredjaredgo is offline
Junior Member
Join Date: Dec 2008
Posts: 3
Wink new hard drive old one died wont take to firmware install

I need help. My wife dropped my zen on the concrete, and the hardrive started clicking, so i took it apart and pulled the sk3008gal toshiba out of it. and bought a used one from a computer store that is guaranteed for 30 days. I just installed it and it was a good start, i heard the drive spinning, no clicking, but when i go to install firmware it reboots sucessfully but past the big letter zen screen it just goes black and stays black. until the battery dies. so i restart it and does the same. So im forced to hit the reset and go to the support screen and try to keep deleting the firmware and reload it but same stuff. and it says am i sure i to delete the same hardware im fixing to install so it says the firmware is there in my zen. I guess there could be something else wrong besides the harddrive. Any suggestions would be greatly appreciated?
Reply With Quote

Advertisement [Remove Advertisement]


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 03:23 PM.