android
Prev Previous Post   Next Post Next
  #1  
Old 05-18-2009, 06:35 PM
k0ni0ph0bia k0ni0ph0bia is offline
Junior Member
 
Join Date: May 2009
Posts: 8
Exclamation Help with my Fuze's scroll wheel

Hey People. I'd really like to figure out if this can be fixed or not before I go out and order a new fuze. Stupid freakin' me, I went and got my Fuze all wet and whatnot and it wouldn't turn on. So I got pretty pissed off with myself almost threw it on the floor but realized I woulda made it much worse, so decided not to. After a few hours, I decided to give it another shot AND IT TURNED ON... but it was a blank white screen. So I got pissed again and decided to solve the problem myself. BAD IDEA! I opened it up after looking at the disassembly, tinkered around not doing much, and looked to see if anything was jammed, wet, etc. Nothing. So I turn it on again AND IT WORKS FINE NOW, but I turn it back off, put the faceplate back on with the ribbon inserted and tried it. I noticed the left, right, and select buttons were working but the point of all this is that the freaking scroll wheel, the thing I need to navigate with, doesn't work at all. But wheen the screen goes black and I turn the wheel, the display comes back. So WTF! It seems as though it works but it just won't navigate! Any help is HIGHLY appreciated.
Reply With Quote

Advertisement [Remove Advertisement]

 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 12:10 AM.