android
  #1  
Old 06-08-2009, 03:52 PM
Mickz Mickz is offline
Junior Member
 
Join Date: Jun 2009
Posts: 12
Default K3 - Stuck on 'Samsung' logo

I am frustrated as hell. It's my first day of purchase. And i think it was stupid of me trying to upgrade firmware first. And going through all of it. Without listening to any song first!

Here is what happened. I thought i would upgrade to the latest firmware. "4.10" Which i downloaded it from Samsung Singapore site. After upgrading... In ' My Computer' the icon displayed as "removal storage" no longer YP-K3. When i doubled clicked on it... it was asking for format. I thought it would be okay to format. And when i let it to format. After it... It is no longer even charging. Just gets stuck on "Samsung" logo, When i start. It won't proceed. And neither EmoDio, SMS or Computer is detecting it. When i opened the automatic firmware program... it is asking me to connect the device. Now how can i possibly do anything to recover? Since it's not getting detected anywhere.

And yes i tried to reset it too!

I also restarted my system... re-plugged the usb cable. Changed the ports and all!
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 06-09-2009, 05:51 AM
Mickz Mickz is offline
Junior Member
 
Join Date: Jun 2009
Posts: 12
Default

Got mine replaced. Close the thread please.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:11 PM.