android
Prev Previous Post   Next Post Next
  #1  
Old 07-01-2009, 03:16 PM
biggeek biggeek is offline
Junior Member
 
Join Date: Jun 2009
Posts: 7
Unhappy Zen X-Fi 8 GB Dead After Two Weeks

I actually had been super careful with my 8GB Zen X-Fi because I had not purchased a pouch or cover for it.

But two weeks after my first use, I went to turn it on...And nothing happened.

I figured that the battery had lost it's charge, so I plugged it into my computer and nothing. The power LED on the Zen stayed dark and my computer wouldn't acknowledge that it was plugged in. The reset button didn't work, either. It turned into a $130 paperweight.

Now I had read about the reliability issues that a minority of people have had with the Zens, so while I don't enjoy having to deal with it...It wasn't a total surprise. I purchased it from NewEgg which has a reputation for fast replacement within the 30 day return period, although it took $7.50 to ship it back.

A new replacement Zen X-Fi is on it's way from NewEgg. Now if this NEXT one dies prematurely or acts up, I think that I will join the "Anything but Zen" crowd.

Addendum: Yes, I really liked my Zen while it worked.
Reply With Quote

Advertisement [Remove Advertisement]

 

Tags
broken, dead, return

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 02:04 PM.