android
  #1  
Old 10-03-2009, 03:30 AM
mathfeel mathfeel is offline
Junior Member
 
Join Date: Sep 2009
Posts: 8
Default tag displayed as unknown.

I have a very weird situation. I have a classical CD consisting of six tracks of two pieces: three movement each. The files are in FLAC.

I use mp3tag to tag them all. When I upload them to P3, the first three track (the first piece) have all the tracks displayed correctly, but the last three tracks (the second piece) are all shown as unknown (artist, album, title...).

What is more strange is embed album art is displayed correctly for ALL six tracks. I am not sure what to make of the tag situation.

Anyone?
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 10-03-2009, 02:05 PM
triarii117's Avatar
triarii117 triarii117 is offline
Senior Member
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 554
Default

I think the P3 has problems with FLAC tags. Others have mentioned this too.
__________________
PMPs: Cowon J3, Samsung P3(touchscreen problems), Creative Zen (4GB, black)
Headphones: Panasonic RP-HTX7, Philips, JVC Marshmallow IEMS (why not)
Reply With Quote

  #3  
Old 10-03-2009, 04:22 PM
mathfeel mathfeel is offline
Junior Member
 
Join Date: Sep 2009
Posts: 8
Default

Quote:
Originally Posted by triarii117 View Post
I think the P3 has problems with FLAC tags. Others have mentioned this too.
FLAC doesn't take id3v2 tag, correct?

Last edited by mathfeel; 10-03-2009 at 04:32 PM.
Reply With Quote

  #4  
Old 10-03-2009, 08:41 PM
Detroit's Avatar
Detroit Detroit is offline
Member
 
Join Date: Aug 2008
Location: IN
Posts: 184
Default

All the songs on my P3 are FLAC and they work just fine. Are the titles different for each of your files? Not sure what the problem could be as I use Mp3Tag too.
__________________
Sources: Auzentech Prelude, NuForce uDAC, Samsung P3, Zune HD
Phones: Denon D7000 w/ J$ Pads, Denon D2000, Ultrasone HFI-780, Phonak Audeo PFE

Reply With Quote

  #5  
Old 10-04-2009, 12:11 AM
triarii117's Avatar
triarii117 triarii117 is offline
Senior Member
 
Join Date: Jun 2009
Location: Austin, TX
Posts: 554
Default

Quote:
Originally Posted by mathfeel View Post
FLAC doesn't take id3v2 tag, correct?
Maybe. I'm not too sure, I do not mess with FLAC very often.
__________________
PMPs: Cowon J3, Samsung P3(touchscreen problems), Creative Zen (4GB, black)
Headphones: Panasonic RP-HTX7, Philips, JVC Marshmallow IEMS (why not)
Reply With Quote

  #6  
Old 10-04-2009, 03:46 AM
mathfeel mathfeel is offline
Junior Member
 
Join Date: Sep 2009
Posts: 8
Default

Quote:
Originally Posted by Detroit View Post
All the songs on my P3 are FLAC and they work just fine. Are the titles different for each of your files? Not sure what the problem could be as I use Mp3Tag too.
Yes, each movement is labeled with 1, 2, 3 etc. So are always different.
Reply With Quote

  #7  
Old 10-04-2009, 08:20 AM
mathfeel mathfeel is offline
Junior Member
 
Join Date: Sep 2009
Posts: 8
Default resolution

I think I found the bug and my experience of tracking it down might be helpful to others who also use mp3tag (or other tagger) and USB mass storage mode like me.

Actually I accidentally solved the problem without knowing what's wrong at first when I decided to clean up the tags, leaving only those used by the P3. It didn't work at first. Then I decided, perhaps I need to create a new file in the file system. This seemed reasonable to me if P3's algorithm is such that it would not rescan the all files for tags update but only new files. So I copy-delete-rename to replace the file with a new copy.

Not yet unmount the P3, I didn't know if it worked. In the mean time, I also added few new files. Rebooted P3. The problematic old files now works, but three other songs are having similar problems. When I inspected, two of them had a long UNSYNCLYRICS field and the other one's TITLE field was very very long due to a buggy automatic tagging script I wrote. Fixed those, copy-delete-rename. Everything works. The problem files I started this thread with did not have long field, but I suspect P3 did not like the fact that they had two "PERFORMER" fields in them. (They were for the violinist and the pianist).

So to summarize for other user who also uses tagger program + UMS mode:
1. There is some implicit limit to how long a tag field content can be. Even if mp3tag let you have it, P3 does not like it. So remove all long fields.
2. P3 would re-read your changed tag only if it's a new file. So for any change that do not show up: copy-delete-rename.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:14 PM.