android
Go Back   abi>>forums > MP3 Players By Brand > Creative > Zen X-Fi2

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-08-2010, 05:59 PM
monoke monoke is offline
Junior Member
 
Join Date: Jan 2010
Posts: 6
Default Please help! Music tracks not showing up properly

My brother received a X-Fi2 as an Xmas gift. He has only got round to using it tonight, and has come upon a few problems.

First of all the Creative Centrale software, it's completely useless. I've practically washed my hands with it and refuse to go near it again unless it's essential.

I'm not very overly computer friendly, so I figured the easiest way to get music onto the player would be to treat it as a mass storage device, and simply drag and drop albums from his iTunes folder into the drive.

This is what has happened so far.

-12 albums are on the player right now.

-Only 4 albums are listed under 'Albums'

-6 albums have to be accessed through the 'Artist' menu.

-The remaining two albums can only be accessed through the 'All Tracks' menu.

-Album art is only available for 7 albums.

-All albums are of 'Unknown' genre.

Why is this. All artist, album, genre, cover art information is in place in iTunes, but the information is not being transferred over?

Am I missing something? I read on another website it's okay to drag and drop. How else can I get music onto the player without using Creative Centrale?

Thanks.
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 01-08-2010, 07:19 PM
FrododorF's Avatar
FrododorF FrododorF is offline
Senior Member
 
Join Date: Feb 2007
Location: Montgomery AL
Posts: 712
Default

you need to fix the id3 tags because the library builds from them, i use media monkey, there are other programs too but my mind is blanking right now. also you need to make your thread title more informative please.
__________________
Leprechauns hide their gold in Electrical Outlets..
..Use Forks to Get em Out..
Reply With Quote

  #3  
Old 01-09-2010, 05:08 AM
ZenChick's Avatar
ZenChick ZenChick is offline
Ultra Senior Member
 
Join Date: Jul 2006
Location: Right... Behind... You...
Posts: 7,427
Default

One of the best, freely-available freestanding ID3 tag editors is MP3Tag. It is a very powerful yet intuitive bulk tagging utility.

And I second the thread title request. Titles such as "Please Help" are not helpful at all. I fixed it this time; but in the future, such threads will likely be closed without comment.
__________________
ZenChick - The one them iPod-owners warned you about!
Creative Zen Vision:M 30GB * Creative MuVo N200 1GB * Philips GoGear Vibe 4GB
Resident Linux Geekette ** Got IRC? Look me up on irc.freenode.net #AnythingButiPod
Reply With Quote

  #4  
Old 01-09-2010, 10:06 AM
monoke monoke is offline
Junior Member
 
Join Date: Jan 2010
Posts: 6
Default

Thanks for your replies. My apologies on the thread title, I'm new to forums, so I'm unaware of the regular procedure.

I'll try to be a little bit more informative as requested. These are my main issues.

1) Is it okay to successfully drag and drop music directly onto the player, without using any software such as iTunes, WMP of Creative Centrale?

2) If I must use software, could you please explain how to add music using iTunes or WMP.

3) The problem I'm having seems to be the result of tagging. This is why certain albums aren't appearing in the 'Albums' menu, but still appearing in the "All Tracks' menu. But in iTunes all this information is correctly in place, so why am I still having problems?

ID3Tag's are something I'm not very familiar with. I thought by changing the information of each track in iTunes I'm changing the ID3Tag's?

Is it necessary to use other software for this?

These are probably very naive questions, but this is all very new to me.

Thanks again.
Reply With Quote

  #5  
Old 01-09-2010, 10:37 AM
badazzmofo badazzmofo is offline
Junior Member
 
Join Date: Dec 2009
Posts: 75
Default

1: yes

2: you only need software to create the playlists but you can play music from the /music directory directly.

3: dont use itunes, itunes is for mac and ipod and it hates cross-compatible hardware.
use either winamp http://www.winamp.com/media-player or mediamonkey http://www.mediamonkey.com/download/ to change those id3 tags and to create playlists
Reply With Quote

  #6  
Old 01-09-2010, 12:46 PM
dkstott dkstott is offline
Junior Member
 
Join Date: Jan 2010
Posts: 36
Default

The solution to the problem should lie within Centrale....after all, isn't that why Creative provides it??

if Creative did things right, we would not have to refer anyone to media monkey or any other 3rd party software provider to fix the album art issues.

Dave
Reply With Quote

  #7  
Old 01-10-2010, 08:27 AM
monoke monoke is offline
Junior Member
 
Join Date: Jan 2010
Posts: 6
Default

Thanks for your advice once again.

I've downloaded and installed mediamonkey, checked that the tag information was correct, saved, then sent to the player. But I'm still having the same problem.

Out of ten albums, only one is listed under "Albums'.

Out of ten artists, only 3 are listed under 'Artists'.

Only 'Unknown Genre' is listed under 'Genre'. But when I click into 'Unknown' I come across more artist names?

I don't really see what the problem could be. All artist, album, genre and artwork is present in the tags.

I'm really confused and very frustrated!

Last edited by monoke; 01-10-2010 at 09:35 AM.
Reply With Quote

  #8  
Old 01-10-2010, 08:41 AM
monoke monoke is offline
Junior Member
 
Join Date: Jan 2010
Posts: 6
Default

I've just downloaded and used mp3tag, but the results have been the exact same.

Am I missing something?

I'm beginning to think there's something wrong with the player...
Reply With Quote

  #9  
Old 01-10-2010, 10:50 AM
Olley Olley is offline
Ultra Senior Member
 
Join Date: Dec 2008
Posts: 4,894
Default

Quote:
Originally Posted by dkstott View Post
The solution to the problem should lie within Centrale....after all, isn't that why Creative provides it??
Using Centrale:

Highlight the song (by clicking once on it).
click on edit. (top menu)
Wait a few second for a properties window to pop up.
Edit any entry you see, or simply add info to the tags shown. Click + to add art.
When you have everything as you like it, click on OK.
Reply With Quote

  #10  
Old 01-10-2010, 02:28 PM
monoke monoke is offline
Junior Member
 
Join Date: Jan 2010
Posts: 6
Default

Quote:
Originally Posted by Olley View Post
Using Centrale:

Highlight the song (by clicking once on it).
click on edit. (top menu)
Wait a few second for a properties window to pop up.
Edit any entry you see, or simply add info to the tags shown. Click + to add art.
When you have everything as you like it, click on OK.
I went back and tried Centrale again, checked that all the tag were correctly in place, sent it to the player and their still all mixed up.

This is a piece of crap!
Reply With Quote

  #11  
Old 01-11-2010, 07:12 AM
BigSigh BigSigh is offline
Junior Member
 
Join Date: Sep 2008
Location: England
Posts: 89
Default

You have to delete the content from the player, fix the tabs then sync it back to the player
Reply With Quote

  #12  
Old 01-12-2010, 12:57 AM
ZenChick's Avatar
ZenChick ZenChick is offline
Ultra Senior Member
 
Join Date: Jul 2006
Location: Right... Behind... You...
Posts: 7,427
Default

To be perfectly frank: If you're using Windows Vista or Windows 7, I wouldn't even mess with Centrale. There's no need to, and it's just extra software cluttering your hard drive and creating the potential for software conflicts. Use Windows Media Player instead, or any other MTP-aware sync manager. You will find the experience so much less stressful. WMP, for example, can sync tag changes without requiring deleting the file off the player first. In short: If the supplied software frustrates you, then just don't use it.
__________________
ZenChick - The one them iPod-owners warned you about!
Creative Zen Vision:M 30GB * Creative MuVo N200 1GB * Philips GoGear Vibe 4GB
Resident Linux Geekette ** Got IRC? Look me up on irc.freenode.net #AnythingButiPod
Reply With Quote

  #13  
Old 01-12-2010, 05:01 PM
dkstott dkstott is offline
Junior Member
 
Join Date: Jan 2010
Posts: 36
Default

Zenchick

All of my problems with album art & the X-fi2 have been with WMP.... I gave up using Centrale

the X-fi2 will not recognize the method of tagging that WMP uses.


Dave
Reply With Quote

  #14  
Old 01-12-2010, 05:09 PM
dkstott dkstott is offline
Junior Member
 
Join Date: Jan 2010
Posts: 36
Default

does anyone know if Media Monkey will allow me to fix the album art on my X-fi2 without deleting the files ??

Dave
Reply With Quote

  #15  
Old 01-12-2010, 09:07 PM
LordXenos's Avatar
LordXenos LordXenos is offline
Junior Member
 
Join Date: Dec 2009
Location: Louisville, KY, USA
Posts: 94
Default

I have been using MP3Tag to attach album art and make sure everything is updated. It is a hasle ( I have over 8000 MP3s ) but from my experience, it is the best tagging tool. If I get some time (maybe later tonight) I will post a tagging tutorial complete with pictures (maybe even a video if I feel fancy).

Music data tags are always a huge problem with portable media players. That is why it's nice to have your entire library properly tagged before trying to move it to the PMP.

Anyway, hopefully I'll be able to post something that helps later tonight.
__________________
If you have a question, please ask. I am more than happy to help.

Cheers,
Your friendly neighborhood
Dark Lord
Reply With Quote

  #16  
Old 01-13-2010, 06:56 AM
BigSigh BigSigh is offline
Junior Member
 
Join Date: Sep 2008
Location: England
Posts: 89
Default

The way Zens deal with Album Art Deleting and re syncing are the only way. Sort out all your tagging Album Art issue on the PC then re sync it to the Player.
Reply With Quote

  #17  
Old 01-13-2010, 09:24 AM
LordXenos's Avatar
LordXenos LordXenos is offline
Junior Member
 
Join Date: Dec 2009
Location: Louisville, KY, USA
Posts: 94
Default

I've made up a quick video tutorial to show you how I tag my MP3s... after I do, my ZEN finds everything fine; even album art.
__________________
If you have a question, please ask. I am more than happy to help.

Cheers,
Your friendly neighborhood
Dark Lord
Reply With Quote

  #18  
Old 01-13-2010, 03:43 PM
badazzmofo badazzmofo is offline
Junior Member
 
Join Date: Dec 2009
Posts: 75
Default

has anyone solved the problem of the artist name in FLAC file comeing out as

TIST=artistname

or

RTIST=artistname

?

ive tried removing, retagging, and reinserting to no avail.
Reply With Quote

  #19  
Old 01-13-2010, 07:54 PM
ZenChick's Avatar
ZenChick ZenChick is offline
Ultra Senior Member
 
Join Date: Jul 2006
Location: Right... Behind... You...
Posts: 7,427
Default

Quote:
Originally Posted by dkstott View Post
Zenchick

All of my problems with album art & the X-fi2 have been with WMP.... I gave up using Centrale

the X-fi2 will not recognize the method of tagging that WMP uses.


Dave
I'm going to fall back on my experience with the Vision:M here...

I have noticed that, whenever I had synced music to my ZVM with anything other than WMP, and then later went in and synced more music with WMP, the player refused to display album art for all the songs synced with WMP. This also worked this way in reverse: Using WMP to sync and then using any other method to add tracks resulted in no album art for the newly-added tracks. This problem, however, magically went away when I completely reformatted my player and synced everything back completely with WMP, or completely with another method.

I use Linux now, and my ZVM has no issues with mixing sync managers here, having synced with Rhythmbox, Banshee, and Qlix. If the track contained an image in its ID3 tag, it displayed on the ZVM.

This leads me to believe that the problem is with WMP doing things in somewhat non-standard ways, which forces the player to do things the WMP way, and therefore it doesn't work right for any other sync manager. So, going back on my ZVM wisdom, my advice is to blank the player and re-sync it - and be prepared to do that each time you want to change out sync managers within Windows (Note: WMP12 may have fixed this issue, but I haven't tested this out).
__________________
ZenChick - The one them iPod-owners warned you about!
Creative Zen Vision:M 30GB * Creative MuVo N200 1GB * Philips GoGear Vibe 4GB
Resident Linux Geekette ** Got IRC? Look me up on irc.freenode.net #AnythingButiPod
Reply With Quote

  #20  
Old 01-13-2010, 09:15 PM
LordXenos's Avatar
LordXenos LordXenos is offline
Junior Member
 
Join Date: Dec 2009
Location: Louisville, KY, USA
Posts: 94
Default

Quote:
This leads me to believe that the problem is with WMP doing things in somewhat non-standard ways
WMP does tag several items in a non-standard way (depending on what you consider non-standard) I had to re-tag my entire library because WMP kinda screwed up part of it.
__________________
If you have a question, please ask. I am more than happy to help.

Cheers,
Your friendly neighborhood
Dark Lord
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 03:52 AM.