Prev Previous Post   Next Post Next
Old 03-11-2010, 02:50 PM
jblayze jblayze is offline
Junior Member
Join Date: Mar 2010
Posts: 3
Default firmware problem - windows 7

I hope someone can assist me with this problem and get my Zen back in working order!

Several months ago, the hard drive on my 30 GB crashed. As a result, every time I turned it on, it would "rebuild" the library for a couple of minutes but after that I could listen to music. However, I lost all videos and pictures and some songs were gone. I could not add any new content but I wasn't willing to format it and lose what I had and start from scratch. This past week though I had enough and decided to try and restore it. I went into the Startup screen and formatted the system but I also foolishly deleted the Firmware, so now I have the "Firmware Problem". I loaded the Creative software as I thought that might help but it didn't.

It was at this point I tried to Google a solution, which pointed me to this site as well as others. I have read through numerous posts on this issue and I found that most recommended to use a PC with Windows XP and WMP 10. I did try on another PC with Win XP and Media Player 9, but when I connected the Zen to that computer, it was not recognized. Same issue with my current Windows 7 system.

I am currenlty running on Windows 7 with WMP 12. I have downloaded the current firmware update file from the Creative website. I cannot get the "Upgrade" button to be active when the player is connected. When I connect the player to my computer, the player says "Docked". When I go to the Firmware Update screen and then connect it, I don't get the docked message and hence I cannot update the firmware.

Please note that I have removed the Creative software as I read after the fact on this forum that I shouldn't have installed it in the first place! However, I really don't know what to do now and could use some help! Please advise!
Reply With Quote

Advertisement [Remove Advertisement]


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 03:09 AM.