android
  #1041  
Old 10-30-2010, 06:50 PM
Idroy's Avatar
Idroy Idroy is offline
Junior Member
 
Join Date: Feb 2010
Location: The Netherlands
Posts: 71
Default

It's getting late here, I'll try it tomorrow
Reply With Quote

Advertisement [Remove Advertisement]

  #1042  
Old 10-31-2010, 04:16 AM
Timar Timar is offline
Member
 
Join Date: Apr 2010
Posts: 107
Default

Quote:
Originally Posted by saratoga View Post
Well it doesn't crash when I use it, but thats no promise it'll work for everyone, for clip/fuze/clip+ or for everything in rockbox
I have used it for quite a while now, and haven't experienced a single crash. It's rock(box) solid

Btw. I wonder why only FCLK is boosted to 240 MHz and PCLK stays fixed at 40 MHz with HAVE_ADJUSTABLE_CPU_FREQ? I thought the latter was unused? I haven't done a battery bench so far, but I immediately noticed another improvement: the SD acces noise on my device is significantly reduced (maybe because PCLK==DRAM!?)

Last edited by Timar; 10-31-2010 at 04:58 AM.
Reply With Quote

  #1043  
Old 10-31-2010, 07:26 AM
nycbone nycbone is offline
Junior Member
 
Join Date: Jul 2010
Location: NYC
Posts: 16
Default

I had trouble installing RB on my Clip+ due to my apparent inability to read and interpret simple directions (confused about which Sansa updater file was needed).

Now that I have it working...

Wow! The custom EQ is amazing as are the other sound settings.

Consider me converted.
__________________
Clip+ (Rockbox) --> RE0 | KSC75
Reply With Quote

  #1044  
Old 10-31-2010, 07:28 AM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

Rockbox 3.7 is out, and the Clip+ has been promoted to stable: http://www.rockbox.org/wiki/ReleaseNotes37
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #1045  
Old 10-31-2010, 07:39 AM
WalkGood's Avatar
WalkGood WalkGood is offline
Moderator
 
Join Date: Aug 2006
Location: FL
Posts: 12,579
Default

Quote:
Originally Posted by dfkt View Post
Rockbox 3.7 is out, and the Clip+ has been promoted to stable: http://www.rockbox.org/wiki/ReleaseNotes37
I see your name in the credits, congrats again
__________________
WalkGood,
Ramón

abi >> | Forum Rules | Glossary | Why Rockbox | FLAC or MP3? | irc
Reply With Quote

  #1046  
Old 10-31-2010, 08:04 AM
nycbone nycbone is offline
Junior Member
 
Join Date: Jul 2010
Location: NYC
Posts: 16
Default

Yes, congrats and thank you. Job well done!
__________________
Clip+ (Rockbox) --> RE0 | KSC75
Reply With Quote

  #1047  
Old 10-31-2010, 08:38 AM
Idroy's Avatar
Idroy Idroy is offline
Junior Member
 
Join Date: Feb 2010
Location: The Netherlands
Posts: 71
Default

Here is my build (v3.7, usb support, context sensitive backlight, higher quality audio hw settings, Meier crossfeed and the cpu frequency scaling) http://www.mediafire.com/?t1xcucy0kd5qp8n
Reply With Quote

  #1048  
Old 10-31-2010, 09:26 AM
henriquemaia's Avatar
henriquemaia henriquemaia is offline
Junior Member
 
Join Date: Apr 2010
Posts: 47
Default

Quote:
Originally Posted by Idroy View Post
Here is my build (v3.7, usb support, context sensitive backlight, higher quality audio hw settings, Meier crossfeed and the cpu frequency scaling) http://www.mediafire.com/?t1xcucy0kd5qp8n
Thanks! Another very awaited "release" from ldroy
Reply With Quote

  #1049  
Old 10-31-2010, 01:49 PM
Pennhaven Pennhaven is offline
Member
 
Join Date: Dec 2006
Location: Michigan
Posts: 206
Default

Quote:
Originally Posted by Idroy View Post
Here is my build (v3.7, usb support, context sensitive backlight, higher quality audio hw settings, Meier crossfeed and the cpu frequency scaling) http://www.mediafire.com/?t1xcucy0kd5qp8n
Anyone else have trouble with Idroy's latest 3.7 freq scaling build?

I loaded it and started playing music. In the middle of the third or so song the Clip+ shut down and would not restart with the power button. I had to use the hold power button for 15+ seconds, release, and press again maneuver to get it to boot up on again.

I've only had my Clip+ for a few days so I guess there could be some other problem with it, but it had been working flawlessly with Idroy's original build.

I definitely appreciate your sharing your effort, Idroy, even if there may be a possible problem. Thanks.

Last edited by Pennhaven; 11-01-2010 at 10:22 AM.
Reply With Quote

  #1050  
Old 10-31-2010, 01:54 PM
ted209 ted209 is offline
Junior Member
 
Join Date: Dec 2008
Posts: 39
Default

Quote:
Originally Posted by Idroy View Post
Here is my build (v3.7, usb support, context sensitive backlight, higher quality audio hw settings, Meier crossfeed and the cpu frequency scaling) http://www.mediafire.com/?t1xcucy0kd5qp8n
Thanks very much - I'd like to try this out. Do I just copy over the folder? Do I need to update my bootloader or anything?
Reply With Quote

  #1051  
Old 10-31-2010, 01:59 PM
glove4 glove4 is offline
Member
 
Join Date: Jan 2010
Location: North Carolina
Posts: 385
Default

Last I put RB on my Clip+, there was a noticeable issue with pitch, where songs I frequently listen to sounded noticeably slower (I often listen to fast to blazing fast metal, so it is obvious when there is a pitch issue). This seems to have improved according to release notes. Any confirmation of it from someone who noticed it before?
Reply With Quote

  #1052  
Old 10-31-2010, 02:12 PM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Quote:
Originally Posted by glove4 View Post
Last I put RB on my Clip+, there was a noticeable issue with pitch, where songs I frequently listen to sounded noticeably slower (I often listen to fast to blazing fast metal, so it is obvious when there is a pitch issue). This seems to have improved according to release notes. Any confirmation of it from someone who noticed it before?
That was fixed a little while ago.
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #1053  
Old 10-31-2010, 02:46 PM
Idroy's Avatar
Idroy Idroy is offline
Junior Member
 
Join Date: Feb 2010
Location: The Netherlands
Posts: 71
Default

Quote:
Originally Posted by ted209 View Post
Thanks very much - I'd like to try this out. Do I just copy over the folder? Do I need to update my bootloader or anything?
You need to extract it in the root folder of your player (if it asks to overwrite files choose yes), and you don't need to update the bootloader.
Reply With Quote

  #1054  
Old 10-31-2010, 03:58 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,617
Default

Quote:
Originally Posted by Timar View Post
Btw. I wonder why only FCLK is boosted to 240 MHz and PCLK stays fixed at 40 MHz with HAVE_ADJUSTABLE_CPU_FREQ?
I asked funman about that a while ago. Apparently changing PCLK is harder then just boosting FCLK. IIRC when you boost fclk you can just switch which source is used for it, but changing PCLK requires actually relocking a PLL. But yes, maxing PCLK at 65MHz when boosting would be nice, since everything is faster with increased PCLK.

Quote:
Originally Posted by Timar View Post
I thought the latter was unused?
No PCLK is basically everything thats not the CPU, so things like RAM, IRAM, display controller, etc. I did some tests a while ago with different PCLKs and increasing it greatly increases most codecs's decode rate.

Quote:
Originally Posted by Timar View Post
I haven't done a battery bench so far, but I immediately noticed another improvement: the SD acces noise on my device is significantly reduced (maybe because PCLK==DRAM!?)
I tested MP3 and saw a smallish improvement (less then 1 hour on the clip+). What noise do you get normally? I usually don't hear anything.
Reply With Quote

  #1055  
Old 10-31-2010, 04:13 PM
Idroy's Avatar
Idroy Idroy is offline
Junior Member
 
Join Date: Feb 2010
Location: The Netherlands
Posts: 71
Default

Hmmm, I got a weird problem now, when I open database on the main menu, it says that it is not ready, so I let it Initialize. Then it just freezes at: "building database... 1514 found (off to return)". I waited for an hour or so, and it still hangs there.

I already pressed Update Now and Initialize Now in the database settings menu, after that I opened database and it says the same thing. I also tried to format the player in the OF, and you quessed it: it didn't work aswell. It isn't build related though, I put my old build on it and that didn't help.

Do I need to format the whole player (plus microsd card) or is there any quick solution for it?

*edit* When I remove the micro sd card, it freezes at 798 (It's lower because there are less tracks on the player). To me it looks like it doesn't complete the 'building the database' process.

Last edited by Idroy; 10-31-2010 at 04:20 PM.
Reply With Quote

  #1056  
Old 10-31-2010, 05:04 PM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

New build, same patches as before: r28426M-101031-sansaclipplus (FS#9305, FS#11304, FS#11577-Meier) - dfkt.zip

Rockbox is 'stable', and it's Halloween - that must be the best build ever.
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #1057  
Old 10-31-2010, 07:03 PM
Adub's Avatar
Adub Adub is offline
Moderator
 
Join Date: Jan 2010
Location: T DOT
Posts: 1,604
Default

That's what i was waiting for ;D. Thanks as always.
__________________
last.fm#abi ircrockboxnoobglossaryhiphopthreadhorrormoviethread
XBLive Tag: wuaffiliate
Battle.net Tag: wuaffiliate#1677

Last edited by Adub; 10-31-2010 at 09:38 PM.
Reply With Quote

  #1058  
Old 10-31-2010, 08:04 PM
Pennhaven Pennhaven is offline
Member
 
Join Date: Dec 2006
Location: Michigan
Posts: 206
Default

Quote:
Originally Posted by Pennhaven View Post
Anyone else have trouble with Idroy's latest 3.7 freq scaling build?

I loaded it and started playing music. In the middle of the third or so song the Clip+ shut down and would not restart with the power button. I had to use the hold power button for 120 seconds, release, and press again maneuver to get it to boot up on again.
Well I've had a total of 5 crashes now in 4 1/2 hours of playing time. All with high VBR (>250) .mp3s. Never a crash with the earlier build.

Tomorrow I'll change to dfkt's new 3.7 build and see if that one is more stable for me.

Last edited by Pennhaven; 10-31-2010 at 08:58 PM.
Reply With Quote

  #1059  
Old 10-31-2010, 09:17 PM
yatsunil yatsunil is offline
Junior Member
 
Join Date: Oct 2010
Location: Singapore
Posts: 8
Default

Quote:
Originally Posted by dfkt View Post
New build, same patches as before: r28426M-101031-sansaclipplus (FS#9305, FS#11304, FS#11577-Meier) - dfkt.zip

Rockbox is 'stable', and it's Halloween - that must be the best build ever.
Grabbed it. Running it now and loving it! Thanks a bundle mate!!!

Cheers!
Reply With Quote

  #1060  
Old 10-31-2010, 11:16 PM
henriquemaia's Avatar
henriquemaia henriquemaia is offline
Junior Member
 
Join Date: Apr 2010
Posts: 47
Default

Quote:
Originally Posted by Pennhaven View Post
Well I've had a total of 5 crashes now in 4 1/2 hours of playing time. All with high VBR (>250) .mp3s. Never a crash with the earlier build.

Tomorrow I'll change to dfkt's new 3.7 build and see if that one is more stable for me.
I have a lot of weird problems with the latest ldroy's build (maybe the frequency scaler thing?). I press the pause button and the player starts to pause very slo o o o o o o o o owly, and everything else done during playback is done with terrible amount of lag, but I didn't have a single crash with it.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 12:26 PM.