android
  #1401  
Old 12-13-2011, 01:30 AM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,602
Default

The current SVN build has some USB fixes. Testing on my system it seems to work fairly well, but only if I have a microsd card inserted

YMMV.
__________________
Interested in Google's Summer of Code ? PM me.
Reply With Quote

Advertisement [Remove Advertisement]

  #1402  
Old 12-13-2011, 02:10 AM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Quote:
Originally Posted by saratoga View Post
The current SVN build has some USB fixes. Testing on my system it seems to work fairly well, but only if I have a microsd card inserted

YMMV.
Well, I'm not having any luck with the card out of the player(Zip, not Clip+), so I guess I'll load the card and see what happens.
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #1403  
Old 12-13-2011, 01:08 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,602
Default

Its very random if it will actually mount the disk for me. Probably 2/3s of the time it doesn't. But if it does mount, it seems to work quite well (copied 10GB without an error). Perhaps I'm just lucky though.
__________________
Interested in Google's Summer of Code ? PM me.
Reply With Quote

  #1404  
Old 12-13-2011, 02:09 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,602
Default

More fixes went in and it seems to be working a lot better.
__________________
Interested in Google's Summer of Code ? PM me.
Reply With Quote

  #1405  
Old 12-13-2011, 02:29 PM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Quote:
Originally Posted by saratoga View Post
More fixes went in and it seems to be working a lot better.
I'll try it out tonight after work.
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #1406  
Old 12-13-2011, 03:22 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,602
Default

Tried copying 15 GB back and forth on a couple machines and haven't had any disconnects or errors. At least for my specific player and few PCs it seems quite good.
__________________
Interested in Google's Summer of Code ? PM me.
Reply With Quote

  #1407  
Old 12-13-2011, 07:06 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,197
Default

So far so good here using r31232 on the Clip Zip, Clip+ and V2 Clip. Can't locate my V2 Fuze to try it on there right now. That's on Ubuntu Linux, Vista and Win7.

The connection is quick and has been solid. None of the transfers I've tried have dropped or had any errors. The speed is the same as with the OF.

I had problems in the past with file corruption so I've checked for that several times. No sign of problems yet.
Reply With Quote

  #1408  
Old 12-13-2011, 10:45 PM
Erik Olson Erik Olson is offline
Junior Member
 
Join Date: Oct 2010
Posts: 5
Default

Working for me too -- first time I've been able to transfer files in Rockbox on the clip+. Good Bye 10-minute refresh waits!
Reply With Quote

  #1409  
Old 12-14-2011, 01:10 AM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Just installed r31241 on both of my Zips, and now everything is fine!
First attempt with first player was unsuccessful, perhaps because I plugged it in while powered down.....tried it again while powered up and everything is great. Transferred about 700MB onto the one player, and it seemed to be moving almost 1MB/second faster than with the OF....hovering around 4.9MB/second.

This was after I deleted all the OF folders, etc...now there are only 2 folders there, "rockbox" and "MUSIC", just like I remember seeing in the V1 Fuze I had a while back.

Further evidence of success, I believe......


Edit: updated to the current, which is r31244 , and everything still seems cool. Sometime over the next day or so I'll have to try a bigger transfer, but for the most part my files are set in place. My grey Zip has some free space though, so that will be where I tinker.
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520

Last edited by Marvin the Martian; 12-14-2011 at 03:24 AM.
Reply With Quote

  #1410  
Old 12-14-2011, 02:19 PM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

New patched build: r31254M-111214-sansaclipplus (FS#9305, FS#11304, FS#11767, FS#12075, FS#12338, channel swap) - dfkt
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #1411  
Old 12-16-2011, 10:20 AM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

New patched build. This one includes FS#12454 - Faster line scroll speed, my first patch submitted to the tracker.

r31323M-111216-sansaclipplus (FS#9305, FS#11304, FS#11767, FS#12075, FS#12338, FS#12454, channel swap) - dfkt
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #1412  
Old 12-16-2011, 12:13 PM
oldschool's Avatar
oldschool oldschool is offline
Junior Member
 
Join Date: Jun 2010
Location: Ann Arbor
Posts: 7
Default

How is USB supposed to work? Should I switch to Auto from within the original firmware?
Reply With Quote

  #1413  
Old 12-16-2011, 12:51 PM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,197
Default

You shouldn't have to do anything in the OF. You have to be using a current build with Rockbox up and running, connect the cable and it should connect if it's working for you.
Reply With Quote

  #1414  
Old 12-16-2011, 02:08 PM
johnbthetenth johnbthetenth is offline
Junior Member
 
Join Date: Sep 2010
Location: Southern Germany
Posts: 35
Default

@dfkt: Does USB in RB work for you with this build?
For me it doesn't and I am a little puzzled by the version string that is displayed in RB:
r31040:31323M

The USB fixes had just recently been added: 31040 wouldn't have it, but 31323 should.

Who can shed a little light on that?

Thanks
johnb
P.S.: Mine is an AMSv2 variant 0
----------------------

Update:
After the tenth trial and having it sit connected for several minutes, right now it mounted correctly :-)
That is on Win XP SP3

Last edited by johnbthetenth; 12-17-2011 at 03:08 AM. Reason: added OS used
Reply With Quote

  #1415  
Old 12-16-2011, 02:55 PM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

USB doesn't work well for me with any current build - neither the official ones nor mine, no difference. Same goes for my Clip Zip as well.

The weird revision number is because I didn't resolve a conflict in a lowly language file, which has no impact on performance at all. It would take quite some effort to fix that with the patches I'm using - so I chose the lazy option for now, postponing the conflict.
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #1416  
Old 12-16-2011, 03:06 PM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

The last time I hooked my Zips up, the one wasn't recognized on the first two attempts.....on the third try, it was, and after that, the second Zip was too. I updated builds then, so it remains to be seen how they'll connect the next time I need to.
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #1417  
Old 12-16-2011, 03:09 PM
dfkt's Avatar
dfkt dfkt is offline
Moderator
 
Join Date: May 2006
Location: Vienna, Austria
Posts: 15,330
Default

It's totally hit or miss for me with the Clip+ and Zip - maybe one in five attempts USB is working, otherwise it locks the player up, needing a reset. Win7 Ultimate SP1 32bit, powered Belkin USB hub.
__________________
Please don't PM me with questions that can be answered in a forum thread. Don't be an idiot.
My Gear and Reviews | My RMAA Tests | IRC: #anythingbutipod on Freenode | Last.fm | Album Art Exchange | Rockbox | Replaygain
Reply With Quote

  #1418  
Old 12-16-2011, 03:22 PM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Yes, the first two attempts, I have to reset the player as well. Win 7 Ultimate SP1 64 bit here. Once again, when I just tried, the third attempt, everything came right up fine.
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #1419  
Old 12-16-2011, 04:44 PM
WalkGood's Avatar
WalkGood WalkGood is offline
Moderator
 
Join Date: Aug 2006
Location: FL
Posts: 12,579
Default

hit or miss here too but I can wait, so much stuff on there I'm not sure how soon I'll get to it all
__________________
WalkGood,
Ramón

abi >> | Forum Rules | Glossary | Why Rockbox | FLAC or MP3? | irc
Reply With Quote

  #1420  
Old 12-16-2011, 06:44 PM
marc2003's Avatar
marc2003 marc2003 is offline
Member
 
Join Date: Jul 2008
Location: England
Posts: 297
Default

i've tried loads times with and without my microSDHC card and i can't get USB working at all. the device is not recognised and the player freezes with the USB logo. the old patch on the tracker worked very well but the recent changes have been so huge i can't re-sync it.

ams variant 1 according to the debug menu.
__________________
Sansa Clip+ 8GB :: Sandisk 16GB Micro SDHC :: Rockbox :: FiiO E6 :: Sennheiser PX100 II
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 11:23 AM.