android
  #1  
Old 07-15-2010, 09:13 AM
copterz copterz is offline
Junior Member
 
Join Date: Jul 2010
Posts: 8
Default cannot install rockbox on my fuze v2 :(

hey guys...first post here

ok well i'm trying to install rockbox on my fuze v2 running firmware V02 03 33A.
first i downloaded the rockbox utility, ran it, downloaded the bootloader and everything and it reported no errors, so i assumed it worked. when i unplugged my fuze it just did the refreshing database thing, and then went back to the home screen. i turned it off and on, and again it went to the same home screen.

next i tried the manual installation. i followed the instructions here: http://www.rockbox.org/wiki/SansaAMS for the fuze v2 and downloaded everything. i put the rockbox folder into the root folder of my fuze, then i ran the command prompt and it reported success so i put that firmware file into the root of my fuze and deleted the original one. when i unplugged it it did the refreshing media thing and thats it.

am i doing something wrong?? because i'd really like to try out rockbox
help is appreciated
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 07-15-2010, 09:57 AM
SheepCake SheepCake is offline
Banned
 
Join Date: Jun 2010
Posts: 116
Default

how new is your fuze?

some of the newer ones appear to be designed to block rockboxing, somebody on the sansa forums called sandisk about it and had a rep confirm that they are trying to prevent 3rd party firmware's from being used on newer revisions of the fuze apparently(cant find the link, thought i had saved it)

there may be a fix from the rockbox team at some later date, Not sure if there will be a workaround for this issue or not, both of my fuzes rockboxed fine but they are older v2 and v1 units not units made in the last few months.

from the page you linked

Quote:
Fuzev2: some models can only be upgraded to 2.3.31 or 2.3.31 unmodified OF version : can't downgrade to earlier unmodified OF versions or upgrade to any rockbox patched OF version. There is probably some additional upgrade file check we have not discovered. See FS#11406
Reply With Quote

  #3  
Old 07-15-2010, 10:59 AM
copterz copterz is offline
Junior Member
 
Join Date: Jul 2010
Posts: 8
Default

ok well that may be it...i bought my fuze at futureshop like 10 days ago :P
Reply With Quote

  #4  
Old 07-15-2010, 11:39 AM
SheepCake SheepCake is offline
Banned
 
Join Date: Jun 2010
Posts: 116
Default

yeah,that sucks, but TBH unless you really need gapless and the better EQ the OF is fine, they may find a workaround when/if funman or another dev can get ahold of one of these modified fuze's to give a good hard look at whats been changed.
Reply With Quote

  #5  
Old 07-15-2010, 11:43 AM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,154
Default

I wouldn't feel to badly. The Fuze is an excellent player even without Rockbox. If it's in Flyspray someone may be working on a fix. I wouldn't give up hope.

saratoga is both the Sansa forum moderator here and a Rockbox developer. funman is another developer that seems to stop by whenever he can lend a hand. They may spot something in your procedures that will help. I'd check in regularly to see if they might have some information on your situation.

Nothing is guaranteed with Rockbox but someone may find a solution. Until then I believe all you can do is wait and enjoy your player as is.

BTW, Welcome to ABi, I just wish it were under happier circumstances.
Reply With Quote

  #6  
Old 07-15-2010, 01:10 PM
lestatar's Avatar
lestatar lestatar is offline
Ultra Senior Member
 
Join Date: Dec 2009
Location: Hong Kong now, but NYC always
Posts: 4,657
Default

copterz: welcome to abi and yeah, bummer you are having issues.

Stupid question though: I am new to RB myself, but I had zero issues installing it on my V2 Fuze. Mine was purchased in May and came with, I believe v2.02.26 FW, which I upgraded to v2.02.33 immediately.

However, as part of my own [manual] RB install on the Fuze, I first DOWNGRADED my OF back to v2.02.26. I believe I saw a mention that this is best at the time I was doing due diligence research on RB installs.

I have been informed that RB should be OF version independent in some ways - of course, it is possible as theorized that current/new Fuze devices have some sort of protective scheme to prevent any modifications. If so, this SUCKS.

But perhaps try downgrading the FW to v2.02.26 and give RB another shot? What have you got to lose?

And yes, the default GUI/FW on the Fuze is nothing special, but it does work.

good luck!
-lestatar
__________________
DAPs:2xRBFuze8+16GB|SonyE345|ZenV+,Micro,Xtra40GBx2|RBG igabeatFX|RCAOpal
IEMs:PanaHJE900|Nuforce 700x|HippoVB|iMetal590,i490|SM PL-21|CX300|EP630,Aurvana
Guitars:IbanezS540,JS1200|Ovation
PoolCues: a bunch
A Glossary for Newbies
Reply With Quote

  #7  
Old 07-15-2010, 01:36 PM
copterz copterz is offline
Junior Member
 
Join Date: Jul 2010
Posts: 8
Default

alright thanks everyone ill visit the rockbox site occasionally to see if theres any updates
Reply With Quote

  #8  
Old 07-15-2010, 02:01 PM
SheepCake SheepCake is offline
Banned
 
Join Date: Jun 2010
Posts: 116
Default

Quote:
Originally Posted by lestatar View Post
copterz: welcome to abi and yeah, bummer you are having issues.

Stupid question though: I am new to RB myself, but I had zero issues installing it on my V2 Fuze. Mine was purchased in May and came with, I believe v2.02.26 FW, which I upgraded to v2.02.33 immediately.

However, as part of my own [manual] RB install on the Fuze, I first DOWNGRADED my OF back to v2.02.26. I believe I saw a mention that this is best at the time I was doing due diligence research on RB installs.

I have been informed that RB should be OF version independent in some ways - of course, it is possible as theorized that current/new Fuze devices have some sort of protective scheme to prevent any modifications. If so, this SUCKS.

But perhaps try downgrading the FW to v2.02.26 and give RB another shot? What have you got to lose?

And yes, the default GUI/FW on the Fuze is nothing special, but it does work.

good luck!
-lestatar
v2.02.33 works fine, the wiki page just listed what was out at the time that part of the wiki was written, I grabbed the newer mkboot(or whatever its called) and updated the v2.02.33 to rockbox, it worked perfectly.

IF he could downgrade that would tell us if his unit is a locked one tho.

copterz could you please try downgrading your firmware to the older build(2.02.26).

also if you could give us the number off the back of your fuze that could help as well(so the RB guys could list your number in the known batch of not working units if you cant downgrade your firmware)

all the help you can give them will help them help you
also would be nice if
Reply With Quote

  #9  
Old 07-15-2010, 02:10 PM
copterz copterz is offline
Junior Member
 
Join Date: Jul 2010
Posts: 8
Default

sure i'll downgrade... im guessing to do that i download an older firmware and place it in the root of my device?

EDIT: ok guess not because i did that and it still says im on 2.03.33A

EDIT2: alright i went to http://www.rockbox.org/tracker/task/11406 and sure enough mine has the serial number of the models affected oh well at least i know why i cant install it now

Last edited by copterz; 07-15-2010 at 02:22 PM.
Reply With Quote

  #10  
Old 07-15-2010, 02:29 PM
lestatar's Avatar
lestatar lestatar is offline
Ultra Senior Member
 
Join Date: Dec 2009
Location: Hong Kong now, but NYC always
Posts: 4,657
Default

Ah man, that really really sucks... :-(
__________________
DAPs:2xRBFuze8+16GB|SonyE345|ZenV+,Micro,Xtra40GBx2|RBG igabeatFX|RCAOpal
IEMs:PanaHJE900|Nuforce 700x|HippoVB|iMetal590,i490|SM PL-21|CX300|EP630,Aurvana
Guitars:IbanezS540,JS1200|Ovation
PoolCues: a bunch
A Glossary for Newbies
Reply With Quote

  #11  
Old 07-15-2010, 05:08 PM
jimnms's Avatar
jimnms jimnms is offline
Junior Member
 
Join Date: Apr 2009
Posts: 19
Default

Quote:
Originally Posted by SheepCake View Post
how new is your fuze?

some of the newer ones appear to be designed to block rockboxing, somebody on the sansa forums called sandisk about it and had a rep confirm that they are trying to prevent 3rd party firmware's from being used on newer revisions of the fuze apparently(cant find the link, thought i had saved it)
I hope that isn't true. Sandisk would be hurting themselves if they did that. Some people buy specific products because they do support 3rd party firmware. I don't use it on my Fuze or Clip+, but I did buy a wireless router specifically because of it's support for 3rd party firmware such as Tomato and DD-WRT. The company (Buffalo) even advertises that as a selling point and you can now buy new routers with DD-WRT pre-installed.
__________________
Sandisk Clip+ 8GB
Sandisk Sansa Fuze 8GB Black
Reply With Quote

  #12  
Old 07-15-2010, 06:04 PM
SheepCake SheepCake is offline
Banned
 
Join Date: Jun 2010
Posts: 116
Default

i can see them doing it because they have idiots working for them who think that return rates will skyrocket due to people who rockbox and have problems or brick their players trying to rockbox.

dosnt suprise me at all, its a stupid move, they should just make their own build of rockbox that supports DRM(audible type drm) and such and has a custom skin(like the OF skin) would make things nicer for geeks if in the system menu we had rockbox type options but didnt have to rockbox the player.
Reply With Quote

  #13  
Old 07-15-2010, 07:02 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,587
Default

Quote:
Originally Posted by SheepCake View Post
dosnt suprise me at all, its a stupid move, they should just make their own build of rockbox that supports DRM(audible type drm)
You couldn't do this because of how the licensing works. You could package rockbox on a hardware device and sell it, but you'd have to open source everything, and obviously you can't open source audible's software since they don't give out the source.
Reply With Quote

  #14  
Old 07-15-2010, 10:06 PM
funman funman is offline
Rockbox Developer
 
Join Date: Jul 2008
Posts: 161
Default

Sandisk prevents some Fuze from being downgraded < 2.3.31 because of a hardware change, not for blocking rockbox (not sure what exactly that Sandisk person meant).

Someone from Finland sent me such a Fuzev2 and now we can patch firmware correctly, but before those Fuzev2 can be rockboxed we need to handle this hardware change.

Check SansaAMS page on rockbox wiki, we try to keep the specific problems updated whenever there is progress.
Reply With Quote

  #15  
Old 07-16-2010, 12:51 PM
Illbashu Illbashu is offline
Junior Member
 
Join Date: Feb 2009
Posts: 68
Default

So is this going to be fixed? I just bought a cancelled my ordered of my a 16GB view and bought a 8GB Fuze from dell because I wanted Rockbox and then I found this thread. Hopefully mine wont have the same prob.
Reply With Quote

  #16  
Old 07-16-2010, 12:59 PM
saratoga saratoga is offline
Rockbox Developer / Moderator
 
Join Date: Apr 2007
Posts: 3,587
Default

Quote:
Originally Posted by Illbashu View Post
So is this going to be fixed?
Read the post above yours. It has everything thats known about the issue.
Reply With Quote

  #17  
Old 09-13-2010, 01:21 AM
IWannaRock IWannaRock is offline
Junior Member
 
Join Date: Sep 2010
Posts: 9
Default same problem as copterz above

Wished I found this thread before.

Sansa Fuze v2 purchased from FutureShop 09/03/10. Serial #B/1008CBNK-8GB, firmware 33A. Can't downgrade firmware, can't rockbox.

I thought I'd buy one of these while I could since I saw there is a new Fuze+ on the way and didn't want to wait for a rockbox version for it (or risk rockbox never working on the + at all...damn irony!).

With the new Fuze+ on the way I'm not optimistic this seemingly difficult problem will be solved for such relativity few units, but I'll check here every once and a while just in case.

I guess I could return the Fuze, but I think I'll keep it anyway since it plays flac and has more storage than my other DAP...still I really wanted to rock.

Regardless, Sandisk has lost me as a customer and I wouldn't recommend anyone purchase any Fuze v2 or Fuze+.
Reply With Quote

  #18  
Old 09-13-2010, 01:26 AM
Marvin the Martian's Avatar
Marvin the Martian Marvin the Martian is offline
Ultra Senior Member
 
Join Date: Oct 2008
Location: east central NY state
Posts: 10,602
Default

Quote:
Originally Posted by IWannaRock View Post
Wished I found this thread before.

Sansa Fuze v2 purchased from FutureShop 09/03/10. Serial #B/1008CBNK-8GB, firmware 33A. Can't downgrade firmware, can't rockbox.

I thought I'd buy one of these while I could since I saw there is a new Fuze+ on the way and didn't want to wait for a rockbox version for it (or risk rockbox never working on the + at all...damn irony!).

With the new Fuze+ on the way I'm not optimistic this seemingly difficult problem will be solved for such relativity few units, but I'll check here every once and a while just in case.

I guess I could return the Fuze, but I think I'll keep it anyway since it plays flac and has more storage than my other DAP...still I really wanted to rock.

Regardless, Sandisk has lost me as a customer and I wouldn't recommend anyone purchase any Fuze v2 or Fuze+.
The problem was solved, I think....and people are rockboxing even their newer Fuzes. Take a look here, I think the instructions you need are there.http://www.rockbox.org/wiki/SansaAMS
__________________
iPod Touch 5G 32GB, Touch 4G 32GB, Clip Sport 8GB. Rockbox-> Clip Zip 4GB, iPod Nano 2G 4GB, iPod 5.5G 80GB
2012 Nexus 7 32GB, Asus MeMoPad 8 16+64GB, LG Optimus G Pro, Nokia Lumia 900 and Lumia 520
Reply With Quote

  #19  
Old 09-13-2010, 02:28 AM
Xinz Xinz is offline
Member
 
Join Date: Nov 2009
Location: Singapore
Posts: 336
Default

I got one Fuze v2 and rockboxed it last month the moment I opened it, its working
__________________
I have my C2!!!
Reply With Quote

  #20  
Old 09-13-2010, 05:28 AM
rickysio's Avatar
rickysio rickysio is offline
Ultra Senior Member
 
Join Date: Jul 2010
Location: Singapore
Posts: 1,074
Default

I got one a week ago and just dropped RB on it, and it worked. I think they've fixed it already.
__________________
Current Rig : SanDisk Sansa Clip+ 8GB Black | Sansa Fuze v2 2GB + 8GB | Hippo VB | Panasonic HJE900 | N900 32GB + 16GB
Graveyard :
FutureSonics Atrio | Cowon D2 16GB Black + 16GB SDHC | SoundMAGIC PL30 | Koss PortaPro | iPod Touch 2G 8GB

Last edited by rickysio; 09-13-2010 at 05:35 AM.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:33 AM.