android
  #1  
Old 07-15-2010, 11:16 PM
dougm dougm is offline
Junior Member
 
Join Date: Jul 2010
Posts: 3
Default smoked my e280

Ok, it was my own fault, I was designing a custom usb charger and I swapped polarity accidentally and heard a heart-stopping little popping sound when I plugged the sansa in as a test.

The interesting thing is it works fine, starts, runs, everything, except it won't charge the battery anymore.

My hope is that I just blew the LiIon charging chip and if I swap that chip I'll be back in business. So I'm wondering if any of you know which chip is the charging chip? Of the chips I could identify none of them seem to be the charging chip.

Any other ideas are welcome.

Thanks,

DougM
Reply With Quote

Advertisement [Remove Advertisement]

  #2  
Old 07-16-2010, 02:45 PM
carpenter940 carpenter940 is offline
Member
 
Join Date: Aug 2007
Posts: 347
Default

I don't know the answer to this but I do have a sansa that doesn't charge the battery and I'm interested in the answer to this also.
__________________
My Themes:
dancing cat Miss LED BECScope Mickey Heavy Metal
Reply With Quote

  #3  
Old 07-16-2010, 03:33 PM
WalkGood's Avatar
WalkGood WalkGood is offline
Moderator
 
Join Date: Aug 2006
Location: FL
Posts: 12,579
Default

sounds like it, I'd try another battery first they're cheap.
__________________
WalkGood,
Ramón

abi >> | Forum Rules | Glossary | Why Rockbox | FLAC or MP3? | irc
Reply With Quote

  #4  
Old 07-17-2010, 10:33 AM
dougm dougm is offline
Junior Member
 
Join Date: Jul 2010
Posts: 3
Default

Carpenter940, in your case swapping the battery might fix it (are you getting the charging lightning bolt icon when you plug it in?).

In my case I tried a battery swap and it didn't help. I definitely popped a chip - but which one...

Thanks,

DougM
Reply With Quote

  #5  
Old 07-17-2010, 11:12 AM
WalkGood's Avatar
WalkGood WalkGood is offline
Moderator
 
Join Date: Aug 2006
Location: FL
Posts: 12,579
Default

Quote:
Originally Posted by dougm View Post
... In my case I tried a battery swap and it didn't help. I definitely popped a chip - but which one...
DougM, this link on hardware components might be helpful if you can't find an answer there you might want to ask in #rockbox irc channel.
__________________
WalkGood,
Ramón

abi >> | Forum Rules | Glossary | Why Rockbox | FLAC or MP3? | irc
Reply With Quote

  #6  
Old 07-18-2010, 10:47 PM
dougm dougm is offline
Junior Member
 
Join Date: Jul 2010
Posts: 3
Default

Thanks Ramon, I checked the link and it only shows the major chips - I'll have to learn how to IRC (how embarrassing, considering my age) before I go on the channel.

I did manage to pick up a fuze on eBay for pretty cheap, so for the most part the problem has been solved. I'll still work on it, but as an academic exercise.

Thanks everyone for your help!
Reply With Quote

  #7  
Old 07-19-2010, 01:49 AM
skip252 skip252 is offline
Administrator
 
Join Date: Dec 2007
Location: Chicago
Posts: 5,277
Default

Here's Link to the Rockbox WIKI page about which chip handles the charging . It says that the chip is the same on the c2xx and e2xx v1 Sansas.

Heres a link to ABI's teardown of the c200 showing the chips. The bottom picture seems to show the chip dougm is looking for.
Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 01:20 PM.