android
  #821  
Old 07-24-2012, 07:11 PM
alito alito is offline
Junior Member
 
Join Date: Oct 2010
Posts: 48
Default

Quote:
Originally Posted by lebellium View Post
Good news for you guys
I tried a normal upgrade from fw 2.30 to this LRv3.5c1 fw...
It worked OK for me, too.
Just three comments about the new fw.

1. Safe mode screen shows version 2.20 of the modded software. Is it an intended step back or just a glitch...

2. When disconnecting USB after safe mode the R0 does not turn off, I had to use the reset button. It was more convenient before. I also use safe-mode a lot, mainly to copy music.

3. Finally, any instructions to roll back to 2.30 (just in case)

Thanks a lot lebellium and all the team!

Last edited by alito; 07-24-2012 at 07:52 PM.
Reply With Quote

Advertisement [Remove Advertisement]

  #822  
Old 07-24-2012, 07:18 PM
alito alito is offline
Junior Member
 
Join Date: Oct 2010
Posts: 48
Default

Follows my previous post:
I have noticed that the strange click-pop sounds when changing tracks is still present in files stored in flash. NOT with those in the SD card. EDIT: Only with wma, not mp3 or ape or flac, and BOTH in flash and SD card.

Also, I suspect shutdown is a tad slower (not that it really matters).

Thanks again

ps: the sounds seem to be part of the track, a really very short one, not electrostatic clicking or popping or hissing. Tried it with a Bach record, where every track was in a different key, and so were the sounds! Upon further research, repetition of a short fragment of the track is most likely.

Last edited by alito; 07-24-2012 at 07:37 PM.
Reply With Quote

  #823  
Old 07-25-2012, 03:36 AM
VanniX VanniX is offline
Member
 
Join Date: Nov 2011
Location: Italy - Clowns country
Posts: 120
Default

@alito:
1) I used a modded version of lorenzo safe mode. In the final release i add the shutdown and all other features of modfirm 2.30. See my last post: http://anythingbutipod.com/forum/sho...&postcount=820

2) Read point 1

3) Copy R0.ROM in nand and reboot

If you send me a track i can try to correct the bug (if it's really a bug).
Reply With Quote

  #824  
Old 07-25-2012, 04:38 AM
Martus0 Martus0 is offline
Junior Member
 
Join Date: Apr 2012
Posts: 51
Default

Just flashed final version and everything seems to be fine, didn't encounter any strange sound so far. I have different question, have you noticed that rockbox at max volume is quieter than OF at max volume, is there any way to change (fix) it?
Reply With Quote

  #825  
Old 07-25-2012, 05:29 AM
alito alito is offline
Junior Member
 
Join Date: Oct 2010
Posts: 48
Default

Quote:
Originally Posted by VanniX View Post
@alito:
1) I used a modded version of lorenzo safe mode. In the final release i add the shutdown and all other features of modfirm 2.30. See my last post: http://anythingbutipod.com/forum/sho...&postcount=820
2) Read point 1
3) Copy R0.ROM in nand and reboot
If you send me a track i can try to correct the bug (if it's really a bug).
Thanks a lot VanniX.

I followed your instructions and all is good. However, the safe mode screen still shows v. 2.20 (not 2.30). Should it be this way? Is there a place to check what ROM version is installed?

The short sound after manually changing WMA tracks (SD and NAND) is still present, not when tracks change automatically (shuffle on/off).

Also, I think the volume seems to be higher now again.

Finally, I have a question regarding the sys.cfg file. Are ther any instructions/ regarding the part "Autoexec script in /mnt/mmc/autoexec at startup"?

Thanks again and looking foward to your updates.
Reply With Quote

  #826  
Old 07-25-2012, 05:59 AM
VanniX VanniX is offline
Member
 
Join Date: Nov 2011
Location: Italy - Clowns country
Posts: 120
Default

@Martus0:
For max volume you should ask to rockbox dev. However you can increase "Master" volume in alsa server. You can edit "rockbox_loader.sh" in your neoghost partition. Find the alsa config lines and try to edit it (if you set 100% audio output can be very biased).


@alito
The safe mode screen is only an image. I copied it from last lorenzo's firmware.
You can check version in the header of .ROM file that you have flashed. However in final version there isn't mods dir in etc (you can check with rockbox file manager)

For autoexec you can simply put your personal script in your mmc card (microsd) in a dir called "autoexec". Now if you enable this feature your script will run at startup.
This feature is similar than the other created in the first modified firmware.

If you send me your wma track i can test them.
Reply With Quote

  #827  
Old 07-25-2012, 06:42 AM
alito alito is offline
Junior Member
 
Join Date: Oct 2010
Posts: 48
Default

VanniX
thanks for your answer. I was wondering if the ROM version could be checked within the R0.

What language should the scripts be written? ...LUA?

As for the WMA files, most of mine are encoded with Quintessential or dBpoweramp. i am uploading a couple of them with different bitrate, so you can check changing tracks (https://rapidshare.com/files/566351741/wma tracks.rar).

Thanks again
Reply With Quote

  #828  
Old 07-25-2012, 08:45 AM
Mr.Frost Mr.Frost is offline
Junior Member
 
Join Date: Sep 2010
Posts: 16
Default

Hm, for some reason I can't copy practically anything to my R0 when I boot into safe mod.
After 30-60s the player just disconnects from my computer O_o Tryed both Linux and Win7.
Reply With Quote

  #829  
Old 07-25-2012, 08:48 AM
alito alito is offline
Junior Member
 
Join Date: Oct 2010
Posts: 48
Default

Mr.Frost,
I had the same issue, for some days; it was a pain when copying large music folders. But I blamed my USB connection (my daughter's BlackBerry phone wouldn't hold the connection also). I changed to another USB port, and so far it is working ok. It stays on until I disconnect it.
Reply With Quote

  #830  
Old 07-25-2012, 08:53 AM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,597
Default

Indeed, we are aware of that annoying issue.
VanniX will investigate it and release a new ROM tonight.
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*
Reply With Quote

  #831  
Old 07-25-2012, 09:00 AM
Mr.Frost Mr.Frost is offline
Junior Member
 
Join Date: Sep 2010
Posts: 16
Default

@alito,
My phone (Also from Samsung) keeps the connection till I disconnect it. But R0 not.
And yes, I noticed that the shutdown on this firmware takes much longer time than in the 2.30, too.
I measured start up and shutdown times and got 8 s for start up and 6 s for shutdown. On 2.30 it took a second or two for shutdown.
@Vannix,
I drawn an image for Safe mode, it looks simple and clear. If you like it please use it for Safe mode screen.
Attached Images
File Type: png Safe Mode 2.png (11.7 KB, 14 views)

Last edited by Mr.Frost; 07-25-2012 at 01:06 PM.
Reply With Quote

  #832  
Old 07-25-2012, 05:53 PM
VanniX VanniX is offline
Member
 
Join Date: Nov 2011
Location: Italy - Clowns country
Posts: 120
Default

@alito
@Mr.Frost
@lebellium
@all_other..

I updated this post:
http://anythingbutipod.com/forum/sho...&postcount=820

Important news:
Fixed safe mode (more than 1hour of test - no problems found)
Added auto enter in safe mode when player is off and you connect to pc (this option is also selectable in sys.cfg file).
Reply With Quote

  #833  
Old 07-25-2012, 06:23 PM
alito alito is offline
Junior Member
 
Join Date: Oct 2010
Posts: 48
Default

Well, it worked like a charm.

Auto enter in safe mode is so convenient (alt least, until USB is 100% operative). However, it does not auto-off when disconnected (but it re-connects to PC if you plug the USB connector again which I think did not occur before--and I did try it!).

Great work everybody!
Reply With Quote

  #834  
Old 07-25-2012, 07:18 PM
acus acus is offline
Junior Member
 
Join Date: Apr 2009
Location: italy
Posts: 6
Default

After flashing with new LightROM 4.1,
I can confirm that it does not auto-off when disconnected from your PC, you must switch-off it manually.
Anyway, Rockbox is much faster!! Congratulations.

Regards
Reply With Quote

  #835  
Old 07-25-2012, 07:50 PM
lebellium's Avatar
lebellium lebellium is offline
Samsung Moderator
 
Join Date: Sep 2007
Location: Paris
Posts: 3,597
Default

Ok it seems to work well, thanks VanniX

@alito and acus: it is normal the auto-shutdown in Safe Mode doesn't work anymore as we had to revert-back to the Safe Mode of fw 2.20. Safe Mode of fw 2.30 is unfortunately too unstable.
USB stability is more important than the autoshutdown. Of course, both together would be better...maybe in a next version
__________________
I'm French^^ *GenerationMP3 Samsung Moderator*

Last edited by lebellium; 07-25-2012 at 07:56 PM.
Reply With Quote

  #836  
Old 07-26-2012, 02:13 AM
Predelnik Predelnik is offline
Junior Member
 
Join Date: Oct 2011
Location: Russia, Moscow
Posts: 59
Default

Ok maybe i'll try this build tonight too, though auto-off would be very nice, but anyway when i was using OF for connecting, there was library updating after each disconnect and that was taking a lot of time.
Reply With Quote

  #837  
Old 07-26-2012, 06:43 AM
VanniX VanniX is offline
Member
 
Join Date: Nov 2011
Location: Italy - Clowns country
Posts: 120
Default

At the moment auto shutdown can't be added in safe mode, for auto shutdown i must add a check that lead to the crash of storage module.
So, as lebellium said, and considering that safe mode is the only way to connect r0 to pc, we prefer a "stable" safe mode instead of a "cool" safe mode.
For shutdown you must hold power for 10 sec or push the reset button.

@Mr.Frost:
Thank you for the img, but we prefer to use the same logo for all roms. Changing, when necessary, only the rom name. We can better organize and release new roms faster.

Thank you all for using this LightROM
Reply With Quote

  #838  
Old 07-26-2012, 08:32 AM
alito alito is offline
Junior Member
 
Join Date: Oct 2010
Posts: 48
Default

Quote:
Originally Posted by lebellium View Post
It is normal the auto-shutdown in Safe Mode doesn't work anymore as we had to revert-back to the Safe Mode of fw 2.20. Safe Mode of fw 2.30 is unfortunately too unstable.
USB stability is more important than the autoshutdown. Of course, both together would be better...maybe in a next version
I totally agree. At least, pressing the power button for 10 seconds is more convenient than prodding the reset button!!

Thanks again.
Reply With Quote

  #839  
Old 07-26-2012, 01:51 PM
Appick's Avatar
Appick Appick is offline
Junior Member
 
Join Date: Mar 2011
Location: France
Posts: 83
Default

Excellent, thanks.
I still get the "cracking" noise when I advance a track or change songs with Flac, Mp3 and WMA. But the rest seems great. Faster and auto safe mode on PC. Brill'
__________________
Appick
Reply With Quote

  #840  
Old 07-26-2012, 02:31 PM
VanniX VanniX is offline
Member
 
Join Date: Nov 2011
Location: Italy - Clowns country
Posts: 120
Default

wtf.. I can't hear that ""cracking noise"". I also tried alito's wma track, but i can't hear anything strange.. :S
Reply With Quote

Reply

Tags
r0, rockbox, samsung yp-r0

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:04 AM.